Bug 440055 - Can't unlock the screen if the user has an empty password
Summary: Can't unlock the screen if the user has an empty password
Status: RESOLVED FIXED
Alias: None
Product: kscreenlocker
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other FreeBSD
: VHI critical
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 440344 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-07-20 03:08 UTC by Graham Perrin
Modified: 2022-05-18 14:17 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-07-20 03:08:12 UTC
SUMMARY

I guess, the logic here should be to not allow locking where there's no password. 

STEPS TO REPRODUCE

1. Log in as a user with an empty password
2. after a while, find the screen locked
3. attempt to unlock without entering a password

OBSERVED RESULT

4. the screen remains locked

EXPECTED RESULT

4. unlock

SOFTWARE/OS VERSIONS

% pkg info -x kscreenlock
plasma5-kscreenlocker-5.22.3_1
% 

Operating System: FreeBSD 14.0
KDE Plasma Version: 5.22.3
KDE Frameworks Version: 5.83.0
Qt Version: 5.15.2
Kernel Version: 14.0-CURRENT (64-bit)
Graphics Platform: X11
Memory: 15.9 GiB of RAM
Graphics Processor: AMD TURKS

ADDITIONAL INFORMATION
Comment 1 David Redondo 2021-07-28 06:49:42 UTC
*** Bug 440344 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2021-08-05 01:03:52 UTC
Eek. Can confirm.
Comment 3 Graham Perrin 2021-08-30 05:26:10 UTC
Does SDDM have an impact?

For example: 

Passwordless Login · Issue #751 · sddm/sddm
<https://github.com/sddm/sddm/issues/751>
Comment 4 David Edmundson 2022-05-14 18:59:57 UTC
The behaviour is now changed - but not perfect (hence leaving this open) it now unlocks immediately on resume from the "screensaver" mode.
Comment 5 David Edmundson 2022-05-18 11:17:02 UTC
Git commit dc6341bb3073ebe0beb945018cc7bb67ee2dd828 by David Edmundson.
Committed on 18/05/2022 at 11:09.
Pushed by davidedmundson into branch 'master'.

Add an explicit unlock button for passwordless users

In the refactor we correctly made it so passwordless users were not
prompted for passwords.

This is in the right direction but the UX was still slightly off as it
meant wiggling the mouse unlocked the screen, not an explicit action.

This patch adds an explicit button that must be pressed if no other
prompts were given during the authentication process.

M  +10   -1    lookandfeel/contents/lockscreen/LockScreenUi.qml
A  +23   -0    lookandfeel/contents/lockscreen/NoPasswordUnlock.qml     [License: GPL(v2.0+)]

https://invent.kde.org/plasma/plasma-workspace/commit/dc6341bb3073ebe0beb945018cc7bb67ee2dd828