Bug 456639 - "Unlock" button on lockscreen after entering correct password
Summary: "Unlock" button on lockscreen after entering correct password
Status: RESOLVED FIXED
Alias: None
Product: kscreenlocker
Classification: Plasma
Component: greeter (show other bugs)
Version: 5.25.3
Platform: Arch Linux Linux
: VHI normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 456656 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-07-12 16:26 UTC by 80p3fy75dc
Modified: 2022-07-12 22:57 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.23.3.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 80p3fy75dc 2022-07-12 16:26:22 UTC
SUMMARY
After updating to 5.25.3 on Arch Linux, every time I type my user password to unlock my session, I'm now getting an additional "Unlock" button (this one: https://bugsfiles.kde.org/attachment.cgi?id=150324) and I have to either click on it or press space bar / return key to finally unlock the session.

STEPS TO REPRODUCE
1. Lock the Plasma session
2. Type [correct] user password
3. This "Unlock" button shows up every time (https://bugsfiles.kde.org/attachment.cgi?id=150324) and I have to either click on it or press space bar / return key

EXPECTED RESULT
The "Unlock" button doesn't show up and the session is unlocked immediately

SOFTWARE/OS VERSIONS
Linux/KDE Plasma:  Arch Linux
KDE Plasma Version: 5.25.3
KDE Frameworks Version: 5.96.0
Qt Version: qt5-base - 5.15.5+kde+r170-1

ADDITIONAL INFORMATION
I'm no using any other unlock method like fingerprint or face unlock, just plain password.
Comment 1 Patrick Silva 2022-07-12 17:21:06 UTC
Can reproduce on my Arch too.
Comment 2 Nate Graham 2022-07-12 17:26:01 UTC
Does this happen with a multi-monitor setup, or are you using a single-monitor setup?
Comment 3 Nate Graham 2022-07-12 17:26:50 UTC
Oh, actually this is Bug 455712.

*** This bug has been marked as a duplicate of bug 455712 ***
Comment 4 80p3fy75dc 2022-07-12 18:06:01 UTC
(In reply to Nate Graham from comment #2)
> Does this happen with a multi-monitor setup, or are you using a
> single-monitor setup?

Single monitor, sorry, forgot to mention it.
Comment 5 Nate Graham 2022-07-12 18:11:23 UTC

*** This bug has been marked as a duplicate of bug 455712 ***
Comment 6 Fabian Vogt 2022-07-12 18:19:53 UTC
Not a duplicate, this is specific to a bad cherry-pick in 5.25.3. Fixed with https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1912.
Comment 7 Fabian Vogt 2022-07-12 18:26:10 UTC
Git commit bfb47cb202784733618e53e1088e8676c2815456 by Fabian Vogt.
Committed on 12/07/2022 at 18:11.
Pushed by fvogt into branch 'Plasma/5.25'.

Fix non-functional lockscreen due to bad cherry-pick

The cherry-pick of 923ce7e5887d
("Fix password field in lock screen not clearing after failed login attempt")
introduced two assignments to properties which don't exist in 5.25 yet. This
causes execution of those blocks to abort early, resulting in a bad state,
like hadPrompt never getting set to true.

M  +0    -2    lookandfeel/contents/lockscreen/LockScreenUi.qml

https://invent.kde.org/plasma/plasma-workspace/commit/bfb47cb202784733618e53e1088e8676c2815456
Comment 8 80p3fy75dc 2022-07-12 19:12:09 UTC
(In reply to Fabian Vogt from comment #6)
> Not a duplicate, this is specific to a bad cherry-pick in 5.25.3. Fixed with
> https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1912.

Can confirmed it's fixed here on Arch Linux after updating to plasma-workspace 5.25.3.1-1.

Thanks!
Comment 9 Antonio Rojas 2022-07-12 21:03:40 UTC
*** Bug 456656 has been marked as a duplicate of this bug. ***