Bug 454937 - On Wayland, launch feedback always triggers for global-shortcut-launched apps that have `StartupNotify=false` in their desktop file
Summary: On Wayland, launch feedback always triggers for global-shortcut-launched apps...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kglobalaccel
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: VHI normal
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords: regression
: 455455 455638 455850 456124 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-06-06 17:30 UTC by Nate Graham
Modified: 2022-07-09 18:03 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2022-06-06 17:30:01 UTC
See for example Spectacle. Hit the PrintScreen key to launch it and you'll see the launch feedback animation despite having `StartupNotify=false` in its desktop file.
Comment 1 Patrick Silva 2022-06-17 13:49:49 UTC
*** Bug 455455 has been marked as a duplicate of this bug. ***
Comment 2 Patrick Silva 2022-06-20 10:02:13 UTC
*** Bug 455638 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2022-06-24 13:50:45 UTC
*** Bug 455850 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2022-06-24 13:51:46 UTC
Possibly related: Bug 455126.
Comment 5 Nate Graham 2022-06-29 16:13:43 UTC
*** Bug 456124 has been marked as a duplicate of this bug. ***
Comment 6 Bug Janitor Service 2022-06-29 19:41:11 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/2594
Comment 7 Aleix Pol 2022-07-04 16:47:19 UTC
Git commit 78d80123f1d2efbfa00733390430ce381db9c245 by Aleix Pol.
Committed on 04/07/2022 at 15:44.
Pushed by apol into branch 'master'.

xdgactivation: Properly prevent disabled activation notifications

The logic when checking the settings was wrong and it would always
notify unless both keys were actually disabled.

M  +4    -2    src/xdgactivationv1.cpp

https://invent.kde.org/plasma/kwin/commit/78d80123f1d2efbfa00733390430ce381db9c245
Comment 8 Aleix Pol 2022-07-04 16:48:40 UTC
Git commit 155b3cd4907e619e2ae0ec4feca873a213f839d0 by Aleix Pol Gonzalez, on behalf of Aleix Pol.
Committed on 04/07/2022 at 16:48.
Pushed by apol into branch 'Plasma/5.25'.

xdgactivation: Properly prevent disabled activation notifications

The logic when checking the settings was wrong and it would always
notify unless both keys were actually disabled.


(cherry picked from commit 78d80123f1d2efbfa00733390430ce381db9c245)

M  +4    -2    src/xdgactivationv1.cpp

https://invent.kde.org/plasma/kwin/commit/155b3cd4907e619e2ae0ec4feca873a213f839d0