Bug 455850 - Spectacle's "Launch Feedback" next to cursor can show up in screenshot even when cursor is hidden
Summary: Spectacle's "Launch Feedback" next to cursor can show up in screenshot even w...
Status: RESOLVED DUPLICATE of bug 454937
Alias: None
Product: Spectacle
Classification: Applications
Component: General (show other bugs)
Version: 22.04.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-23 15:04 UTC by Yao Mitachi
Modified: 2022-06-24 13:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yao Mitachi 2022-06-23 15:04:42 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. Disable "include mouse pointer"
2. Use global shortcut to launch Spectacle while, for example, a game is in fullscreen

OBSERVED RESULT

While playing Final Fantasy XIV in fullscreen using Gamescope on top of Plasma (Wayland), I took a screenshot, and ended up with a tiny Spectacle icon floating in the middle of my screenshot.

EXPECTED RESULT

If the cursor is hidden, so too should Launch Feedback.

SOFTWARE/OS VERSIONS

Linux: 5.18.5-arch1
KDE Plasma Version: 5.25.1
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5

ADDITIONAL INFORMATION

As a workaround, I have disabled Launch Feedback. Also, I am using Gamescope because without it, while moving the in-game camera around while using Plasma on Wayland, sometimes (somewhat rarely) the camera flips direction instantly; using Gamescope fixes this, and that camera issue does not happen on X11.
Comment 1 Nate Graham 2022-06-24 13:50:45 UTC
Likely related to whatever caused Bug 455126.

*** This bug has been marked as a duplicate of bug 454937 ***