Bug 454275 - WindowHeap-based effects eat every other click after clicking anywhere on a window thumbnail
Summary: WindowHeap-based effects eat every other click after clicking anywhere on a w...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-various (show other bugs)
Version: git master
Platform: Other Linux
: HI normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 451150 451450 451537 452858 453185 453997 454989 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-23 14:27 UTC by Nate Graham
Modified: 2022-06-24 18:26 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.2
nate: Wayland-
nate: X11+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2022-05-23 14:27:14 UTC
We have three KWin effects based on WindowHeap that allow interaction with window thumbnails. And each of them suffers from an identical problem in that on X11, after clicking anywhere on a window thumbnail (e.g. to close it, or drag it elsewhere), the next click on a window thumbnail gets eaten.

See Bug 453997, Bug 451150 and Bug 451450.
Comment 1 Nate Graham 2022-05-23 14:27:31 UTC
*** Bug 453997 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2022-05-23 14:27:40 UTC
*** Bug 451150 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2022-05-23 14:27:45 UTC
*** Bug 451537 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2022-05-23 14:28:01 UTC
*** Bug 451450 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2022-05-23 14:28:05 UTC
*** Bug 453185 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2022-05-23 14:28:10 UTC
*** Bug 452858 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2022-06-08 19:00:16 UTC
*** Bug 454989 has been marked as a duplicate of this bug. ***
Comment 8 Bug Janitor Service 2022-06-24 15:04:39 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/2576
Comment 9 Nate Graham 2022-06-24 17:55:09 UTC
Git commit 66a54d38d4dfe231980dfa1e4393d62f3c559df1 by Nate Graham, on behalf of Marco Martin.
Committed on 24/06/2022 at 17:54.
Pushed by ngraham into branch 'master'.

effects: Set timestamp for input events

Set the time for mouse and touch events. This is especially important
for the mouse is as the timestamp will be used to discriminate between
single and double click. Previously this was always sending the double
click event, making buttons work only every other click.
Related: bug 449907

M  +3    -0    src/backends/x11/standalone/effects_mouse_interception_x11_filter.cpp
M  +1    -2    src/libkwineffects/kwinoffscreenquickview.cpp

https://invent.kde.org/plasma/kwin/commit/66a54d38d4dfe231980dfa1e4393d62f3c559df1
Comment 10 Nate Graham 2022-06-24 17:55:37 UTC
Git commit e6ae8fb6755398d3512863c7de6493360962118e by Nate Graham, on behalf of Marco Martin.
Committed on 24/06/2022 at 17:55.
Pushed by ngraham into branch 'Plasma/5.25'.

effects: Set timestamp for input events

Set the time for mouse and touch events. This is especially important
for the mouse is as the timestamp will be used to discriminate between
single and double click. Previously this was always sending the double
click event, making buttons work only every other click.
Related: bug 449907


(cherry picked from commit 66a54d38d4dfe231980dfa1e4393d62f3c559df1)

M  +3    -0    src/backends/x11/standalone/effects_mouse_interception_x11_filter.cpp
M  +1    -2    src/libkwineffects/kwinoffscreenquickview.cpp

https://invent.kde.org/plasma/kwin/commit/e6ae8fb6755398d3512863c7de6493360962118e