Bug 449166 - Dragging items in Dolphin makes them look shaky when using Breeze cursors
Summary: Dragging items in Dolphin makes them look shaky when using Breeze cursors
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: wayland
: 449932 451052 453276 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-25 18:36 UTC by Matej Mrenica
Modified: 2022-05-16 13:31 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: https://invent.kde.org/plasma/kwin/-/commit/a47f18d8a25be65ad825fd653ee12f9d4f5a28a4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matej Mrenica 2022-01-25 18:36:35 UTC
SUMMARY
While dragging a file/folder inside Dolphin this item jumps up and down slightly. Also mouse cursor quickly changes from normal to "hand".
Comment 1 Nate Graham 2022-01-25 21:44:47 UTC
Cannot reproduce with current git master.

Could you use OBS to take a screen recording that shows the issue?
Comment 2 Matej Mrenica 2022-01-26 08:50:50 UTC
Here's a video made with my phone because OBS has issues: https://gfycat.com/scholarlydrearyerin

About those issues:
1. Dragged items are not visible when using either Screen capture or windows capture.
2. Only maximized windows show properly in OBS, windows of any other size show partially or fully as garbage. 

Are these KDE issues or OBS issues?
Comment 3 Patrick Silva 2022-01-26 10:31:06 UTC
Can reproduce on Arch (Plasma 5.24 beta) and neon unstable. I can't record the bug on neon unstable due to bug 448841, and OBS Studio is unable to record my screen on Arch due to bug 448423.
Comment 4 Nate Graham 2022-01-26 15:51:38 UTC
Weird!

Does it happen only in Dolphin, or on the desktop too? How about in open/save dialogs?
Comment 5 Matej Mrenica 2022-01-26 16:19:07 UTC
Not on Desktop but yes in dialogs.
Comment 6 Matej Mrenica 2022-01-26 16:21:35 UTC
To clarify, It doesn't looks the same in dialogs, but there is an issue there too.
Comment 7 Nate Graham 2022-01-27 18:47:24 UTC
Thanks. Is this on Wayland, or X11?
Comment 8 Matej Mrenica 2022-01-27 18:48:14 UTC
(In reply to Nate Graham from comment #7)
> Thanks. Is this on Wayland, or X11?

This is Wayland.
Comment 9 Nate Graham 2022-01-27 18:56:27 UTC
Thanks.
Comment 10 corey 2022-02-10 13:40:54 UTC
*** Bug 449932 has been marked as a duplicate of this bug. ***
Comment 11 corey 2022-02-10 13:41:36 UTC
(In reply to corey from comment #10)
> *** Bug 449932 has been marked as a duplicate of this bug. ***

I'm also experiencing this. I created a bug report, but just saw this one here.

AMD and Intel GPU, Wayland.
Comment 12 Prajna Sariputra 2022-02-15 06:58:49 UTC
I can also reproduce this issue with Dolphin 21.12.2.

Operating System: Arch Linux
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.9-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 530
Comment 13 Patrick Silva 2022-03-03 20:00:16 UTC
*** Bug 451052 has been marked as a duplicate of this bug. ***
Comment 14 Michael D 2022-03-04 16:26:38 UTC
This happens in more than just dolphin (e.. Juk) so probably should be filed under kwin, non?
Comment 15 Thiago Sueto 2022-03-13 01:09:17 UTC
(In reply to Michael D from comment #14)
> This happens in more than just dolphin (e.. Juk) so probably should be filed
> under kwin, non?

I think so. This happens in the Save As... that appears after pressing Ctrl+S in Firefox (as people mentioned already), and it happens in Pcmanfm-qt to a lesser extent. It doesn't happen on Nautilus, although there's some slight jerkyness there as well (might not be related).

Me and other 3 users over KDE Brasil can confirm this shaky dragging in Dolphin, so marking this as confirmed.
Comment 16 Patrick Silva 2022-05-02 11:33:23 UTC
*** Bug 453276 has been marked as a duplicate of this bug. ***
Comment 17 Jacob 2022-05-07 19:36:25 UTC
I have found that if i move the file over the tabs bar area (must have at least 1 tab open), not the tabs themselves and back to the file area it stops and the cursor stays as "drag and drop" instead of flickering and jittering between "dragging hand" and "drag and drop". 
Also I have found that dragging a file from the places panel to the file area can cause it to hand for a little bit.

This happens on both of my systems; desktop and laptop, both on Wayland with mesa, laptop is a fresh arch install.
Comment 18 Patrick Silva 2022-05-13 12:13:04 UTC
No longer reproducible on neon unstable.
Comment 19 Nate Graham 2022-05-13 12:46:19 UTC
Curiously enough, I can still reproduce it. Wayland, git master.
Comment 20 Patrick Silva 2022-05-13 13:02:49 UTC
ops, I can't reproduce with a third-party cursor theme called Radioactive but I can with Breeze.
Comment 21 Nate Graham 2022-05-13 14:01:42 UTC
Can reproduce that a non-Breeze cursor works. How odd.
Comment 22 Michael D 2022-05-13 20:22:03 UTC
Same--the bug disappears using Adwaita cursors. However, I do get other weird fliggering from drag n' drop with non-Breeze cursors: sometimes when I drag a file to a folder (e.g. trash) in Places it causes flickering outside of the window near the Places folder I dragged to. Not always reproducible, but not hard to reproduce.
Comment 23 Michael D 2022-05-13 20:23:13 UTC
"fliggering" = "flickering"
Comment 24 Vlad Zahorodnii 2022-05-16 13:31:53 UTC
The fix will be also available in 5.24.6 https://invent.kde.org/plasma/kwayland-server/-/merge_requests/375