Bug 448857 - Plasma Crashed when unmounting usb with 2 partitions
Summary: Plasma Crashed when unmounting usb with 2 partitions
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.5
Platform: openSUSE RPMs Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-01-20 22:56 UTC by news.group
Modified: 2022-01-21 23:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description news.group 2022-01-20 22:56:39 UTC
Application: plasmashell (5.23.5)

Qt Version: 5.15.2
Frameworks Version: 5.90.0
Operating System: Linux 5.16.0-1-default x86_64
Windowing System: X11
Distribution: openSUSE Tumbleweed
DrKonqi: 5.23.5 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
I unmounted both partitions on the one usb drive, at the point of unmounting the second partition, Plasma crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  std::__atomic_base<QThreadData*>::load (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/11/bits/atomic_base.h:836
#7  std::atomic<QThreadData*>::load (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/11/atomic:570
#8  QAtomicOps<QThreadData*>::loadRelaxed<QThreadData*> (_q_value=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/qt5/QtCore/qatomic_cxx11.h:239
#9  QBasicAtomicPointer<QThreadData>::loadRelaxed (this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/qt5/QtCore/qbasicatomic.h:248
#10 QQmlNotifierEndpoint::connect (this=this@entry=0x558387ded5d0, source=0x55838d40f980, sourceSignal=47, engine=0x0, doNotify=doNotify@entry=true) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.4.x86_64/src/qml/qml/qqmlnotifier.cpp:122
#11 0x00007f1de0863645 in QQmlVMEMetaObjectEndpoint::tryConnect (this=0x558387ded5d0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.4.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:258
#12 0x00007f1de08638ed in QQmlVMEMetaObject::connectAlias (this=this@entry=0x55838d528420, aliasId=aliasId@entry=1) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.4.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:1294
#13 0x00007f1de0864ee9 in QQmlVMEMetaObject::metaCall (this=0x55838d528420, o=<optimized out>, c=QMetaObject::ReadProperty, _id=<optimized out>, a=0x7ffed11fe300) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.4.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:906
#14 0x00007f1de0798f7d in QQmlPropertyData::readProperty (property=0x7ffed11fe2e0, target=<optimized out>, this=0x7f1db492d2b8) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#15 loadProperty (v4=0x558385eab0b0, object=0x55838d5281d0, property=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde36-1.4.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:152
#16 0x00007f1d7934aa53 in ?? ()
#17 0x0000000000000000 in ?? ()
[Inferior 1 (process 3877) detached]

The reporter indicates this bug may be a duplicate of or related to bug 446248.

Possible duplicates by query: bug 446248, bug 445231, bug 445114, bug 444352, bug 442475.

Reported using DrKonqi
Comment 1 news.group 2022-01-21 19:33:47 UTC
The usb drive that causes Plasma to crash was formatted by Ventoy, specifically using GPT partition style.  In this format both partitions are mounted and Plasma crashes when both partitions are unmounted.
I have reformatted the drive using Ventoy, but this time with a MBR partition style.  In this format only one partition is mounted and no issues when it is unmounted.

I have added fdisk output for both the GPT & MBR partition styles, in case this is helpful.

Disk /dev/sdd: 112.64 GiB, 120945901568 bytes, 236222464 sectors
Disk model: Transcend 128GB 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 479AE6A6-4773-B477-23F1-A882B0936453

Device         Start       End   Sectors   Size Type
/dev/sdd1       2048 236154879 236152832 112.6G Microsoft basic data
/dev/sdd2  236156888 236222423     65536    32M Microsoft basic data


Disk /dev/sdd: 112.64 GiB, 120945901568 bytes, 236222464 sectors
Disk model: Transcend 128GB 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x79089258

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sdd1  *         2048 236156927 236154880 112.6G  7 HPFS/NTFS/exFAT
/dev/sdd2       236156928 236222463     65536    32M ef EFI (FAT-12/16/32)
Comment 2 Fushan Wen 2022-01-21 23:54:07 UTC
It's fixed in 5.24. Please test again after updating Plasma and reopen if the bug still persists.

*** This bug has been marked as a duplicate of bug 427945 ***