Bug 442475 - Plasma crashed after unplugging USB memory stick
Summary: Plasma crashed after unplugging USB memory stick
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: generic-crash (show other bugs)
Version: 5.22.5
Platform: Ubuntu Packages Linux
: NOR crash
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-09-15 11:39 UTC by niluxv.opensource.C-h2ty6xl
Modified: 2021-10-25 21:43 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.20 KB, text/plain)
2021-09-22 16:50 UTC, Łukasz Konieczny
Details
New crash information added by DrKonqi (32.21 KB, text/plain)
2021-10-17 12:47 UTC, lilian.lobry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description niluxv.opensource.C-h2ty6xl 2021-09-15 11:39:06 UTC
Application: plasmashell (5.22.5)

Qt Version: 5.15.2
Frameworks Version: 5.86.0
Operating System: Linux 5.11.0-35-generic x86_64
Windowing System: X11
Drkonqi Version: 5.22.5
Distribution: Ubuntu 21.04

-- Information about the crash:
- What I was doing when the application crashed:
I unplugged a USB memory stick after dismounting it using the "safely remove" button.

- Unusual behavior I noticed:
Desktop background went black for a second or so and panel disappeared and reappeared.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault

[KCrash Handler]
#4  std::__atomic_base<QThreadData*>::load (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/10/bits/atomic_base.h:741
#5  std::atomic<QThreadData*>::load (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/10/atomic:523
#6  QAtomicOps<QThreadData*>::loadRelaxed<QThreadData*> (_q_value=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qatomic_cxx11.h:239
#7  QBasicAtomicPointer<QThreadData>::loadRelaxed (this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qbasicatomic.h:248
#8  QQmlNotifierEndpoint::connect (this=this@entry=0x55dd946d0140, source=0x55dd90684340, sourceSignal=46, engine=0x0, doNotify=doNotify@entry=true) at qml/qqmlnotifier.cpp:122
#9  0x00007ff47defe274 in QQmlVMEMetaObjectEndpoint::tryConnect (this=0x55dd946d0140) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:266
#10 0x00007ff47defe51d in QQmlVMEMetaObject::connectAlias (this=<optimized out>, aliasId=<optimized out>) at qml/qqmlvmemetaobject.cpp:1294
#11 0x00007ff47deffa3d in QQmlVMEMetaObject::metaCall (this=0x55dd904fb860, o=<optimized out>, c=QMetaObject::ReadProperty, _id=<optimized out>, a=0x7ffcfe187390) at qml/qqmlvmemetaobject.cpp:906
#12 0x00007ff47de36c0c in QQmlPropertyData::readPropertyWithArgs (this=<optimized out>, this=<optimized out>, args=0x7ffcfe187390, target=0x55dd93936920) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:367
#13 QQmlPropertyData::readPropertyWithArgs (args=0x7ffcfe187390, target=0x55dd93936920, this=0x7ff464b300f8) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:360
#14 QQmlPropertyData::readProperty (property=0x7ffcfe187370, target=0x55dd93936920, this=0x7ff464b300f8) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#15 loadProperty (v4=0x55dd8ea5b1b0, object=0x55dd93936920, property=...) at jsruntime/qv4qobjectwrapper.cpp:152
#16 0x00007ff44a9c9773 in ?? ()
#17 0x0000000000000000 in ?? ()
[Inferior 1 (process 2049) detached]

The reporter indicates this bug may be a duplicate of or related to bug 427945.

Possible duplicates by query: bug 441365, bug 439498, bug 430431, bug 427945, bug 422533.

Reported using DrKonqi
Comment 1 Łukasz Konieczny 2021-09-22 16:50:16 UTC
Created attachment 141797 [details]
New crash information added by DrKonqi

plasmashell (5.22.5) using Qt 5.15.2

- What I was doing when the application crashed:
I unplugged pendrive from computer using external drives applet.

-- Backtrace (Reduced):
#6  std::__atomic_base<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/10/bits/atomic_base.h:741
#7  std::atomic<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/10/atomic:523
#8  QAtomicOps<QThreadData*>::loadRelaxed<QThreadData*>(std::atomic<QThreadData*> const&) (_q_value=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qatomic_cxx11.h:239
#9  QBasicAtomicPointer<QThreadData>::loadRelaxed() const (this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qbasicatomic.h:248
#10 QQmlNotifierEndpoint::connect(QObject*, int, QQmlEngine*, bool) (this=this@entry=0x56544ba586e0, source=0x56544d0618e0, sourceSignal=46, engine=0x0, doNotify=doNotify@entry=true) at qml/qqmlnotifier.cpp:122
Comment 2 niluxv.opensource.C-h2ty6xl 2021-09-30 09:15:33 UTC
It seems like it happens only when the USB stick is removed immediately upon the "The device can now be safely removed" message, and not when there is a larger pause between these events.
Comment 3 lilian.lobry 2021-10-17 12:47:46 UTC
Created attachment 142529 [details]
New crash information added by DrKonqi

plasmashell (5.23.0) using Qt 5.15.3

- What I was doing when the application crashed:
I unmounted my external hard drive via the menu bar and then unplugged it, causing Plasma to crash.

-- Backtrace (Reduced):
#4  std::__atomic_base<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/9/bits/atomic_base.h:734
#5  std::atomic<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/9/atomic:519
#6  QAtomicOps<QThreadData*>::loadRelaxed<QThreadData*>(std::atomic<QThreadData*> const&) (_q_value=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qatomic_cxx11.h:239
#7  QBasicAtomicPointer<QThreadData>::loadRelaxed() const (this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qbasicatomic.h:248
#8  QQmlNotifierEndpoint::connect(QObject*, int, QQmlEngine*, bool) (this=this@entry=0x557a15850410, source=0x7f4b643c5a70, sourceSignal=46, engine=0x0, doNotify=doNotify@entry=true) at qml/qqmlnotifier.cpp:122
Comment 4 Tony 2021-10-25 21:42:06 UTC
*** Bug 444352 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2021-10-25 21:43:47 UTC

*** This bug has been marked as a duplicate of bug 427945 ***