Bug 444352 - Plasma crashed after clicking on the "Safely remove drive".
Summary: Plasma crashed after clicking on the "Safely remove drive".
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.0
Platform: openSUSE RPMs Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-10-25 01:23 UTC by Aleksandar Dezelin
Modified: 2021-10-25 21:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksandar Dezelin 2021-10-25 01:23:18 UTC
Application: plasmashell (5.23.0)

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.11-2-default x86_64
Windowing System: X11
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.23.0 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:

I right-clicked on the flash drive in Dolphin and selected "Safely remove" from the pop-up menu.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  std::__atomic_base<QThreadData*>::load (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/11/bits/atomic_base.h:836
#7  std::atomic<QThreadData*>::load (__m=std::memory_order_relaxed, this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/c++/11/atomic:570
#8  QAtomicOps<QThreadData*>::loadRelaxed<QThreadData*> (_q_value=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/qt5/QtCore/qatomic_cxx11.h:239
#9  QBasicAtomicPointer<QThreadData>::loadRelaxed (this=<error reading variable: Cannot access memory at address 0x8>) at /usr/include/qt5/QtCore/qbasicatomic.h:248
#10 QQmlNotifierEndpoint::connect (this=this@entry=0x55d841e7d3b0, source=0x55d848b2a1d0, sourceSignal=46, engine=0x0, doNotify=doNotify@entry=true) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qml/qml/qqmlnotifier.cpp:122
#11 0x00007ff7b4d13405 in QQmlVMEMetaObjectEndpoint::tryConnect (this=0x55d841e7d3b0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:258
#12 0x00007ff7b4d136a8 in QQmlVMEMetaObject::connectAlias (this=this@entry=0x55d847940730, aliasId=aliasId@entry=1) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:1294
#13 0x00007ff7b4d14c99 in QQmlVMEMetaObject::metaCall (this=0x55d847940730, o=<optimized out>, c=QMetaObject::ReadProperty, _id=<optimized out>, a=0x7ffc8ecfd1d0) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qml/qml/qqmlvmemetaobject.cpp:906
#14 0x00007ff7b4c48edd in QQmlPropertyData::readProperty (property=0x7ffc8ecfd1b0, target=<optimized out>, this=0x7ff78c9000b8) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#15 loadProperty (v4=0x55d8413eca20, object=0x55d848946e10, property=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:152
#16 0x00007ff7894922d3 in ?? ()
#17 0x0000000000000000 in ?? ()
[Inferior 1 (process 2216) detached]

Possible duplicates by query: bug 442475, bug 441365, bug 439498, bug 430431, bug 427945.

Reported using DrKonqi
Comment 1 Tony 2021-10-25 21:42:06 UTC

*** This bug has been marked as a duplicate of bug 442475 ***
Comment 2 Nate Graham 2021-10-25 21:45:25 UTC

*** This bug has been marked as a duplicate of bug 427945 ***