Bug 448455 - Can't close overview with a hotkey
Summary: Can't close overview with a hotkey
Status: RESOLVED DUPLICATE of bug 448435
Alias: None
Product: kwin
Classification: Plasma
Component: effects-overview (show other bugs)
Version: 5.23.90
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-14 12:22 UTC by d3coder
Modified: 2022-02-09 23:02 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description d3coder 2022-01-14 12:22:23 UTC
SUMMARY
Can't close overview with a hotkey


STEPS TO REPRODUCE
1. Press Meta + W to open overview
2. Press Meta + W again to close overview

OBSERVED RESULT
Overview is not closed. w is written in search bar

EXPECTED RESULT
Overview is closed

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.0-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4790K CPU @ 4.00GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2022-01-14 21:25:23 UTC
Does it magically start working if you restart KWin or the system?

If so it might be the same as Bug 448385, and we should re-open it and investigate.
Comment 2 Bug Janitor Service 2022-01-29 04:37:39 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 d3coder 2022-01-29 06:27:37 UTC
I re-checked it and it works now. Esc to close and Meta + W to open and close works. There were no updates to KWin in my distro since this bug report was made.
Comment 4 Nate Graham 2022-01-31 17:18:36 UTC
It's a semi-random heisenbug, unfortunately.
Comment 5 Johannes 2022-02-09 09:58:21 UTC
I've got a very similar bug: I can open and close overview using Meta+W, but if I set another keyboard shortcut to open the overview (in my case Alt+W), I can't use it to close it afterwards, and only Meta+W works for that purpose, as if it was hardcoded. In all cases, the escape key does not close the overview, which is problematic.

Should I file another bug for that?

Using Kubuntu with KDE backports, plasmashell 5.24.0
Comment 6 Vlad Zahorodnii 2022-02-09 23:02:47 UTC

*** This bug has been marked as a duplicate of bug 448435 ***