Bug 448435 - Overview effect's shortcut breaks a lot on X11
Summary: Overview effect's shortcut breaks a lot on X11
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-overview (show other bugs)
Version: git master
Platform: Fedora RPMs Linux
: HI normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 448455 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-14 03:17 UTC by Nate Graham
Modified: 2022-07-22 19:18 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2022-01-14 03:17:26 UTC
On Wayland, my default Meta+W shortcut breaks a lot. It's set correctly in the shortcuts KCM, but just kind of randomly stops working sometimes.

Restarting KWin fixes it, and then within an hour or two, it will break again until the next time KWin is restarted.
Comment 1 Patrick Silva 2022-01-14 20:11:07 UTC
Can confirm on Arch Linux running Plasma 5.24 beta.
Comment 2 Nate Graham 2022-01-18 22:26:01 UTC
Hmm, I haven't been able to reproduce this over the past few days.
Comment 3 Samuel Reddy 2022-01-24 23:51:25 UTC
Can reproduce on Arch Linux Plasma 5.24 Beta:
On Wayland, switch between Light and Dark mode in the quick settings, the overview shortcut won't work. This does not happen on X11.
Comment 4 Vlad Zahorodnii 2022-02-09 23:02:47 UTC
*** Bug 448455 has been marked as a duplicate of this bug. ***
Comment 5 Schlaefer 2022-02-13 09:45:15 UTC
1. Go to System Settings → Window Rules
2. Edit a rule and hit Apply
3. Meta+W Overview shortcut breaks

Operating System: EndeavourOS
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.9-246-tkg-bmq (64-bit)
Graphics Platform: Wayland
Comment 6 Vlad Zahorodnii 2022-02-14 07:42:51 UTC
(In reply to Schlaefer from comment #5)
> 1. Go to System Settings → Window Rules
> 2. Edit a rule and hit Apply
> 3. Meta+W Overview shortcut breaks
> 
> Operating System: EndeavourOS
> KDE Plasma Version: 5.24.0
> KDE Frameworks Version: 5.90.0
> Qt Version: 5.15.2
> Kernel Version: 5.16.9-246-tkg-bmq (64-bit)
> Graphics Platform: Wayland

This issue should be fixed with KF 5.91. After update, reboot your computer.
Comment 7 Nate Graham 2022-02-14 18:27:36 UTC
This whole issue, or just that specific set of steps to reproduce?
Comment 8 carlo 2022-02-18 22:09:37 UTC
Same problem here on Tumbleweed, Plasma 5.24.
I noticed this happens after changing some settings, e.g. theme, icons, fonts etc.
Comment 9 Bug Janitor Service 2022-03-05 14:20:01 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/2091
Comment 10 Jawad 2022-03-20 09:10:15 UTC
Sometimes when press meta Key Overview shows but i can't type anything even if i press on the search bar, and can't close Overview with pressing apps or on white space only `Esc` button closes overview, it's also fixes when restarting Kwin, X11, Also Overview Effect Meta Shortcut breaks Alot in X11
Comment 11 Marco Martin 2022-07-21 15:07:15 UTC
This should be fixed now.
if this still happens on checkouts newer than today please reopen