Bug 448385 - Escape Key should exit effect
Summary: Escape Key should exit effect
Alias: None
Product: kwin
Classification: Plasma
Component: effects-overview (show other bugs)
Version: 5.23.90
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: KWin default assignee
Depends on:
Reported: 2022-01-13 19:00 UTC by Nico
Modified: 2022-01-17 11:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Nico 2022-01-13 19:00:02 UTC
Escape Key should exit effect

1. Open Overview effect
2. Press ESC

Nothing happens

Overview effect should exit, just like when pressing the hotkey again

Linux/KDE Plasma: 
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2

Comment 1 Nate Graham 2022-01-13 21:56:06 UTC
Works for me on Plasma 5.24. I'm on Wayland though. Are you trying it on X11? If so can you try on Wayland?
Comment 2 Nico 2022-01-14 05:04:10 UTC
I'm in X11. I can try with Wayland later today
Comment 3 Nico 2022-01-14 18:32:46 UTC
I don't know why, but it works now (X11). Maybe it happened because I enabled it the first time in this version?
Comment 4 Nate Graham 2022-01-14 18:56:27 UTC
So does it not work right after you enable the effect, and you need to reboot before it starts working?
Comment 5 Nico 2022-01-14 19:03:27 UTC
No, I tried to disable and re-enable it, and now it works. My guess is because I'm using Plasma for quite some and I haven't used/enabled the effect before, and it conflicted with some other setting but somehow fixed itself now. Sorry, I can't provide a better description.
Comment 6 Nico 2022-01-14 19:04:05 UTC
The search also didn't work before (I couldn't focus the search field), but now does.
Comment 7 Nate Graham 2022-01-14 19:31:12 UTC
If you're not able to reproduce any of those bugs, there's not much to do here, since I can't reproduce them either. :/
Comment 8 Nico 2022-01-17 11:54:13 UTC
I just experienced the same bug on my PC at work which runs Fedora 35 with Plasma 5.23.4. I can't exit it with ESC and I can't focus the search field.

I'm sure it must have something to do with enabling it the first time. I somehow crashed KWin and after an automatic restart it started working.

I will see if I can reproduce the behavior in a VM.