Bug 448024 - KMail crashes on close after playing with tags
Summary: KMail crashes on close after playing with tags
Status: RESOLVED DUPLICATE of bug 442550
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-01-06 14:42 UTC by Erik Quaeghebeur
Modified: 2022-01-06 15:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Quaeghebeur 2022-01-06 14:42:10 UTC
Application: kmail (5.18.3 (21.08.3))
 (Compiled from sources)
Qt Version: 5.15.2
Frameworks Version: 5.88.0
Operating System: Linux 5.15.12-gentoo-a x86_64
Windowing System: X11
Distribution: Gentoo/Linux
DrKonqi: 5.23.4 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
I had just configures a tag and marked one message with that tag. Then KMail started blocking. (Unending trying-to-open message view.) Then I closed KMail, which causes the crash.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault

[KCrash Handler]
#4  0x0000796bf887b7d8 in QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator->() const (this=0x8) at ../../include/QtCore/../../../qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/tools/qscopedpointer.h:118
#5  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > >(QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >&) (ptr=...) at ../../include/QtCore/../../../qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/global/qglobal.h:1143
#6  QAction::d_func() (this=this@entry=0x0) at /var/tmp/portage/dev-qt/qtwidgets-5.15.2-r12/work/qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/widgets/kernel/qaction.h:63
#7  QAction::setText(QString const&) (this=this@entry=0x0, text=...) at /var/tmp/portage/dev-qt/qtwidgets-5.15.2-r12/work/qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/widgets/kernel/qaction.cpp:714
#8  0x0000796c00d7c082 in KMMainWidget::updateFolderMenu() (this=0x796b70008070) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/kmmainwidget.cpp:3996
#9  0x0000796c00d8698e in KMMainWidget::setupActions() (this=0x796b70008070) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/kmmainwidget.cpp:3384
#10 0x0000796c00d8bedd in KMMainWidget::KMMainWidget(QWidget*, KXMLGUIClient*, KActionCollection*, QExplicitlySharedDataPointer<KSharedConfig> const&) (this=this@entry=0x796b70008070, parent=parent@entry=0x62c3586d5c90, aGUIClient=aGUIClient@entry=0x62c3586d5d08, actionCollection=actionCollection@entry=0x62c354e621f0, config=...) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/kmmainwidget.cpp:249
#11 0x0000796c00d3508a in KMMainWin::KMMainWin(QWidget*) (this=this@entry=0x62c3586d5c90, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/kmmainwin.cpp:50
#12 0x0000796c00d47107 in KMKernel::openReader(bool, bool) (this=<optimized out>, onlyCheck=<optimized out>, startInTray=<optimized out>) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/kmkernel.cpp:560
#13 0x0000796c00d4c47f in KMKernel::action(bool, bool, bool, QString const&, QString const&, QString const&, QString const&, QString const&, QUrl const&, QList<QUrl> const&, QStringList const&, QString const&, QString const&, QString const&) (this=0x7ffcd3b1df80, mailto=<optimized out>, check=<optimized out>, startInTray=<optimized out>, to=..., cc=..., bcc=..., subj=..., body=..., messageFile=..., attachURLs=..., customHeaders=..., replyTo=..., inReplyTo=..., identity=...) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/kmkernel.cpp:1269
#14 0x0000796c00d4dd0e in KMKernel::handleCommandLine(bool, QStringList const&, QString const&) (this=<optimized out>, noArgsOpensReader=noArgsOpensReader@entry=true, args=..., workingDir=...) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/kmkernel.cpp:471
#15 0x000062c34640d842 in KMailApplication::activate(QStringList const&, QString const&) (this=<optimized out>, args=..., workingDir=...) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/main.cpp:100
#16 0x0000796c00e8f0f3 in KontactInterface::PimUniqueApplication::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7ffcd3b1d480, _o=<optimized out>) at /var/tmp/portage/kde-apps/kontactinterface-21.08.3/work/kontactinterface-21.08.3_build/src/KF5KontactInterface_autogen/EWIEGA46WW/moc_pimuniqueapplication.cpp:87
#17 KontactInterface::PimUniqueApplication::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7ffcd3b1d480) at /var/tmp/portage/kde-apps/kontactinterface-21.08.3/work/kontactinterface-21.08.3_build/src/KF5KontactInterface_autogen/EWIEGA46WW/moc_pimuniqueapplication.cpp:79
#18 0x0000796c00e8f3a3 in KontactInterface::PimUniqueApplication::qt_metacall(QMetaObject::Call, int, void**) (this=0x7ffcd3b1df60, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7ffcd3b1d480) at /var/tmp/portage/kde-apps/kontactinterface-21.08.3/work/kontactinterface-21.08.3_build/src/KF5KontactInterface_autogen/EWIEGA46WW/moc_pimuniqueapplication.cpp:124
#19 0x0000796bf75bed1b in QDBusConnectionPrivate::deliverCall(QObject*, int, QDBusMessage const&, QVector<int> const&, int) (this=<optimized out>, object=<optimized out>, msg=<optimized out>, metaTypes=<optimized out>, slotIdx=<optimized out>) at ../../include/QtCore/../../../qtbase-a4f9e56975fa6ab4a1f63a9b34a4d77b1cfe4acd/src/corelib/tools/qvarlengtharray.h:190
#20 0x0000796bf75c2863 in QDBusConnectionPrivate::activateCall(QObject*, int, QDBusMessage const&) (this=this@entry=0x796b84003a00, object=0x7ffcd3b1df60, flags=81, msg=...) at /var/tmp/portage/dev-qt/qtdbus-5.15.2-r10/work/qtbase-a4f9e56975fa6ab4a1f63a9b34a4d77b1cfe4acd/src/dbus/qdbusintegrator.cpp:904
#21 0x0000796bf75c311e in QDBusConnectionPrivate::activateCall(QObject*, int, QDBusMessage const&) (msg=..., flags=<optimized out>, object=<optimized out>, this=0x796b84003a00) at /var/tmp/portage/dev-qt/qtdbus-5.15.2-r10/work/qtbase-a4f9e56975fa6ab4a1f63a9b34a4d77b1cfe4acd/src/dbus/qdbusintegrator.cpp:853
#22 QDBusConnectionPrivate::activateObject(QDBusConnectionPrivate::ObjectTreeNode&, QDBusMessage const&, int) (this=0x796b84003a00, node=..., msg=..., pathStartPos=<optimized out>) at /var/tmp/portage/dev-qt/qtdbus-5.15.2-r10/work/qtbase-a4f9e56975fa6ab4a1f63a9b34a4d77b1cfe4acd/src/dbus/qdbusintegrator.cpp:1521
#23 0x0000796bf75c5698 in QDBusActivateObjectEvent::placeMetaCall(QObject*) (this=0x62c34e4477b0) at /var/tmp/portage/dev-qt/qtdbus-5.15.2-r10/work/qtbase-a4f9e56975fa6ab4a1f63a9b34a4d77b1cfe4acd/src/dbus/qdbusintegrator.cpp:1617
#24 0x0000796bf7ed9256 in QObject::event(QEvent*) (this=0x7ffcd3b1df60, e=0x62c34e4477b0) at /var/tmp/portage/dev-qt/qtcore-5.15.2-r11/work/qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/kernel/qobject.cpp:1314
#25 0x0000796bf887f96f in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x7ffcd3b1df60, e=0x62c34e4477b0) at /var/tmp/portage/dev-qt/qtwidgets-5.15.2-r12/work/qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/widgets/kernel/qapplication.cpp:3632
#26 0x0000796bf7ead9b8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x7ffcd3b1df60, event=0x62c34e4477b0) at /var/tmp/portage/dev-qt/qtcore-5.15.2-r11/work/qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/kernel/qcoreapplication.cpp:1064
#27 0x0000796bf7eb1025 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=0x0, event_type=0, data=0x62c347a49950) at /var/tmp/portage/dev-qt/qtcore-5.15.2-r11/work/qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/kernel/qcoreapplication.cpp:1821
#28 0x0000796bf7f00033 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x62c347b55b40) at /var/tmp/portage/dev-qt/qtcore-5.15.2-r11/work/qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/kernel/qeventdispatcher_glib.cpp:277
#29 0x0000796bf1b5ce9b in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#30 0x0000796bf1b5d158 in  () at /usr/lib64/libglib-2.0.so.0
#31 0x0000796bf1b5d20f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#32 0x0000796bf7effac4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x62c347b5c3a0, flags=...) at /var/tmp/portage/dev-qt/qtcore-5.15.2-r11/work/qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/kernel/qeventdispatcher_glib.cpp:423
#33 0x0000796bf7eac3ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffcd3b1da30, flags=..., flags@entry=...) at ../../include/QtCore/../../../qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/global/qflags.h:69
#34 0x0000796bf7eb49dd in QCoreApplication::exec() () at ../../include/QtCore/../../../qtbase-7c6c0030cf80ef7b9ace42996b0e0c3a72f76860/src/corelib/global/qflags.h:121
#35 0x000062c34640d4d5 in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /var/tmp/portage/kde-apps/kmail-21.08.3/work/kmail-21.08.3/src/main.cpp:173
[Inferior 1 (process 2508) detached]

The reporter indicates this bug may be a duplicate of or related to bug 424509.

Possible duplicates by query: bug 447360, bug 443988, bug 443958, bug 424509, bug 406871.

Reported using DrKonqi
Comment 1 Nicolas Fella 2022-01-06 15:28:54 UTC

*** This bug has been marked as a duplicate of bug 442550 ***