Bug 447360 - KMail crashes on startup when it can't authenticate account
Summary: KMail crashes on startup when it can't authenticate account
Status: RESOLVED DUPLICATE of bug 442550
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-12-21 20:59 UTC by Loren Burkholder
Modified: 2022-01-06 15:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.58 KB, text/plain)
2021-12-25 01:20 UTC, ewagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Loren Burkholder 2021-12-21 20:59:01 UTC
Application: kmail (5.19.0 (21.12.0))

Qt Version: 5.15.2
Frameworks Version: 5.89.0
Operating System: Linux 5.15.5-1-default x86_64
Windowing System: Wayland
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.23.4 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
KMail was not loading emails from any of my accounts, so I tried restarting it. When I restart KMail, it crashes and then starts up again. This is very possibly related to the fact that my employer's email server seems to be down so that KMail can't authenticate that account.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  0x00007f6407463a75 in QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=0x8) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
#7  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > > (ptr=...) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1143
#8  QAction::d_func (this=this@entry=0x0) at kernel/qaction.h:63
#9  QAction::setText (this=this@entry=0x0, text=...) at kernel/qaction.cpp:714
#10 0x00007f640f89495a in KMMainWidget::updateFolderMenu (this=0x7f63b4120ab0) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/kmmainwidget.cpp:4038
#11 0x00007f640f88b6cc in KMMainWidget::setupActions (this=0x7f63b4120ab0) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/kmmainwidget.cpp:3400
#12 0x00007f640f8752ea in KMMainWidget::KMMainWidget (this=<optimized out>, parent=<optimized out>, aGUIClient=<optimized out>, actionCollection=<optimized out>, config=..., this=<optimized out>, parent=<optimized out>, aGUIClient=<optimized out>, actionCollection=<optimized out>, config=...) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/kmmainwidget.cpp:248
#13 0x00007f640f83c25b in KMMainWin::KMMainWin (this=<optimized out>, this=<optimized out>) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/kmmainwin.cpp:49
#14 0x00007f640f84ddf7 in KMKernel::openReader (this=<optimized out>, onlyCheck=<optimized out>, startInTray=<optimized out>) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/kmkernel.cpp:565
#15 0x00007f640f8530ef in KMKernel::action (this=0x7ffeac7d72c0, mailto=<optimized out>, check=<optimized out>, startInTray=<optimized out>, to=..., cc=..., bcc=..., subj=..., body=..., messageFile=..., attachURLs=..., customHeaders=..., replyTo=..., inReplyTo=..., identity=...) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/kmkernel.cpp:1276
#16 0x00007f640f84c8d3 in KMKernel::handleCommandLine (this=<optimized out>, noArgsOpensReader=noArgsOpensReader@entry=true, args=..., workingDir=...) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/kmkernel.cpp:476
#17 0x000055b741cc5882 in KMailApplication::activate (this=<optimized out>, args=..., workingDir=...) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/main.cpp:100
#18 0x00007f640f986213 in KontactInterface::PimUniqueApplication::qt_static_metacall (_c=<optimized out>, _id=<optimized out>, _a=0x7ffeac7d67a0, _o=0x7ffeac7d72a0) at /usr/src/debug/kontactinterface-21.12.0-1.1.x86_64/build/src/KF5KontactInterface_autogen/EWIEGA46WW/moc_pimuniqueapplication.cpp:87
#19 KontactInterface::PimUniqueApplication::qt_static_metacall (_o=_o@entry=0x7ffeac7d72a0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=1, _a=_a@entry=0x7ffeac7d67a0) at /usr/src/debug/kontactinterface-21.12.0-1.1.x86_64/build/src/KF5KontactInterface_autogen/EWIEGA46WW/moc_pimuniqueapplication.cpp:79
#20 0x00007f640f9862f3 in KontactInterface::PimUniqueApplication::qt_metacall (this=0x7ffeac7d72a0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7ffeac7d67a0) at /usr/src/debug/kontactinterface-21.12.0-1.1.x86_64/build/src/KF5KontactInterface_autogen/EWIEGA46WW/moc_pimuniqueapplication.cpp:124
#21 0x00007f6405f2769b in QDBusConnectionPrivate::deliverCall (this=<optimized out>, object=<optimized out>, msg=..., metaTypes=..., slotIdx=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qvarlengtharray.h:190
#22 0x00007f6405f2b08c in QDBusConnectionPrivate::activateCall (this=this@entry=0x7f63c8003c00, object=0x7ffeac7d72a0, flags=81, msg=...) at qdbusintegrator.cpp:904
#23 0x00007f6405f2b91d in QDBusConnectionPrivate::activateCall (msg=..., flags=<optimized out>, object=<optimized out>, this=0x7f63c8003c00) at qdbusintegrator.cpp:853
#24 QDBusConnectionPrivate::activateObject (this=0x7f63c8003c00, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1521
#25 0x00007f6405f2de38 in QDBusActivateObjectEvent::placeMetaCall (this=0x55b743aa7e40) at qdbusintegrator.cpp:1617
#26 0x00007f64068e4fee in QObject::event (this=0x7ffeac7d72a0, e=0x55b743aa7e40) at kernel/qobject.cpp:1314
#27 0x00007f6407467a7f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x7ffeac7d72a0, e=0x55b743aa7e40) at kernel/qapplication.cpp:3632
#28 0x00007f64068b89fa in QCoreApplication::notifyInternal2 (receiver=0x7ffeac7d72a0, event=0x55b743aa7e40) at kernel/qcoreapplication.cpp:1064
#29 0x00007f64068bba47 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x55b743239c10) at kernel/qcoreapplication.cpp:1821
#30 0x00007f6406910853 in postEventSourceDispatch (s=s@entry=0x55b743266d10) at kernel/qeventdispatcher_glib.cpp:277
#31 0x00007f640109ad9f in g_main_dispatch (context=0x55b74324b630) at ../glib/gmain.c:3381
#32 g_main_context_dispatch (context=0x55b74324b630) at ../glib/gmain.c:4099
#33 0x00007f640109b128 in g_main_context_iterate (context=context@entry=0x55b74324b630, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#34 0x00007f640109b1df in g_main_context_iteration (context=0x55b74324b630, may_block=1) at ../glib/gmain.c:4240
#35 0x00007f640690fed4 in QEventDispatcherGlib::processEvents (this=0x55b743264200, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#36 0x00007f64068b73fb in QEventLoop::exec (this=this@entry=0x7ffeac7d6d80, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#37 0x00007f64068bf6e0 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#38 0x00007f6406d0918c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#39 0x00007f64074679f5 in QApplication::exec () at kernel/qapplication.cpp:2824
#40 0x000055b741cc543a in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kmail-21.12.0-1.1.x86_64/src/main.cpp:173
[Inferior 1 (process 20220) detached]

The reporter indicates this bug may be a duplicate of or related to bug 368349, bug 315568.

Possible duplicates by query: bug 443988, bug 443958, bug 424509, bug 406871, bug 404237.

Reported using DrKonqi
Comment 1 ewagner 2021-12-25 01:20:45 UTC
Created attachment 144849 [details]
New crash information added by DrKonqi

kmail (5.19.0 (21.12.0)) using Qt 5.15.2

- What I was doing when the application crashed:
Emails would not load, but titles were listed.  Attempted to view different emails, none would load.  Kmail crashed.  Reproduced issue multiple times.

- Custom settings of the application:
Default settings except for unchecking 'Download all messages for offline use' on my email accounts.

-- Backtrace (Reduced):
#4  0x00007ffbae89cb39 in QAction::setText(QString const&) () at /usr/lib/libQt5Widgets.so.5
#5  0x00007ffbb6e0caae in KMMainWidget::updateFolderMenu() () at /usr/lib/libkmailprivate.so.5
#6  0x00007ffbb6e17ca6 in KMMainWidget::setupActions() () at /usr/lib/libkmailprivate.so.5
#7  0x00007ffbb6e1d731 in KMMainWidget::KMMainWidget(QWidget*, KXMLGUIClient*, KActionCollection*, QExplicitlySharedDataPointer<KSharedConfig> const&) () at /usr/lib/libkmailprivate.so.5
#8  0x00007ffbb6dc6bd4 in KMMainWin::KMMainWin(QWidget*) () at /usr/lib/libkmailprivate.so.5
Comment 2 Nicolas Fella 2022-01-06 15:33:28 UTC

*** This bug has been marked as a duplicate of bug 442550 ***