Bug 443988 - KMail crashed after start-up of openSUSE PC from StandBy Mode, Login and Start of KMail
Summary: KMail crashed after start-up of openSUSE PC from StandBy Mode, Login and Star...
Status: RESOLVED DUPLICATE of bug 442550
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-10-18 18:05 UTC by philipp.grimmer
Modified: 2022-01-06 15:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philipp.grimmer 2021-10-18 18:05:53 UTC
Application: kmail (5.18.1 (21.08.1))

Qt Version: 5.15.2
Frameworks Version: 5.86.0
Operating System: Linux 5.14.9-1-default x86_64
Windowing System: X11
Drkonqi Version: 5.22.5
Distribution: openSUSE Tumbleweed

-- Information about the crash:
- What I was doing when the application crashed:

I started up my PC from its StandBy Mode, logged into openSUSE Tumbleweed and started KMail (as no programs were open anymore). Then the KMail App crashed.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7fd43d4ec040 (LWP 1931))]
[KCrash Handler]
#6  0x00007fd44aab9a75 in QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> >::operator-> (this=0x8) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:118
#7  qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > > (ptr=...) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1143
#8  QAction::d_func (this=0x0) at kernel/qaction.h:63
#9  QAction::setText (this=0x0, text=...) at kernel/qaction.cpp:714
#10 0x00007fd452ef0f8a in KMMainWidget::updateFolderMenu() () from /lib64/libkmailprivate.so.5
#11 0x00007fd452ee8746 in KMMainWidget::setupActions() () from /lib64/libkmailprivate.so.5
#12 0x00007fd452ed2c14 in KMMainWidget::KMMainWidget(QWidget*, KXMLGUIClient*, KActionCollection*, QExplicitlySharedDataPointer<KSharedConfig> const&) () from /lib64/libkmailprivate.so.5
#13 0x00007fd452e9a75b in KMMainWin::KMMainWin(QWidget*) () from /lib64/libkmailprivate.so.5
#14 0x00007fd452eac167 in KMKernel::openReader(bool, bool) () from /lib64/libkmailprivate.so.5
#15 0x00007fd452eb14af in KMKernel::action(bool, bool, bool, QString const&, QString const&, QString const&, QString const&, QString const&, QUrl const&, QList<QUrl> const&, QStringList const&, QString const&, QString const&, QString const&) () from /lib64/libkmailprivate.so.5
#16 0x00007fd452eaac43 in KMKernel::handleCommandLine(bool, QStringList const&, QString const&) () from /lib64/libkmailprivate.so.5
#17 0x0000561b26936882 in ?? ()
#18 0x00007fd452fdd703 in ?? () from /lib64/libKF5KontactInterface.so.5
#19 0x00007fd452fdd7e3 in KontactInterface::PimUniqueApplication::qt_metacall(QMetaObject::Call, int, void**) () from /lib64/libKF5KontactInterface.so.5
#20 0x00007fd4495aa69b in QDBusConnectionPrivate::deliverCall (this=<optimized out>, object=<optimized out>, msg=..., metaTypes=..., slotIdx=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qvarlengtharray.h:190
#21 0x00007fd4495ae08c in QDBusConnectionPrivate::activateCall (this=this@entry=0x7fd424003a00, object=0x7fffbade5710, flags=81, msg=...) at qdbusintegrator.cpp:904
#22 0x00007fd4495ae91d in QDBusConnectionPrivate::activateCall (msg=..., flags=<optimized out>, object=<optimized out>, this=0x7fd424003a00) at qdbusintegrator.cpp:853
#23 QDBusConnectionPrivate::activateObject (this=0x7fd424003a00, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1521
#24 0x00007fd4495b0e38 in QDBusActivateObjectEvent::placeMetaCall (this=0x561b2c62da40) at qdbusintegrator.cpp:1617
#25 0x00007fd449f3afbe in QObject::event (this=0x7fffbade5710, e=0x561b2c62da40) at kernel/qobject.cpp:1314
#26 0x00007fd44aabda7f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x7fffbade5710, e=0x561b2c62da40) at kernel/qapplication.cpp:3632
#27 0x00007fd449f0e9ca in QCoreApplication::notifyInternal2 (receiver=0x7fffbade5710, event=0x561b2c62da40) at kernel/qcoreapplication.cpp:1064
#28 0x00007fd449f11a17 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x561b26c8c1e0) at kernel/qcoreapplication.cpp:1821
#29 0x00007fd449f66823 in postEventSourceDispatch (s=s@entry=0x561b26dea640) at kernel/qeventdispatcher_glib.cpp:277
#30 0x00007fd443c10d5f in g_main_dispatch (context=0x7fd434005000) at ../glib/gmain.c:3381
#31 g_main_context_dispatch (context=0x7fd434005000) at ../glib/gmain.c:4099
#32 0x00007fd443c110e8 in g_main_context_iterate (context=context@entry=0x7fd434005000, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#33 0x00007fd443c1119f in g_main_context_iteration (context=0x7fd434005000, may_block=1) at ../glib/gmain.c:4240
#34 0x00007fd449f65ea4 in QEventDispatcherGlib::processEvents (this=0x561b26de7430, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#35 0x00007fd449f0d3cb in QEventLoop::exec (this=this@entry=0x7fffbade51f0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#36 0x00007fd449f156b0 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#37 0x0000561b2693643a in ?? ()
#38 0x00007fd44983e540 in __libc_start_call_main (main=main@entry=0x561b26935460, argc=argc@entry=3, argv=argv@entry=0x7fffbade59a8) at ../sysdeps/nptl/libc_start_call_main.h:58
#39 0x00007fd44983e5ec in __libc_start_main_impl (main=0x561b26935460, argc=3, argv=0x7fffbade59a8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffbade5998) at ../csu/libc-start.c:409
#40 0x0000561b26936615 in ?? ()
[Inferior 1 (process 1931) detached]

The reporter indicates this bug may be a duplicate of or related to bug 418844.

Possible duplicates by query: bug 443958, bug 443935, bug 443435, bug 440377, bug 440343.

Reported using DrKonqi
Comment 1 Nicolas Fella 2022-01-06 15:35:30 UTC

*** This bug has been marked as a duplicate of bug 442550 ***