Bug 447451 - Kicker's sub-menus cannot be navigated by keyboard in Wayland
Summary: Kicker's sub-menus cannot be navigated by keyboard in Wayland
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Menu (Kicker) (show other bugs)
Version: 5.23.4
Platform: Slackware Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: wayland
: 448009 451282 453766 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-12-24 01:04 UTC by sombragris
Modified: 2022-07-19 15:19 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sombragris 2021-12-24 01:04:51 UTC
When usig the hierarchical kicker start menu with sub menus, the menu can be navigated only in the first level using the keyboard (e.g., keyboard cursor arrow keys). Entering into a sublevel and choosing a sublevel item is not possible.

STEPS TO REPRODUCE
1. Boot Plasma with Wayland. Use the traditional Kicker Start Menu with cascading/submenus.
2. Open menu with Alt+F1 or whatever shortcut you have.
3. Choose any item, for example "Power / Session"
4. Try to select one of the options, such as "Shut Down" by using the keyboard navigation keys.

OBSERVED RESULT
The user is forced to use the mouse pointer device to select any item in any sub-menus

EXPECTED RESULT
The user should be able to select any menu item in any category by using regular keyboard navigation keys and activating any of these menu items by using the Enter key.

This is the case in X11, where the start menu behaves as expected.

SYSTEM INFORMATION
Operating System: Slackware 15.0
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.3
Kernel Version: 5.15.11 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 15,5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620

ADDITIONAL INFORMATION
As I said, the submenus behave normally under X11.
Comment 1 Nate Graham 2022-01-12 17:26:10 UTC
Can reproduce.
Comment 2 Nate Graham 2022-01-12 17:29:47 UTC
*** Bug 448009 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2022-03-10 18:58:53 UTC
*** Bug 451282 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2022-05-16 16:38:46 UTC
*** Bug 453766 has been marked as a duplicate of this bug. ***
Comment 5 Patrick Silva 2022-05-18 16:37:27 UTC
Can reproduce on neon unstable.
Comment 6 Patrick Silva 2022-07-16 12:02:15 UTC
No longer reproducible on neon unstable.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.25.80
KDE Frameworks Version: 5.97.0
Qt Version: 5.15.5
Graphics Platform: Wayland
Comment 7 sombragris 2022-07-16 16:15:20 UTC
Still present (and reproducible) on Slackware64-current as of today.

KDE Plasma Version: 5.25.3
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.4
Kernel Version: 5.18.12 (64-bit)
Graphics Platform: Wayland
Comment 8 Nate Graham 2022-07-19 15:19:01 UTC
Musta been fixed by something in git master, then. I can also reproduce that it's fixed!