Bug 459272 - Unable to navigate submenus with cursor keys
Summary: Unable to navigate submenus with cursor keys
Status: RESOLVED DUPLICATE of bug 447451
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Menu (Kicker) (show other bugs)
Version: 5.25.5
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-17 12:34 UTC by Frank Steinmetzger
Modified: 2022-09-18 15:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Steinmetzger 2022-09-17 12:34:50 UTC
SUMMARY
I just noticed that I can’t navigate to submenus in the cascading menu anymore. I can only go up and down on the main menu level and open a submenu with cursor right, but while the visible selection mark enters the menu, the actual focus does not. Instead, pressing up/down still changes the top-level menu selection.

STEPS TO REPRODUCE
1. Press <Meta> to open the menu.
2. Use cursor up/down to select a menu.
3. Press cursor right to open a submenu. The first item of the submenu is highlighted.

OBSERVED RESULT
Selection focus stays in the top level. Pressing up/down when the submenu item is highlighted still selects a new menu here instead. If the highlighted submenu item is a menu item itself, pressing cursor right again does not enter its subsubmenu. Observed under both X11 and Wayland.

EXPECTED RESULT
Cursor navigation should be restored to the original and intuitive behavior.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6
Kernel Version: 5.19.9-arch1-1 (64-bit)
Graphics Platform: Wayland
Comment 1 Frank Steinmetzger 2022-09-18 11:27:35 UTC
(In reply to Frank Steinmetzger from comment #0)

> Observed under both X11 and Wayland.

Correction: I’m back in X11 and I can’t reproduce it there.
Comment 2 Patrick Silva 2022-09-18 15:17:29 UTC

*** This bug has been marked as a duplicate of bug 447451 ***