Bug 445249 - Akonadi crash after unplugging Thunderbolt dock with attached monitor on Wayland
Summary: Akonadi crash after unplugging Thunderbolt dock with attached monitor on Wayland
Status: RESOLVED DUPLICATE of bug 450217
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-10 07:29 UTC by phrxmd
Modified: 2022-04-07 09:04 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description phrxmd 2021-11-10 07:29:39 UTC
Application: akonadiserver (5.18.3 (21.08.3))

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.14-1-default x86_64
Windowing System: Wayland
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.23.2 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
Unplugged my Thunderbolt dock, which has a monitor attached via DisplayPort, in order to fix an issue where the monitor would not go to the resolution I selected in System Settings.

- Unusual behavior I noticed:
The Wayland session was behaving strangely prior to unplugging. 
The monitor is capable of 3840x2160 resolution and has supported this resolution in KWin Wayland in the past. I can see and select this resolution in System Settings.

Since this morning (with no user changes to my KDE configuration or packages), the monitor comes up with 2560x1440. I can set it to 3840x2160 in System Settings. However, when I apply the settings, the monitor will go to 2560x1440 anyway (as confirmed by the monitor's HUD), and when I enter System Settings again, I see it again at 2560x1440.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Akonadi Server (akonadiserver), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = {<No data fields>}}
[KCrash Handler]
#6  std::default_delete<Akonadi::Server::Connection>::operator() (__ptr=0x111, this=<optimized out>) at /usr/include/c++/11/bits/unique_ptr.h:79
#7  std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >::~unique_ptr (this=<optimized out>, this=<optimized out>) at /usr/include/c++/11/bits/unique_ptr.h:361
#8  __gnu_cxx::new_allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > >::destroy<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > (__p=<optimized out>, this=<optimized out>) at /usr/include/c++/11/ext/new_allocator.h:168
#9  std::allocator_traits<std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::destroy<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > (__p=<optimized out>, __a=...) at /usr/include/c++/11/bits/alloc_traits.h:531
#10 std::vector<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >, std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::_M_erase (__position=std::unique_ptr<Akonadi::Server::Connection> = {get() = {<No data fields>}}, this=<optimized out>) at /usr/include/c++/11/bits/vector.tcc:177
#11 std::vector<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >, std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::erase (__position=std::unique_ptr<Akonadi::Server::Connection> = {get() = {<No data fields>}}, this=<optimized out>) at /usr/include/c++/11/bits/stl_vector.h:1431
#12 Akonadi::Server::AkonadiServer::connectionDisconnected (this=<optimized out>) at /usr/src/debug/akonadi-server-21.08.3-1.1.x86_64/src/server/akonadi.cpp:234
#13 0x00007fd6f95f8fee in QObject::event (this=0x7ffe83590c90, e=0x7fd6a4005970) at kernel/qobject.cpp:1314
#14 0x00007fd6f95cc9cf in doNotify (event=0x7fd6a4005970, receiver=0x7ffe83590c90) at kernel/qcoreapplication.cpp:1154
#15 QCoreApplication::notify (event=<optimized out>, receiver=<optimized out>, this=<optimized out>) at kernel/qcoreapplication.cpp:1140
#16 QCoreApplication::notifyInternal2 (receiver=0x7ffe83590c90, event=0x7fd6a4005970) at kernel/qcoreapplication.cpp:1064
#17 0x00007fd6f95cfa47 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x55eb0afff980) at kernel/qcoreapplication.cpp:1821
#18 0x00007fd6f9624853 in postEventSourceDispatch (s=s@entry=0x55eb0b03da30) at kernel/qeventdispatcher_glib.cpp:277
#19 0x00007fd6f7852d4f in g_main_dispatch (context=0x55eb0b03d4d0) at ../glib/gmain.c:3381
#20 g_main_context_dispatch (context=0x55eb0b03d4d0) at ../glib/gmain.c:4099
#21 0x00007fd6f78530d8 in g_main_context_iterate (context=context@entry=0x55eb0b03d4d0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#22 0x00007fd6f785318f in g_main_context_iteration (context=0x55eb0b03d4d0, may_block=1) at ../glib/gmain.c:4240
#23 0x00007fd6f9623ed4 in QEventDispatcherGlib::processEvents (this=0x55eb0b03cbf0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#24 0x00007fd6f95cb3fb in QEventLoop::exec (this=this@entry=0x7ffe83590ad0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#25 0x00007fd6f95d36e0 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#26 0x000055eb08ff7559 in AkApplicationBase::exec (this=0x7ffe83590c60) at /usr/src/debug/akonadi-server-21.08.3-1.1.x86_64/src/shared/akapplication.cpp:107
#27 main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/akonadi-server-21.08.3-1.1.x86_64/src/server/main.cpp:65
[Inferior 1 (process 3075) detached]

The reporter indicates this bug may be a duplicate of or related to bug 442147.

Possible duplicates by query: bug 444916, bug 444909, bug 444534, bug 444446, bug 444421.

Reported using DrKonqi
Comment 1 phrxmd 2021-11-10 08:02:34 UTC
The screen resolution issue I reported separately as bug 445353.
Comment 2 phrxmd 2021-11-10 08:03:06 UTC
Sorry, bug 445253.
Comment 3 phrxmd 2021-11-10 10:23:52 UTC
This happens reproducibly, every time I unplug my Thunderbolt dock I get this Akonadi crash.
Comment 4 phrxmd 2021-11-10 11:29:14 UTC
This also happens if I leave the dock plugged in and switch off my external screen.

Could be related to bug 438839 or bug 444801, but it's not Plasmashell that crashes.
Comment 5 Krisztián Szegi 2021-11-24 18:26:54 UTC
I have the same issue, at least as far as backtrace is concerned, although I can consistently reproduce it in a totally different way:
For me, this crash happens when I open an rdp connection with KRDC under wayland.
After that, my attached monitor has its scaling broken, and has its cursor click coordinates out of sync with its position.
Maybe related, that I scale my laptop's screen to 125%, but not my attached screen
Comment 6 Krisztián Szegi 2021-11-25 06:55:33 UTC
Application: akonadiserver (5.18.3 (21.08.3))

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.14-1-default x86_64
Windowing System: Wayland
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.23.2 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
This also happens to me - as far as the backtrace is concerned, the same thing - but with a totally different user action as its cause.
In my case, the crash happens when I open an krdc (rdp client) connection.

- Unusual behavior I noticed:
There are a bunch of oddness with some recent updates, not necessarily related, but severly lowering the comfort level:
- Display configuration has no setting anymore to select primary screen.
- I can force it to be the laptop's screen instead of the external, with some toggling of the external's enabled checkbox
- This is sometimes forgotten after reboot.
- Desktop widgets placed in the corner is being displaced inwards on ALMOST EVERY login. Somehow this is almost deterministic.
- I had my whole desktop (background, widgets erased, different Task-manager on Panel  - or different panel?) replaced with an update

-- Backtrace
Same as Philipp Reichmuth's, DrKonqi said this issue is already exist...
Comment 7 phrxmd 2022-02-09 22:52:47 UTC
Still happens with akonadiserver 21.12.2-1.1 on Plasma 5.24.0, reproducibly every time I switch off or unplug my external screen or my connected Thunderbolt dock.

Operating System: openSUSE Tumbleweed 20220207
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.5-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Comment 8 phrxmd 2022-02-10 22:08:01 UTC
The KWin crash that precedes for me this is reported as bug 449957. As soon as KWin comes back up again after this, Akonadi crashes.
Comment 9 postix 2022-04-07 09:04:08 UTC

*** This bug has been marked as a duplicate of bug 450217 ***