Bug 442147 - Akonadi crashes without any interaction
Summary: Akonadi crashes without any interaction
Status: RESOLVED DUPLICATE of bug 450217
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi, wayland
Depends on:
Blocks:
 
Reported: 2021-09-07 21:55 UTC by Tianyu Zhu
Modified: 2022-04-07 09:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tianyu Zhu 2021-09-07 21:55:46 UTC
Application: akonadiserver (5.18.1 (21.08.1))

Qt Version: 5.15.3
Frameworks Version: 5.85.0
Operating System: Linux 5.11.0-27-generic x86_64
Windowing System: Wayland
Drkonqi Version: 5.22.5
Distribution: KDE neon User Edition 5.22

-- Information about the crash:
- What I was doing when the application crashed:

Writing some code in IntelliJ.

- Custom settings of the application:

This only happens once in awhile in Wayland, and, I *think* when IntelliJ tries to open a dialog window.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Akonadi Server (akonadiserver), signal: Segmentation fault

[New LWP 78368]
[New LWP 78406]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f05dc1c4aff in __GI___poll (fds=0x7ffde461a938, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
[Current thread is 1 (Thread 0x7f05d852e840 (LWP 78364))]

Thread 3 (Thread 0x7f05d6d1b700 (LWP 78406)):
#0  0x00007f05dc1c4aff in __GI___poll (fds=0x558664708bd0, nfds=1, timeout=2403731) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f05dae3236e in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f05dae324a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f05dc7acfdb in QEventDispatcherGlib::processEvents (this=0x7f05c8000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f05dc75126b in QEventLoop::exec (this=this@entry=0x7f05d6d1ad60, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007f05dc56ac22 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007f05dc56bdbc in QThreadPrivate::start (arg=0x5586646b60b0) at thread/qthread_unix.cpp:329
#7  0x00007f05db826609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f05dc1d1293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f05d7fbd700 (LWP 78368)):
#0  0x00007f05dc1c4aff in __GI___poll (fds=0x7f05d0005240, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f05dae3236e in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f05dae324a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f05dc7acfdb in QEventDispatcherGlib::processEvents (this=0x7f05d0000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f05dc75126b in QEventLoop::exec (this=this@entry=0x7f05d7fbcd30, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007f05dc56ac22 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007f05dca58f4b in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f05dc56bdbc in QThreadPrivate::start (arg=0x7f05dcadcd80) at thread/qthread_unix.cpp:329
#8  0x00007f05db826609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f05dc1d1293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f05d852e840 (LWP 78364)):
[KCrash Handler]
#4  std::default_delete<Akonadi::Server::Connection>::operator() (this=0x5586646d9788, __ptr=0x111) at /usr/include/c++/9/bits/unique_ptr.h:75
#5  std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >::~unique_ptr (this=0x5586646d9788, __in_chrg=<optimized out>) at /usr/include/c++/9/bits/unique_ptr.h:292
#6  __gnu_cxx::new_allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > >::destroy<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > (this=0x7ffde461bbc8, __p=0x5586646d9788) at /usr/include/c++/9/ext/new_allocator.h:153
#7  std::allocator_traits<std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::destroy<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > (__a=..., __p=0x5586646d9788) at /usr/include/c++/9/bits/alloc_traits.h:497
#8  std::vector<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >, std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::_M_erase (__position=..., this=0x7ffde461bbc8) at /usr/include/c++/9/bits/vector.tcc:177
#9  std::vector<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> >, std::allocator<std::unique_ptr<Akonadi::Server::Connection, std::default_delete<Akonadi::Server::Connection> > > >::erase (__position=..., this=0x7ffde461bbc8) at /usr/include/c++/9/bits/stl_vector.h:1428
#10 Akonadi::Server::AkonadiServer::connectionDisconnected (this=0x7ffde461bb40) at ./src/server/akonadi.cpp:234
#11 0x00007f05dc780309 in QObject::event (this=0x7ffde461bb40, e=0x7f058000e350) at kernel/qobject.cpp:1314
#12 0x00007f05dc75273f in doNotify (event=0x7f058000e350, receiver=0x7ffde461bb40) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:153
#13 QCoreApplication::notify (event=<optimized out>, receiver=<optimized out>, this=<optimized out>) at kernel/qcoreapplication.cpp:1140
#14 QCoreApplication::notifyInternal2 (receiver=0x7ffde461bb40, event=0x7f058000e350) at kernel/qcoreapplication.cpp:1064
#15 0x00007f05dc755071 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x558664671920) at kernel/qcoreapplication.cpp:1821
#16 0x00007f05dc7ad967 in postEventSourceDispatch (s=0x5586646758b0) at kernel/qeventdispatcher_glib.cpp:277
#17 0x00007f05dae3217d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f05dae32400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f05dae324a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f05dc7acfc2 in QEventDispatcherGlib::processEvents (this=0x558664672d20, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#21 0x00007f05dc75126b in QEventLoop::exec (this=this@entry=0x7ffde461ba20, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#22 0x00007f05dc759424 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#23 0x0000558662e783dc in main (argc=<optimized out>, argv=<optimized out>) at ./src/server/main.cpp:65
[Inferior 1 (process 78364) detached]

Possible duplicates by query: bug 441995, bug 441621, bug 441168, bug 440917, bug 440841.

Reported using DrKonqi
Comment 1 postix 2022-04-07 09:00:53 UTC
The stacktraces look the same to me.

*** This bug has been marked as a duplicate of bug 450217 ***