Bug 444599 - System Settings crashed in Breeze::WidgetStateData::~WidgetStateData() after switching view mode and click on an item in the sidebar
Summary: System Settings crashed in Breeze::WidgetStateData::~WidgetStateData() after ...
Status: RESOLVED WORKSFORME
Alias: None
Product: Breeze
Classification: Plasma
Component: QStyle (show other bugs)
Version: master
Platform: Neon Linux
: HI crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi, regression
: 449853 450565 450754 450935 453813 454389 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-29 11:27 UTC by Patrick Silva
Modified: 2022-09-25 00:17 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.3


Attachments
gdbtrace (52.68 KB, text/plain)
2022-05-23 08:11 UTC, Pawel
Details
gdb trace (107.17 KB, text/plain)
2022-05-23 08:38 UTC, Pawel
Details
video of lag spike (2.18 MB, video/x-matroska)
2022-09-21 06:51 UTC, Pawel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2021-10-29 11:27:51 UTC
Application: systemsettings (5.23.80)

Qt Version: 5.15.3
Frameworks Version: 5.88.0
Operating System: Linux 5.11.0-38-generic x86_64
Windowing System: Wayland
Distribution: KDE neon Unstable Edition
DrKonqi: 5.23.80 [CoredumpBackend]

-- Information about the crash:
- What I was doing when the application crashed:
open System Settings in icon view mode, switch to sidebar view mode, click on 'Input devices' in the sidebar, crash occurs.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = 0x0}
[New LWP 15372]
[New LWP 15393]
[New LWP 15428]
[New LWP 15396]
[New LWP 15397]
[New LWP 15394]
[New LWP 15395]
[New LWP 15431]
[New LWP 15427]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/bin/systemsettings'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  __GI_raise (sig=sig@entry=11) at ../sysdeps/unix/sysv/linux/raise.c:50
[Current thread is 1 (Thread 0x7f011d7609c0 (LWP 15372))]
__preamble__

[Current thread is 1 (Thread 0x7f011d7609c0 (LWP 15372))]

Thread 9 (Thread 0x7f00eb7fe700 (LWP 15427)):
#0  0x00007f0122001aff in __GI___poll (fds=0x7f00e002f760, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f012007036e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7f00e002f760, timeout=<optimized out>, context=0x7f00e00d4a90) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7f00e00d4a90, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007f01200704a3 in g_main_context_iteration (context=0x7f00e00d4a90, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007f01225d1602 in QEventDispatcherGlib::processEvents (this=0x7f00e0013860, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007f01225758ab in QEventLoop::exec (this=this@entry=0x7f00eb7fdbc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007f012238f2c2 in QThread::exec (this=this@entry=0x555e163995a0) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007f012100b549 in QQmlThreadPrivate::run (this=0x555e163995a0) at qml/ftw/qqmlthread.cpp:155
#8  0x00007f012239045c in QThreadPrivate::start (arg=0x555e163995a0) at thread/qthread_unix.cpp:329
#9  0x00007f0120a2f609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007f012200e293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7f0104ec8700 (LWP 15431)):
#0  0x00007f0122001aff in __GI___poll (fds=0x7f00f81e5be0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f012007036e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7f00f81e5be0, timeout=<optimized out>, context=0x7f00f8164df0) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7f00f8164df0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007f01200704a3 in g_main_context_iteration (context=0x7f00f8164df0, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007f01225d1602 in QEventDispatcherGlib::processEvents (this=0x7f00f82a2f30, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007f01225758ab in QEventLoop::exec (this=this@entry=0x7f0104ec7bc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007f012238f2c2 in QThread::exec (this=this@entry=0x555e1c28bae0) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007f012100b549 in QQmlThreadPrivate::run (this=0x555e1c28bae0) at qml/ftw/qqmlthread.cpp:155
#8  0x00007f012239045c in QThreadPrivate::start (arg=0x555e1c28bae0) at thread/qthread_unix.cpp:329
#9  0x00007f0120a2f609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007f012200e293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f0115f6d700 (LWP 15395)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x555e1590d7a8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x555e1590d758, cond=0x555e1590d780) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x555e1590d780, mutex=0x555e1590d758) at pthread_cond_wait.c:647
#3  0x00007f011693ca4b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f011693c64b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f0120a2f609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f012200e293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f011676e700 (LWP 15394)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x555e1590d7a8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x555e1590d758, cond=0x555e1590d780) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x555e1590d780, mutex=0x555e1590d758) at pthread_cond_wait.c:647
#3  0x00007f011693ca4b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f011693c64b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f0120a2f609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f012200e293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f011576c700 (LWP 15397)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x555e1590d7a8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x555e1590d758, cond=0x555e1590d780) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x555e1590d780, mutex=0x555e1590d758) at pthread_cond_wait.c:647
#3  0x00007f011693ca4b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f011693c64b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f0120a2f609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f012200e293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f0107fff700 (LWP 15396)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x555e1590d7a8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x555e1590d758, cond=0x555e1590d780) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x555e1590d780, mutex=0x555e1590d758) at pthread_cond_wait.c:647
#3  0x00007f011693ca4b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f011693c64b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f0120a2f609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f012200e293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f00fef1a700 (LWP 15428)):
#0  0x00007f0122001aff in __GI___poll (fds=0x7f00f4012920, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f012007036e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7f00f4012920, timeout=<optimized out>, context=0x7f00f410c560) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7f00f410c560, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007f01200704a3 in g_main_context_iteration (context=0x7f00f410c560, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007f01225d1602 in QEventDispatcherGlib::processEvents (this=0x7f00f40de0a0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007f01225758ab in QEventLoop::exec (this=this@entry=0x7f00fef19bc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007f012238f2c2 in QThread::exec (this=this@entry=0x555e1bce1f40) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007f012100b549 in QQmlThreadPrivate::run (this=0x555e1bce1f40) at qml/ftw/qqmlthread.cpp:155
#8  0x00007f012239045c in QThreadPrivate::start (arg=0x555e1bce1f40) at thread/qthread_unix.cpp:329
#9  0x00007f0120a2f609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007f012200e293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f011cec6700 (LWP 15393)):
#0  0x00007f0122001aff in __GI___poll (fds=0x7f0118005240, nfds=2, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f012007036e in g_main_context_poll (priority=<optimized out>, n_fds=2, fds=0x7f0118005240, timeout=<optimized out>, context=0x7f0118000c20) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7f0118000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007f01200704a3 in g_main_context_iteration (context=0x7f0118000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007f01225d1602 in QEventDispatcherGlib::processEvents (this=0x7f0118000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007f01225758ab in QEventLoop::exec (this=this@entry=0x7f011cec5bb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007f012238f2c2 in QThread::exec (this=this@entry=0x7f0121789d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007f0121705f4b in QDBusConnectionManager::run (this=0x7f0121789d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:179
#8  0x00007f012239045c in QThreadPrivate::start (arg=0x7f0121789d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:329
#9  0x00007f0120a2f609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007f012200e293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f011d7609c0 (LWP 15372)):
[KCrash Handler]
#3  QWeakPointer<QObject>::~QWeakPointer (this=0x555e15d9ec18, __in_chrg=<optimized out>) at /usr/include/c++/9/bits/atomic_base.h:326
#4  0x00007f011cefd2cc in QPointer<Breeze::Animation>::~QPointer (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qpointer.h:53
#5  Breeze::GenericData::~GenericData (this=0x555e15d9ebf0, __in_chrg=<optimized out>) at ./kstyle/animations/breezegenericdata.h:20
#6  0x00007f011cefd347 in Breeze::WidgetStateData::~WidgetStateData (this=0x555e15d9ebf0, __in_chrg=<optimized out>) at ./kstyle/animations/breezewidgetstatedata.h:31
#7  Breeze::WidgetStateData::~WidgetStateData (this=0x555e15d9ebf0, __in_chrg=<optimized out>) at ./kstyle/animations/breezewidgetstatedata.h:32
#8  0x00007f01225a46e3 in QObject::event (this=0x555e15d9ebf0, e=0x555e1beb56a0) at kernel/qobject.cpp:1301
#9  0x00007f012318adc3 in QApplicationPrivate::notify_helper (this=this@entry=0x555e1570ba80, receiver=receiver@entry=0x555e15d9ebf0, e=e@entry=0x555e1beb56a0) at kernel/qapplication.cpp:3632
#10 0x00007f0123193bb8 in QApplication::notify (this=0x7ffc08b3e980, receiver=0x555e15d9ebf0, e=0x555e1beb56a0) at kernel/qapplication.cpp:3156
#11 0x00007f0122576daa in QCoreApplication::notifyInternal2 (receiver=0x555e15d9ebf0, event=0x555e1beb56a0) at ../../include/QtCore/5.15.3/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#12 0x00007f01225796b1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x555e156e6480) at kernel/qcoreapplication.cpp:1821
#13 0x00007f01225d1fa7 in postEventSourceDispatch (s=0x555e1572ab50) at kernel/qeventdispatcher_glib.cpp:277
#14 0x00007f012007017d in g_main_dispatch (context=0x555e1572c020) at ../../../glib/gmain.c:3309
#15 g_main_context_dispatch (context=context@entry=0x555e1572c020) at ../../../glib/gmain.c:3974
#16 0x00007f0120070400 in g_main_context_iterate (context=context@entry=0x555e1572c020, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4047
#17 0x00007f01200704a3 in g_main_context_iteration (context=0x555e1572c020, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#18 0x00007f01225d1602 in QEventDispatcherGlib::processEvents (this=0x555e15733440, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#19 0x00007f01225758ab in QEventLoop::exec (this=this@entry=0x7ffc08b3e860, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#20 0x00007f012257da64 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#21 0x0000555e13c4ced1 in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:183

Reported using DrKonqi
Comment 1 Patrick Silva 2022-01-15 13:15:21 UTC
Crash reproducible on Plasma 5.24 beta.

Operating System: Arch Linux
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 2 Patrick Silva 2022-02-10 16:58:59 UTC
*** Bug 449853 has been marked as a duplicate of this bug. ***
Comment 3 Fushan Wen 2022-02-16 03:58:08 UTC
The wizard shows 449853 instead of this bug.

*** This bug has been marked as a duplicate of bug 449853 ***
Comment 4 Fushan Wen 2022-02-19 12:56:59 UTC
*** Bug 450565 has been marked as a duplicate of this bug. ***
Comment 5 Fushan Wen 2022-02-23 15:04:42 UTC
*** Bug 450754 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2022-03-02 16:47:31 UTC
*** Bug 450935 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2022-03-02 16:51:31 UTC
*** Bug 449853 has been marked as a duplicate of this bug. ***
Comment 8 Ismael Asensio 2022-03-07 19:24:02 UTC
I've been unable to reproduce this bug consistently, so if it is possible, could you please try to reproduce with latest system settings (after commit 1022d0b0d5945613)?

I'm not sure that the commit will fix this (it is not its intention), but just to be sure.

Thanks!
Comment 9 Fushan Wen 2022-03-08 01:33:37 UTC
Yes, opened systemsettings 20 times and no crash. Thanks!
Comment 10 Nate Graham 2022-05-17 14:18:50 UTC
*** Bug 453813 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2022-05-17 14:20:24 UTC
Got a duplicate report (Bug 444599) from someone on Plasma 5.24.5; re-opening.

The way they reproduced it was:
1. right-click on desktop > configure displays
2. click "Switch to Sidebar mode" button in toolbar
Comment 12 Nate Graham 2022-05-17 14:21:22 UTC
(I couldn't reproduce the issue by doing that on current git master though)
Comment 13 Pawel 2022-05-22 09:46:18 UTC
(In reply to Nate Graham from comment #12)
> (I couldn't reproduce the issue by doing that on current git master though)

Hi Nate,

I can reproduce this reliably on 5 25 beta on Arch now. I have captured a crash dump with debug symbols but I can’t access my computer now to upload it. I will attach the gdb trace tomorrow. I am also happy to help test by applying patches on top of 5 25 beta.

I can only trigger the bug as follows:

1. right-click on desktop > configure displays
2. click "Switch to Sidebar mode" button in toolbar
Comment 14 Pawel 2022-05-23 08:11:52 UTC
Created attachment 149133 [details]
gdbtrace

and here is the gdb dump.

Operating System: Arch Linux
KDE Plasma Version: 5.24.90
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Kernel Version: 5.17.9-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 6800 XT
Comment 15 Ismael Asensio 2022-05-23 08:33:38 UTC
(In reply to Pawel from comment #14)
> Created attachment 149133 [details]
> gdbtrace
> 
> and here is the gdb dump.
> 

I can reproduce with the given steps (usually once per session, but not always) and always with a backtrace similar to yours. 

This backtrace is different to the original one in the BR. It seems to be caused by accessing to a null smart pointer, to re-create a combobox model, after ConfigHandler::outputModelChanged() gets triggered, so it's not necessarily an old thing coming back but a new crash unveiling :).

My guess is some errors or race on the destruction of the KCM module when it gets unloaded, or some dangling stuff in the process of switching from one view to the other (which may involve unloading and reloading).
Comment 16 Pawel 2022-05-23 08:38:58 UTC
Created attachment 149134 [details]
gdb trace

You might be correct Ismael. Looking closer at the data it seems it might be a different bug manifesting itself.

I can repro 100% of the time.  I have attached another dump - maybe it can help devs track down the root cause.
Comment 17 Nate Graham 2022-05-25 15:33:34 UTC
*** Bug 454389 has been marked as a duplicate of this bug. ***
Comment 18 Nate Graham 2022-08-22 23:27:56 UTC
With current git master, I still can't reproduce the issue with Pawel's steps. Can you, Ismael?
Comment 19 Bug Janitor Service 2022-09-06 04:36:12 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 20 Bug Janitor Service 2022-09-21 04:47:20 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 21 Pawel 2022-09-21 06:43:02 UTC
Hi Nate,

FWIW, I can no no longer reproduce this issue on Arch Linux Plasma 5.26 beta. Instead of a crash, there is a noticeable lag spike, or a hitch, when clicking "Switch to Sidebar mode" button in the toolbar.

Operating System: Arch Linux
KDE Plasma Version: 5.25.90
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6
Kernel Version: 5.19.10-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 6800 XT
Comment 22 Fushan Wen 2022-09-21 06:49:20 UTC
(In reply to Pawel from comment #21)
> Hi Nate,
> 
> FWIW, I can no no longer reproduce this issue on Arch Linux Plasma 5.26
> beta. Instead of a crash, there is a noticeable lag spike, or a hitch, when
> clicking "Switch to Sidebar mode" button in the toolbar.
> 
> Operating System: Arch Linux
> KDE Plasma Version: 5.25.90
> KDE Frameworks Version: 5.98.0
> Qt Version: 5.15.6
> Kernel Version: 5.19.10-arch1-1 (64-bit)
> Graphics Platform: Wayland
> Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
> Memory: 31.3 GiB of RAM
> Graphics Processor: AMD Radeon RX 6800 XT

The lag is expected because it loads sidebar mode on demand.
Comment 23 Pawel 2022-09-21 06:51:11 UTC
Created attachment 152306 [details]
video of lag spike

see the attached video. the lag only occurs when the system setting application is opened with the icon view and then I click switch to sidebar view. and it only lags the first time the user switches views - each subsequent switch is smooth
Comment 24 Pawel 2022-09-21 06:52:20 UTC
(In reply to Fushan Wen from comment #22)
> (In reply to Pawel from comment #21)
> > Hi Nate,
> > 
> > FWIW, I can no no longer reproduce this issue on Arch Linux Plasma 5.26
> > beta. Instead of a crash, there is a noticeable lag spike, or a hitch, when
> > clicking "Switch to Sidebar mode" button in the toolbar.
> > 
> > Operating System: Arch Linux
> > KDE Plasma Version: 5.25.90
> > KDE Frameworks Version: 5.98.0
> > Qt Version: 5.15.6
> > Kernel Version: 5.19.10-arch1-1 (64-bit)
> > Graphics Platform: Wayland
> > Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
> > Memory: 31.3 GiB of RAM
> > Graphics Processor: AMD Radeon RX 6800 XT
> 
> The lag is expected because it loads sidebar mode on demand.

ah, that makes sense. Thanks and ignore my comment with the video.

As far as I can tell, this defect has been fixed. It would be great if OP could confirm :)
Comment 25 Patrick Silva 2022-09-25 00:17:33 UTC
(In reply to Pawel from comment #24)
> As far as I can tell, this defect has been fixed. It would be great if OP
> could confirm :)
I'm also unable to reproduce the crash. :)


Operating System: Arch Linux
KDE Plasma Version: 5.25.90
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6
Graphics Platform: Wayland