Bug 454389 - System Setttings crashed after switching to sidebar view
Summary: System Setttings crashed after switching to sidebar view
Status: RESOLVED DUPLICATE of bug 444599
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-05-25 11:56 UTC by Patrick Silva
Modified: 2022-05-25 15:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2022-05-25 11:56:15 UTC
Application: systemsettings (5.25.80)

Qt Version: 5.15.4
Frameworks Version: 5.95.0
Operating System: Linux 5.13.0-41-generic x86_64
Windowing System: Wayland
Distribution: KDE neon Unstable Edition
DrKonqi: 5.25.80 [CoredumpBackend]

-- Information about the crash:
I was using icon view, launched Window Rules KCM via Kickoff, clicked on 'All settings' on top, clicked on 'Switch to sidebar view' on top, System Settings crashed.

The crash does not seem to be reproducible.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = 0x0}
[New LWP 25993]
[New LWP 26008]
[New LWP 26020]
[New LWP 26009]
[New LWP 26019]
[New LWP 26017]
[New LWP 26023]
[New LWP 26016]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `/usr/bin/systemsettings kcm_kwinrules'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  __GI_raise (sig=sig@entry=11) at ../sysdeps/unix/sysv/linux/raise.c:50
[Current thread is 1 (Thread 0x7fddc7614e80 (LWP 25993))]
__preamble__

[Current thread is 1 (Thread 0x7fddc7614e80 (LWP 25993))]

Thread 8 (Thread 0x7fddc588b700 (LWP 26016)):
#0  0x00007fddcbf1f99f in __GI___poll (fds=0x7fddbc004a60, nfds=2, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fddca9da36e in g_main_context_poll (priority=<optimized out>, n_fds=2, fds=0x7fddbc004a60, timeout=<optimized out>, context=0x7fddbc000c20) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fddbc000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fddca9da4a3 in g_main_context_iteration (context=0x7fddbc000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fddcc4f2c72 in QEventDispatcherGlib::processEvents (this=0x7fddbc000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fddcc496eab in QEventLoop::exec (this=this@entry=0x7fddc588abb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fddcc2b0462 in QThread::exec (this=this@entry=0x7fddcb683d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fddcb5fff4b in QDBusConnectionManager::run (this=0x7fddcb683d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:179
#8  0x00007fddcc2b1643 in QThreadPrivate::start (arg=0x7fddcb683d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:331
#9  0x00007fddcb397609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fddcbf2c133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fdda7bff700 (LWP 26023)):
#0  0x00007fddcbf1f99f in __GI___poll (fds=0x7fdd94004a60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fddca9da36e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fdd94004a60, timeout=<optimized out>, context=0x7fdd94000c20) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fdd94000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fddca9da4a3 in g_main_context_iteration (context=0x7fdd94000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fddcc4f2c72 in QEventDispatcherGlib::processEvents (this=0x7fdd94000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fddcc496eab in QEventLoop::exec (this=this@entry=0x7fdda7bfebc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fddcc2b0462 in QThread::exec (this=this@entry=0x5619fdac3560) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fddca261689 in QQmlThreadPrivate::run (this=0x5619fdac3560) at qml/ftw/qqmlthread.cpp:155
#8  0x00007fddcc2b1643 in QThreadPrivate::start (arg=0x5619fdac3560) at thread/qthread_unix.cpp:331
#9  0x00007fddcb397609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fddcbf2c133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7fddb6ef9700 (LWP 26017)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5619fc6b574c) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5619fc6b56f8, cond=0x5619fc6b5720) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5619fc6b5720, mutex=0x5619fc6b56f8) at pthread_cond_wait.c:647
#3  0x00007fddb71475eb in cnd_wait (mtx=0x5619fc6b56f8, cond=0x5619fc6b5720) at ../include/c11/threads_posix.h:155
#4  util_queue_thread_func (input=input@entry=0x5619fc7d4130) at ../src/util/u_queue.c:294
#5  0x00007fddb71471eb in impl_thrd_routine (p=<optimized out>) at ../include/c11/threads_posix.h:87
#6  0x00007fddcb397609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#7  0x00007fddcbf2c133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fddb5651700 (LWP 26019)):
#0  0x00007fddcbf1f99f in __GI___poll (fds=0x7fdda82ab5d0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fddca9da36e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fdda82ab5d0, timeout=<optimized out>, context=0x7fdda8544f40) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fdda8544f40, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fddca9da4a3 in g_main_context_iteration (context=0x7fdda8544f40, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fddcc4f2c72 in QEventDispatcherGlib::processEvents (this=0x7fdda83e3a10, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fddcc496eab in QEventLoop::exec (this=this@entry=0x7fddb5650bc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fddcc2b0462 in QThread::exec (this=this@entry=0x5619fc77cbf0) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fddca261689 in QQmlThreadPrivate::run (this=0x5619fc77cbf0) at qml/ftw/qqmlthread.cpp:155
#8  0x00007fddcc2b1643 in QThreadPrivate::start (arg=0x5619fc77cbf0) at thread/qthread_unix.cpp:331
#9  0x00007fddcb397609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fddcbf2c133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fddc618c700 (LWP 26009)):
#0  0x00007fddcbf1f99f in __GI___poll (fds=fds@entry=0x7fddc618bbe0, nfds=nfds@entry=2, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fddc9a67bd6 in poll (__timeout=-1, __nfds=2, __fds=0x7fddc618bbe0) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  QtWaylandClient::EventThread::run (this=0x5619fc65d660) at qwaylanddisplay.cpp:208
#3  0x00007fddcc2b1643 in QThreadPrivate::start (arg=0x5619fc65d660) at thread/qthread_unix.cpp:331
#4  0x00007fddcb397609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#5  0x00007fddcbf2c133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fddad0e0700 (LWP 26020)):
#0  0x00007fddcbf1f99f in __GI___poll (fds=0x7fdd9c004e60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fddca9da36e in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fdd9c004e60, timeout=<optimized out>, context=0x7fdd9c000c20) at ../../../glib/gmain.c:4346
#2  g_main_context_iterate (context=context@entry=0x7fdd9c000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4042
#3  0x00007fddca9da4a3 in g_main_context_iteration (context=0x7fdd9c000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#4  0x00007fddcc4f2c72 in QEventDispatcherGlib::processEvents (this=0x7fdd9c000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#5  0x00007fddcc496eab in QEventLoop::exec (this=this@entry=0x7fddad0dfbc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fddcc2b0462 in QThread::exec (this=this@entry=0x5619fcc0ae60) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fddca261689 in QQmlThreadPrivate::run (this=0x5619fcc0ae60) at qml/ftw/qqmlthread.cpp:155
#8  0x00007fddcc2b1643 in QThreadPrivate::start (arg=0x5619fcc0ae60) at thread/qthread_unix.cpp:331
#9  0x00007fddcb397609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fddcbf2c133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fddc698d700 (LWP 26008)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5619fc641db0) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5619fc641d60, cond=0x5619fc641d88) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5619fc641d88, mutex=0x5619fc641d60) at pthread_cond_wait.c:647
#3  0x00007fddcc2b76db in QWaitConditionPrivate::wait (deadline=..., this=0x5619fc641d60) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait (this=this@entry=0x5619fc65d630, mutex=mutex@entry=0x5619fc65d628, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007fddc9a67b7d in QtWaylandClient::EventThread::waitForReading (this=0x5619fc65d5f0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  QtWaylandClient::EventThread::run (this=0x5619fc65d5f0) at qwaylanddisplay.cpp:206
#7  0x00007fddcc2b1643 in QThreadPrivate::start (arg=0x5619fc65d5f0) at thread/qthread_unix.cpp:331
#8  0x00007fddcb397609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007fddcbf2c133 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fddc7614e80 (LWP 25993)):
[KCrash Handler]
#3  QWeakPointer<QObject>::~QWeakPointer (this=0x5619fe45b558, __in_chrg=<optimized out>) at /usr/include/c++/9/bits/atomic_base.h:326
#4  0x00007fddc591535c in QPointer<Breeze::Animation>::~QPointer (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qpointer.h:53
#5  Breeze::GenericData::~GenericData (this=0x5619fe45b530, __in_chrg=<optimized out>) at ./obj-x86_64-linux-gnu/kstyle/breeze_autogen/4NBMFDNHZT/../../../../kstyle/animations/breezegenericdata.h:18
#6  0x00007fddc59153d7 in Breeze::WidgetStateData::~WidgetStateData (this=0x5619fe45b530, __in_chrg=<optimized out>) at ./obj-x86_64-linux-gnu/kstyle/breeze_autogen/4NBMFDNHZT/../../../../kstyle/animations/breezewidgetstatedata.h:29
#7  Breeze::WidgetStateData::~WidgetStateData (this=0x5619fe45b530, __in_chrg=<optimized out>) at ./obj-x86_64-linux-gnu/kstyle/breeze_autogen/4NBMFDNHZT/../../../../kstyle/animations/breezewidgetstatedata.h:31
#8  0x00007fddcc4c5d23 in QObject::event (this=0x5619fe45b530, e=0x5619fe248f90) at kernel/qobject.cpp:1301
#9  0x00007fddcd0bddc3 in QApplicationPrivate::notify_helper (this=this@entry=0x5619fc63c8c0, receiver=receiver@entry=0x5619fe45b530, e=e@entry=0x5619fe248f90) at kernel/qapplication.cpp:3637
#10 0x00007fddcd0c6bd8 in QApplication::notify (this=0x7ffce6409ce0, receiver=0x5619fe45b530, e=0x5619fe248f90) at kernel/qapplication.cpp:3161
#11 0x00007fddcc4983aa in QCoreApplication::notifyInternal2 (receiver=0x5619fe45b530, event=0x5619fe248f90) at ../../include/QtCore/5.15.4/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:332
#12 0x00007fddcc49acb1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x5619fc617480) at kernel/qcoreapplication.cpp:1821
#13 0x00007fddcc4f3617 in postEventSourceDispatch (s=0x5619fc658310) at kernel/qeventdispatcher_glib.cpp:277
#14 0x00007fddca9da17d in g_main_dispatch (context=0x5619fc65d8c0) at ../../../glib/gmain.c:3309
#15 g_main_context_dispatch (context=context@entry=0x5619fc65d8c0) at ../../../glib/gmain.c:3974
#16 0x00007fddca9da400 in g_main_context_iterate (context=context@entry=0x5619fc65d8c0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4047
#17 0x00007fddca9da4a3 in g_main_context_iteration (context=0x5619fc65d8c0, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#18 0x00007fddcc4f2c72 in QEventDispatcherGlib::processEvents (this=0x5619fc65d5d0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#19 0x00007fddcc496eab in QEventLoop::exec (this=this@entry=0x7ffce6409bc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#20 0x00007fddcc49f054 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#21 0x00005619fc3c208f in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:183

Reported using DrKonqi
Comment 1 Nate Graham 2022-05-25 15:33:34 UTC

*** This bug has been marked as a duplicate of bug 444599 ***