Bug 450754 - System Settings crashed after switching view mode and click on an item in the sidebar
Summary: System Settings crashed after switching view mode and click on an item in the...
Status: RESOLVED DUPLICATE of bug 444599
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.24.1
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-02-23 15:00 UTC by Jinesh Choksi
Modified: 2022-02-23 15:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jinesh Choksi 2022-02-23 15:00:42 UTC
Application: systemsettings (5.24.1)

Qt Version: 5.15.2
Frameworks Version: 5.90.0
Operating System: Linux 5.16.10-1-default x86_64
Windowing System: X11
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.24.1 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
In System Settings, switched from icons only view mode to side bar view mode and then closed the app.

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  QWeakPointer<QObject>::~QWeakPointer (this=<optimized out>, this=<optimized out>) at /usr/include/c++/11/bits/atomic_base.h:385
#7  QPointer<Breeze::Animation>::~QPointer (this=<optimized out>, this=<optimized out>) at /usr/include/qt5/QtCore/qpointer.h:53
#8  Breeze::GenericData::~GenericData (this=<optimized out>, this=<optimized out>) at /usr/src/debug/breeze-5.24.1-1.1.x86_64/build/kstyle/breeze_autogen/4NBMFDNHZT/../../../../kstyle/animations/breezegenericdata.h:20
#9  Breeze::WidgetStateData::~WidgetStateData (this=<optimized out>, this=<optimized out>) at /usr/src/debug/breeze-5.24.1-1.1.x86_64/build/kstyle/breeze_autogen/4NBMFDNHZT/../../../../kstyle/animations/breezewidgetstatedata.h:32
#10 Breeze::EnableData::~EnableData (this=<optimized out>, this=<optimized out>) at /usr/src/debug/breeze-5.24.1-1.1.x86_64/build/kstyle/breeze_autogen/4NBMFDNHZT/../../../../kstyle/animations/breezeenabledata.h:16
#11 Breeze::EnableData::~EnableData (this=<optimized out>, this=<optimized out>) at /usr/src/debug/breeze-5.24.1-1.1.x86_64/build/kstyle/breeze_autogen/4NBMFDNHZT/../../../../kstyle/animations/breezeenabledata.h:16
#12 0x00007f50fcb0524f in QObject::event (this=0x555dcd611f00, e=0x555dcdaff550) at kernel/qobject.cpp:1301
#13 0x00007f50fd78ba7f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x555dcd611f00, e=0x555dcdaff550) at kernel/qapplication.cpp:3632
#14 0x00007f50fcad8e3a in QCoreApplication::notifyInternal2 (receiver=0x555dcd611f00, event=0x555dcdaff550) at kernel/qcoreapplication.cpp:1064
#15 0x00007f50fcadbe77 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x555dcd1cb480) at kernel/qcoreapplication.cpp:1821
#16 0x00007f50fcb30d03 in postEventSourceDispatch (s=s@entry=0x555dcd2e4a40) at kernel/qeventdispatcher_glib.cpp:277
#17 0x00007f50fa5f0e22 in g_main_dispatch (context=0x7f50f0005010) at ../glib/gmain.c:3381
#18 g_main_context_dispatch (context=0x7f50f0005010) at ../glib/gmain.c:4099
#19 0x00007f50fa5f11b8 in g_main_context_iterate (context=context@entry=0x7f50f0005010, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#20 0x00007f50fa5f126f in g_main_context_iteration (context=0x7f50f0005010, may_block=1) at ../glib/gmain.c:4240
#21 0x00007f50fcb30384 in QEventDispatcherGlib::processEvents (this=0x555dcd2f3bf0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#22 0x00007f50fcad783b in QEventLoop::exec (this=this@entry=0x7ffe9c5c59f0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#23 0x00007f50fcadfb10 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#24 0x00007f50fd02d25c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#25 0x00007f50fd78b9f5 in QApplication::exec () at kernel/qapplication.cpp:2824
#26 0x0000555dcc175eb7 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/systemsettings5-5.24.1-1.1.x86_64/app/main.cpp:183
[Inferior 1 (process 5062) detached]

The reporter indicates this bug may be a duplicate of or related to bug 444599.

Possible duplicates by query: bug 450565.

Reported using DrKonqi
Comment 1 Fushan Wen 2022-02-23 15:04:42 UTC

*** This bug has been marked as a duplicate of bug 444599 ***