Bug 440257 - Kdeinit5 crash when generating thumbnail
Summary: Kdeinit5 crash when generating thumbnail
Status: RESOLVED DUPLICATE of bug 439219
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-25 12:07 UTC by Evstifeev Roman
Modified: 2021-07-28 20:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
file that crashes kdeinit5 (1.54 MB, image/x-exr)
2021-07-25 12:07 UTC, Evstifeev Roman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Evstifeev Roman 2021-07-25 12:07:10 UTC
Created attachment 140322 [details]
file that crashes kdeinit5

Kdeinit5 crash when dolphin tries to generate thumbnail for hdr file.
 
STEPS TO REPRODUCE
1. download attached file kloofendal_38d_partly_cloudy_1k.exr
2. open download directory dolphin
3. click "show previews" in dolphin toolbar or menu

OBSERVED RESULT
Thumbnail is not generated.
kdeinit5 crashes with backtrace:

Application: kdeinit5 (kdeinit5), signal: Aborted
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7fc44aa91ec0 (LWP 3886))]
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:49
#7  0x00007fc44c50e864 in __GI_abort () at abort.c:79
#8  0x00007fc44c2d79b6 in __gnu_cxx::__verbose_terminate_handler () at ../../../../libstdc++-v3/libsupc++/vterminate.cc:95
#9  0x00007fc44c2e319c in __cxxabiv1::__terminate (handler=<optimized out>) at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
#10 0x00007fc44c2e3207 in std::terminate () at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:58
#11 0x00007fc44c2e34fd in __cxxabiv1::__cxa_rethrow () at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:133
#12 0x00007fc42015b63e in Imf_2_5::InputFile::InputFile (this=<optimized out>, fileName=<optimized out>, numThreads=<optimized out>, this=<optimized out>, fileName=<optimized out>, numThreads=<optimized out>) at /usr/src/debug/openexr-2.5.6-1.1.x86_64/OpenEXR/IlmImf/ImfInputFile.cpp:497
#13 0x00007fc44407a616 in EXRCreator::create (this=this@entry=0x5556d9bb3a50, path=..., img=...) at /usr/src/debug/kio-extras5-21.04.3-1.2.x86_64/thumbnail/exrcreator.cpp:45
#14 0x00007fc448b6543b in ThumbnailProtocol::get (this=0x7fff5d30a390, url=...) at /usr/src/debug/kio-extras5-21.04.3-1.2.x86_64/thumbnail/thumbnail.cpp:241
#15 0x00007fc448bf288e in KIO::SlaveBase::dispatch (this=0x7fff5d30a390, command=67, data=...) at /usr/src/debug/kio-5.84.0-1.2.x86_64/src/core/slavebase.cpp:1216
#16 0x00007fc448bea266 in KIO::SlaveBase::dispatchLoop (this=0x7fff5d30a390) at /usr/src/debug/kio-5.84.0-1.2.x86_64/src/core/slavebase.cpp:335
#17 0x00007fc448b62766 in kdemain (argc=<optimized out>, argv=0x5556d98a9130) at /usr/src/debug/kio-extras5-21.04.3-1.2.x86_64/thumbnail/thumbnail.cpp:124
#18 0x00005556d79d7ae8 in launch (argc=argc@entry=4, _name=_name@entry=0x5556d9885048 "/usr/lib64/qt5/plugins/kf5/kio/thumbnail.so", args=0x5556d98850e4 "", args@entry=0x5556d9885074 "thumbnail", cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x5556d98850ec "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x5556d79da175 "0") at /usr/src/debug/kinit-5.84.0-1.1.x86_64/src/kdeinit/kinit.cpp:692
#19 0x00005556d79d928b in handle_launcher_request (sock=8, who=<optimized out>) at /usr/src/debug/kinit-5.84.0-1.1.x86_64/src/kdeinit/kinit.cpp:1130
#20 0x00005556d79d98c0 in handle_requests (waitForPid=waitForPid@entry=0) at /usr/src/debug/kinit-5.84.0-1.1.x86_64/src/kdeinit/kinit.cpp:1323
#21 0x00005556d79d461a in main (argc=3, argv=<optimized out>) at /usr/src/debug/kinit-5.84.0-1.1.x86_64/src/kdeinit/kinit.cpp:1761
[Inferior 1 (process 3886) detached]


EXPECTED RESULT
Thumbnail should be generated without a crash.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210723
KDE Plasma Version: 5.22.3
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.2-1-default (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 4600H with Radeon Graphics
Memory: 30.7 GiB of RAM
Graphics Processor: AMD RENOIR
Comment 1 Tony 2021-07-28 20:08:55 UTC

*** This bug has been marked as a duplicate of bug 439219 ***