Bug 442552 - Crash when creating a new file on an FTP server
Summary: Crash when creating a new file on an FTP server
Status: RESOLVED DUPLICATE of bug 433347
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 21.08.1
Platform: Neon Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-09-16 18:42 UTC by aronkvh
Modified: 2022-01-17 12:43 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.47 KB, text/plain)
2022-01-03 10:56 UTC, Fushan Wen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aronkvh 2021-09-16 18:42:18 UTC
Application: dolphin (21.08.1)

Qt Version: 5.15.3
Frameworks Version: 5.86.0
Operating System: Linux 5.11.0-25-generic x86_64
Windowing System: X11
Drkonqi Version: 5.22.5
Distribution: KDE neon User Edition 5.22

-- Information about the crash:
- What I was doing when the application crashed:

I clicked create new, and typed an ftp filename. I always get 405 login OK (failed), but most of the time Dolphin also crashes when doing this.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[New LWP 28522]
[New LWP 28523]
[New LWP 28533]
[New LWP 28534]
[New LWP 28535]
[New LWP 28536]
[New LWP 28543]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007fa33b7b8aff in __GI___poll (fds=0x7fff2e294538, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
[Current thread is 1 (Thread 0x7fa336d759c0 (LWP 28514))]

Thread 8 (Thread 0x7fa30f7fe700 (LWP 28543)):
#0  0x00007fa3398492b8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fa33984a82b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa33984b29b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa33984b4a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa33bd865eb in QEventDispatcherGlib::processEvents (this=0x7fa2e8000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007fa33bd2a87b in QEventLoop::exec (this=this@entry=0x7fa30f7fdbe0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#6  0x00007fa33bb44292 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#7  0x00007fa33bb4542c in QThreadPrivate::start (arg=0x5561ee50f930) at thread/qthread_unix.cpp:329
#8  0x00007fa33a2c9609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007fa33b7c5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fa30ffff700 (LWP 28536)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561edf214c8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561edf21478, cond=0x5561edf214a0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561edf214a0, mutex=0x5561edf21478) at pthread_cond_wait.c:638
#3  0x00007fa315b49a4b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fa315b4964b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fa33a2c9609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fa33b7c5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7fa314838700 (LWP 28535)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561edf214c8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561edf21478, cond=0x5561edf214a0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561edf214a0, mutex=0x5561edf21478) at pthread_cond_wait.c:638
#3  0x00007fa315b49a4b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fa315b4964b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fa33a2c9609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fa33b7c5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fa315039700 (LWP 28534)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561edf214c8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561edf21478, cond=0x5561edf214a0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561edf214a0, mutex=0x5561edf21478) at pthread_cond_wait.c:638
#3  0x00007fa315b49a4b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fa315b4964b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fa33a2c9609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fa33b7c5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fa31583a700 (LWP 28533)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5561edf214c8) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5561edf21478, cond=0x5561edf214a0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5561edf214a0, mutex=0x5561edf21478) at pthread_cond_wait.c:638
#3  0x00007fa315b49a4b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fa315b4964b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fa33a2c9609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fa33b7c5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fa33530b700 (LWP 28523)):
#0  0x00007fa33b7b8aff in __GI___poll (fds=0x7fa3280150f0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fa33984b36e in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa33984b4a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa33bd865eb in QEventDispatcherGlib::processEvents (this=0x7fa328000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fa33bd2a87b in QEventLoop::exec (this=this@entry=0x7fa33530abb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007fa33bb44292 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007fa33cddef4b in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007fa33bb4542c in QThreadPrivate::start (arg=0x7fa33ce62d80) at thread/qthread_unix.cpp:329
#8  0x00007fa33a2c9609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007fa33b7c5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fa335f37700 (LWP 28522)):
#0  0x00007fa33b7b8aff in __GI___poll (fds=0x7fa335f36ae8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fa33a2ffc1a in ?? () from /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fa33a30190a in xcb_wait_for_event () from /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fa33666de88 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fa33bb4542c in QThreadPrivate::start (arg=0x5561eda99dd0) at thread/qthread_unix.cpp:329
#5  0x00007fa33a2c9609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fa33b7c5293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fa336d759c0 (LWP 28514)):
[KCrash Handler]
#4  QString::QString (other=..., this=0x7fff2e295168) at ../../include/QtCore/../../src/corelib/text/qstring.h:1093
#5  QWidgetLineControl::text (this=0x101010101010101) at ../../include/QtWidgets/5.15.3/QtWidgets/private/../../../../../src/widgets/widgets/qwidgetlinecontrol_p.h:241
#6  QLineEdit::text (this=<optimized out>) at widgets/qlineedit.cpp:312
#7  0x00007fa33ddec9ac in ?? () from /lib/x86_64-linux-gnu/libKF5KIOFileWidgets.so.5
#8  0x00007fa33bd62d9e in QtPrivate::QSlotObjectBase::call (a=0x7fff2e295330, r=0x5561edf0c220, this=0x5561ee99a8c0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#9  doActivate<false> (sender=0x5561ee9cec80, signal_index=6, argv=0x7fff2e295330) at kernel/qobject.cpp:3886
#10 0x00007fa33bd5c167 in QMetaObject::activate (sender=sender@entry=0x5561ee9cec80, m=m@entry=0x7fa33cfea720 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff2e295330) at kernel/qobject.cpp:3946
#11 0x00007fa33cf96b90 in KJob::result (this=this@entry=0x5561ee9cec80, _t1=<optimized out>, _t1@entry=0x5561ee9cec80, _t2=...) at ./obj-x86_64-linux-gnu/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:631
#12 0x00007fa33cf9794b in KJob::finishJob (this=0x5561ee9cec80, emitResult=<optimized out>) at ./src/lib/jobs/kjob.cpp:97
#13 0x00007fa33d8aceb8 in KIO::SimpleJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#14 0x00007fa33d8b297e in KIO::StatJob::slotFinished() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#15 0x00007fa33d8ab0d0 in KIO::SimpleJob::slotError(int, QString const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#16 0x00007fa33bd62d9e in QtPrivate::QSlotObjectBase::call (a=0x7fff2e2955d0, r=0x5561ee9cec80, this=0x5561ee9a22a0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#17 doActivate<false> (sender=0x5561ee9cad10, signal_index=5, argv=0x7fff2e2955d0) at kernel/qobject.cpp:3886
#18 0x00007fa33d8779aa in KIO::SlaveInterface::error(int, QString const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#19 0x00007fa33d87a4c6 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#20 0x00007fa33d87816f in KIO::SlaveInterface::dispatch() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#21 0x00007fa33d8810d2 in KIO::Slave::gotInput() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#22 0x00007fa33bd62d9e in QtPrivate::QSlotObjectBase::call (a=0x7fff2e295820, r=0x5561ee9cad10, this=0x5561ee9cb870) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#23 doActivate<false> (sender=0x5561ee9cecf0, signal_index=3, argv=0x7fff2e295820) at kernel/qobject.cpp:3886
#24 0x00007fa33bd59919 in QObject::event (this=0x5561ee9cecf0, e=0x5561ee724ec0) at kernel/qobject.cpp:1314
#25 0x00007fa33c807dc3 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5561ee9cecf0, e=0x5561ee724ec0) at kernel/qapplication.cpp:3632
#26 0x00007fa33c810bb8 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3156
#27 0x00007fa33bd2bd7a in QCoreApplication::notifyInternal2 (receiver=0x5561ee9cecf0, event=0x5561ee724ec0) at ../../include/QtCore/5.15.3/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#28 0x00007fa33bd2e681 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x5561eda6fef0) at kernel/qcoreapplication.cpp:1821
#29 0x00007fa33bd86f77 in postEventSourceDispatch (s=0x5561edbab980) at kernel/qeventdispatcher_glib.cpp:277
#30 0x00007fa33984b17d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fa33984b400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007fa33984b4a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007fa33bd865d2 in QEventDispatcherGlib::processEvents (this=0x5561edbc2140, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#34 0x00007fa33bd2a87b in QEventLoop::exec (this=this@entry=0x7fff2e295dd0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#35 0x00007fa33bd32a34 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#36 0x00005561ec02ffb2 in main (argc=<optimized out>, argv=<optimized out>) at ./src/main.cpp:222
[Inferior 1 (process 28514) detached]

The reporter indicates this bug may be a duplicate of or related to bug 433347.

Possible duplicates by query: bug 82199, bug 439877, bug 439609, bug 439303, bug 437442.

Reported using DrKonqi
Comment 1 Fushan Wen 2022-01-03 10:56:08 UTC
Created attachment 145073 [details]
New crash information added by DrKonqi

dolphin (22.03.70) using Qt 5.15.2

- What I was doing when the application crashed:
Creating a file from templates on a sftp server.

-- Backtrace (Reduced):
#6  QString::QString(QString const&) (other=..., this=0x7fffbe7bf258) at ../../include/QtCore/../../src/corelib/text/qstring.h:1093
#7  QWidgetLineControl::text() const (this=0x6f66736e61727420) at ../../include/QtWidgets/5.15.2/QtWidgets/private/../../../../../src/widgets/widgets/qwidgetlinecontrol_p.h:241
#8  QLineEdit::text() const (this=<optimized out>) at widgets/qlineedit.cpp:312
#9  0x00007f2feb870b83 in KNewFileMenuPrivate::_k_slotStatResult(KJob*) (job=0x5620f1ce9e80, this=0x5620f0758500) at /usr/src/debug/kio-5.89.0git.20220102T093626~da163f5c9-ku.25.1.x86_64/src/filewidgets/knewfilemenu.cpp:1233
#10 operator() (job=0x5620f1ce9e80, __closure=<optimized out>) at /usr/src/debug/kio-5.89.0git.20220102T093626~da163f5c9-ku.25.1.x86_64/src/filewidgets/knewfilemenu.cpp:1210
Comment 2 Nicolas Fella 2022-01-17 12:43:29 UTC

*** This bug has been marked as a duplicate of bug 433347 ***