Bug 439609 - crash creating folder on MTP device
Summary: crash creating folder on MTP device
Status: RESOLVED DUPLICATE of bug 433347
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 20.12.2
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-07-07 18:33 UTC by Clemens Eisserer
Modified: 2021-07-16 22:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (2.82 KB, text/plain)
2021-07-16 22:35 UTC, m.danai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2021-07-07 18:33:29 UTC
Application: dolphin (20.12.2)

Qt Version: 5.15.2
Frameworks Version: 5.79.0
Operating System: Linux 5.12.13-200.fc33.x86_64 x86_64
Windowing system: X11
Distribution: "Fedora release 33 (Thirty Three)"

-- Information about the crash:
- What I was doing when the application crashed:

When I created a new folder (using the right-click context menu New->Folder) on my Huawei P20 phone, Dolphin immediatly crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  0x00007fa384ad2189 in QLineEdit::text() const () from /lib64/libQt5Widgets.so.5
#5  0x00007fa385bc1c48 in QtPrivate::QFunctorSlotObject<KNewFileMenuPrivate::_k_slotTextChanged(QString const&)::{lambda(KJob*)#3}, 1, QtPrivate::List<KJob*>, void>::impl(int, QtPrivate::QSlotObjectBase*, QObject*, void**, bool*) [clone .lto_priv.0] () from /lib64/libKF5KIOFileWidgets.so.5
#6  0x00007fa383e65386 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#7  0x00007fa384f891c0 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#8  0x00007fa384f8de8b in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#9  0x00007fa383e65386 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#10 0x00007fa385725f6a in KIO::SlaveInterface::error(int, QString const&) () from /lib64/libKF5KIOCore.so.5
#11 0x00007fa385725637 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib64/libKF5KIOCore.so.5
#12 0x00007fa38571e05d in KIO::SlaveInterface::dispatch() () from /lib64/libKF5KIOCore.so.5
#13 0x00007fa3857277a2 in KIO::Slave::gotInput() () from /lib64/libKF5KIOCore.so.5
#14 0x00007fa383e65386 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#15 0x00007fa383e5dd1e in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007fa38498eec3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#17 0x00007fa383e35bd8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#18 0x00007fa383e388c7 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#19 0x00007fa383e82c27 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#20 0x00007fa381ddea9f in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#21 0x00007fa381e30a98 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#22 0x00007fa381ddbe73 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#23 0x00007fa383e826f3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#24 0x00007fa383e3457b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#25 0x00007fa383e3c1b4 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#26 0x00007fa385f75d5e in kdemain () from /lib64/libkdeinit5_dolphin.so
#27 0x00007fa385d7b1e2 in ?? () from /lib64/libc.so.6
#28 0x000055ec1d7f00ae in _start ()
[Inferior 1 (process 5056) detached]

Possible duplicates by query: bug 439605, bug 439542, bug 439303, bug 439043, bug 438933.

Reported using DrKonqi
Comment 1 Harald Sitter 2021-07-08 09:43:16 UTC

*** This bug has been marked as a duplicate of bug 433347 ***
Comment 2 m.danai 2021-07-16 22:35:50 UTC
Created attachment 140129 [details]
New crash information added by DrKonqi

dolphin (21.04.3) using Qt 5.15.2

- What I was doing when the application crashed:

Creating folder on phone via MTP. Dolphin crashes everytime after creating a folder.

- Custom settings of the application:

n/a

-- Backtrace (Reduced):
#4  0x00007f5b70d12bab in QLineEdit::text() const () from /usr/lib/libQt5Widgets.so.5
[...]
#7  0x00007f5b7133bdbd in KJob::result(KJob*, KJob::QPrivateSignal) () from /usr/lib/libKF5CoreAddons.so.5
#8  0x00007f5b7133cbec in KJob::finishJob(bool) () from /usr/lib/libKF5CoreAddons.so.5
[...]
#10 0x00007f5b71b77187 in KIO::SlaveInterface::error(int, QString const&) () from /usr/lib/libKF5KIOCore.so.5
#11 0x00007f5b71b79335 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libKF5KIOCore.so.5