Bug 439303 - Dolphin crashed when I created a new folder in gdrive://
Summary: Dolphin crashed when I created a new folder in gdrive://
Status: RESOLVED DUPLICATE of bug 433347
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 21.04.2
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-06-29 14:37 UTC by Christian Hartmann
Modified: 2021-07-01 09:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Hartmann 2021-06-29 14:37:42 UTC
Application: dolphin (21.04.2)

Qt Version: 5.15.2
Frameworks Version: 5.83.0
Operating System: Linux 5.12.12-1-default x86_64
Windowing System: X11
Drkonqi Version: 5.22.1
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed:

I copied a file from a SMB share and created a folder within gdrive:// where I wanted to store the file. After hitting Enter in the create folder dialog Dolphin crashed

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7f494cb29d00 (LWP 18751))]
[KCrash Handler]
#6  QString::QString (other=..., this=0x7fff168dde68) at ../../include/QtCore/../../src/corelib/text/qstring.h:1093
#7  QWidgetLineControl::text (this=0x91) at ../../include/QtWidgets/5.15.2/QtWidgets/private/../../../../../src/widgets/widgets/qwidgetlinecontrol_p.h:241
#8  QLineEdit::text (this=<optimized out>) at widgets/qlineedit.cpp:312
#9  0x00007f4951bcf380 in KNewFileMenuPrivate::_k_slotStatResult (job=0x7f493c0376c0, this=0x5592b04376b0) at /usr/src/debug/kio-5.83.0-1.1.x86_64/src/filewidgets/knewfilemenu.cpp:1265
#10 operator() (job=0x7f493c0376c0, __closure=<optimized out>) at /usr/src/debug/kio-5.83.0-1.1.x86_64/src/filewidgets/knewfilemenu.cpp:1246
#11 QtPrivate::FunctorCall<QtPrivate::IndexesList<0>, QtPrivate::List<KJob*>, void, KNewFileMenuPrivate::_k_slotTextChanged(const QString&)::<lambda(KJob*)> >::call (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:146
#12 QtPrivate::Functor<KNewFileMenuPrivate::_k_slotTextChanged(const QString&)::<lambda(KJob*)>, 1>::call<QtPrivate::List<KJob*>, void> (arg=<optimized out>, f=...) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:256
#13 QtPrivate::QFunctorSlotObject<KNewFileMenuPrivate::_k_slotTextChanged(const QString&)::<lambda(KJob*)>, 1, QtPrivate::List<KJob*>, void>::impl (which=<optimized out>, r=<optimized out>, ret=<optimized out>, a=<optimized out>, this_=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:443
#14 QtPrivate::QFunctorSlotObject<KNewFileMenuPrivate::_k_slotTextChanged(const QString&)::<lambda(KJob*)>, 1, QtPrivate::List<KJob*>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:436
#15 0x00007f494fd8d103 in QtPrivate::QSlotObjectBase::call (a=0x7fff168de020, r=0x5592b0465590, this=0x5592b133bf70) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#16 doActivate<false> (sender=0x7f493c0376c0, signal_index=6, argv=0x7fff168de020) at kernel/qobject.cpp:3886
#17 0x00007f494fd865cf in QMetaObject::activate (sender=sender@entry=0x7f493c0376c0, m=<optimized out>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff168de020) at kernel/qobject.cpp:3946
#18 0x00007f4950fec9cc in KJob::result (this=this@entry=0x7f493c0376c0, _t1=<optimized out>, _t1@entry=0x7f493c0376c0, _t2=...) at /usr/src/debug/kcoreaddons-5.83.0-1.1.x86_64/build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:636
#19 0x00007f4950ff1303 in KJob::finishJob (this=0x7f493c0376c0, emitResult=<optimized out>) at /usr/src/debug/kcoreaddons-5.83.0-1.1.x86_64/src/lib/jobs/kjob.cpp:97
#20 0x00007f494fd8d103 in QtPrivate::QSlotObjectBase::call (a=0x7fff168de150, r=0x7f493c0376c0, this=0x7f493c0365a0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#21 doActivate<false> (sender=0x5592b1132dc0, signal_index=5, argv=0x7fff168de150) at kernel/qobject.cpp:3886
#22 0x00007f494fd865cf in QMetaObject::activate (sender=<optimized out>, m=<optimized out>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7fff168de150) at kernel/qobject.cpp:3946
#23 0x00007f4951755316 in KIO::SlaveInterface::error (this=<optimized out>, _t1=<optimized out>, _t2=...) at /usr/src/debug/kio-5.83.0-1.1.x86_64/build/src/core/KF5KIOCore_autogen/include/moc_slaveinterface.cpp:452
#24 0x00007f4951754a47 in KIO::SlaveInterface::dispatch (this=0x5592b1132dc0, _cmd=102, rawdata=...) at /usr/src/debug/kio-5.83.0-1.1.x86_64/src/core/slaveinterface.cpp:181
#25 0x00007f495174d289 in KIO::SlaveInterface::dispatch (this=0x5592b1132dc0) at /usr/src/debug/kio-5.83.0-1.1.x86_64/src/core/slaveinterface.cpp:78
#26 0x00007f4951756a3a in KIO::Slave::gotInput (this=0x5592b1132dc0) at /usr/src/debug/kio-5.83.0-1.1.x86_64/src/core/slave.cpp:392
#27 0x00007f494fd8d103 in QtPrivate::QSlotObjectBase::call (a=0x7fff168de370, r=0x5592b1132dc0, this=0x5592b0ade0e0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#28 doActivate<false> (sender=0x5592b0851530, signal_index=3, argv=0x7fff168de370) at kernel/qobject.cpp:3886
#29 0x00007f494fd830ae in QObject::event (this=0x5592b0851530, e=0x5592b1129bb0) at kernel/qobject.cpp:1314
#30 0x00007f49509dba5f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5592b0851530, e=0x5592b1129bb0) at kernel/qapplication.cpp:3632
#31 0x00007f494fd56aba in QCoreApplication::notifyInternal2 (receiver=0x5592b0851530, event=0x5592b1129bb0) at kernel/qcoreapplication.cpp:1063
#32 0x00007f494fd59b07 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x5592b00e0c60) at kernel/qcoreapplication.cpp:1817
#33 0x00007f494fdaea83 in postEventSourceDispatch (s=s@entry=0x5592b01d6160) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f494da3180f in g_main_dispatch (context=0x7f4944005000) at ../glib/gmain.c:3337
#35 g_main_context_dispatch (context=0x7f4944005000) at ../glib/gmain.c:4055
#36 0x00007f494da31b98 in g_main_context_iterate (context=context@entry=0x7f4944005000, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4131
#37 0x00007f494da31c4f in g_main_context_iteration (context=0x7f4944005000, may_block=1) at ../glib/gmain.c:4196
#38 0x00007f494fdae104 in QEventDispatcherGlib::processEvents (this=0x5592b01de680, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#39 0x00007f494fd554cb in QEventLoop::exec (this=this@entry=0x7fff168de780, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#40 0x00007f494fd5d7a0 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#41 0x00007f495027d1fc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#42 0x00007f49509db9d5 in QApplication::exec () at kernel/qapplication.cpp:2824
#43 0x00007f4951f7c413 in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/dolphin-21.04.2-2.1.x86_64/src/main.cpp:205
#44 0x00007f4951d7eb35 in __libc_start_main (main=0x5592ae609050 <main(int, char**)>, argc=1, argv=0x7fff168dea58, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff168dea48) at ../csu/libc-start.c:332
#45 0x00005592ae60908e in _start () at ../sysdeps/x86_64/start.S:120
[Inferior 1 (process 18751) detached]

Possible duplicates by query: bug 429973, bug 424760, bug 410345, bug 409383, bug 384419.

Reported using DrKonqi
Comment 1 Harald Sitter 2021-07-01 09:50:51 UTC

*** This bug has been marked as a duplicate of bug 433347 ***