Bug 422533 - Akonadi crash on load
Summary: Akonadi crash on load
Status: RESOLVED WORKSFORME
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Archive Mail Agent (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2020-06-06 12:25 UTC by Cyrille Dunant
Modified: 2022-11-09 05:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyrille Dunant 2020-06-06 12:25:30 UTC
Application: akonadi_archivemail_agent (5.14.44 (20.07.40))

Qt Version: 5.15.0
Frameworks Version: 5.71.0
Operating System: Linux 5.6.14-1-default x86_64
Windowing system: X11
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- Unusual behavior I noticed:

This may have occurred because of the upgrade to Qt5.15. 

Every other agent crashes also.

The crash can be reproduced every time.

-- Backtrace:
Application: akonadi_archivemail_agent (akonadi_archivemail_agent), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f304bbbfb72 in std::__atomic_base<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_acquire, this=0x38) at /usr/include/c++/10/bits/atomic_base.h:741
#5  0x00007f304bbbfb72 in std::atomic<QThreadData*>::load(std::memory_order) const (__m=std::memory_order_acquire, this=0x38) at /usr/include/c++/10/atomic:523
#6  0x00007f304bbbfb72 in QAtomicOps<QThreadData*>::loadAcquire<QThreadData*>(std::atomic<QThreadData*> const&) (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:251
#7  0x00007f304bbbfb72 in QBasicAtomicPointer<QThreadData>::loadAcquire() const (this=0x38) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:255
#8  0x00007f304bbbfb72 in QBasicAtomicPointer<QThreadData>::operator QThreadData*() const (this=0x38) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:251
#9  0x00007f304bbbfb72 in QObjectPrivate::connectImpl(QObject const*, int, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) (sender=0x555d64f97680, signal_index=3, receiver=0x555d64fd0710, slot=0x0, slotObj=0x555d65012050, type=Qt::AutoConnection, types=0x0, senderMetaObject=0x555d63d8e4a0 <QTimer::staticMetaObject>) at kernel/qobject.cpp:5053
#10 0x00007f304bbc00a5 in QObject::connectImpl(QObject const*, void**, QObject const*, void**, QtPrivate::QSlotObjectBase*, Qt::ConnectionType, int const*, QMetaObject const*) (sender=sender@entry=0x555d64f97680, signal=signal@entry=0x7ffee050d770, receiver=receiver@entry=0x555d64fd0710, slot=slot@entry=0x0, slotObj=0x555d65012050, type=Qt::AutoConnection, types=0x0, senderMetaObject=<optimized out>) at kernel/qobject.cpp:5001
#11 0x00007f304c7dfae4 in QObject::connect<void (QTimer::*)(QTimer::QPrivateSignal), Akonadi::CollectionFetchJobPrivate::CollectionFetchJobPrivate(Akonadi::CollectionFetchJob*)::{lambda()#1}>(QtPrivate<void (QTimer::*)(QTimer::QPrivateSignal)>::Object const*, std::enable_if<QtPrivate::FunctionPointer<Akonadi::CollectionFetchJobPrivate::CollectionFetchJobPrivate(Akonadi::CollectionFetchJob*)::{lambda()#1}>::ArgumentCount==(-1), QMetaObject::Connection>::type, QObject const*, QtPrivate::FunctionPointer, Qt::ConnectionType) (type=Qt::AutoConnection, slot=..., context=<optimized out>, signal=(void (QTimer::*)(QTimer * const, QTimer::QPrivateSignal)) 0x7f304bbccec0 <QTimer::timeout(QTimer::QPrivateSignal)>, sender=0x555d64f97680) at /usr/include/qt5/QtCore/qobject.h:322
#12 0x00007f304c7dfae4 in Akonadi::CollectionFetchJobPrivate::CollectionFetchJobPrivate(Akonadi::CollectionFetchJob*) (parent=0x555d64fd0710, this=0x555d64f97620) at /usr/src/debug/akonadi-server-20.07.70git.20200603T160120~f7294de07-ku.40.1.x86_64/src/core/jobs/collectionfetchjob.cpp:49
#13 0x00007f304c7dfae4 in Akonadi::CollectionFetchJob::CollectionFetchJob(Akonadi::Collection const&, Akonadi::CollectionFetchJob::Type, QObject*) (this=0x555d64fd0710, collection=..., type=Akonadi::CollectionFetchJob::Recursive, parent=0x555d64f9c330, this=<optimized out>, collection=..., type=<optimized out>, parent=<optimized out>) at /usr/src/debug/akonadi-server-20.07.70git.20200603T160120~f7294de07-ku.40.1.x86_64/src/core/jobs/collectionfetchjob.cpp:124
#14 0x00007f304c7a3d87 in Akonadi::EntityTreeModelPrivate::fetchCollections(Akonadi::Collection const&, Akonadi::CollectionFetchJob::Type) (this=0x555d64f82970, collection=..., type=Akonadi::CollectionFetchJob::Recursive) at /usr/src/debug/akonadi-server-20.07.70git.20200603T160120~f7294de07-ku.40.1.x86_64/src/core/models/entitytreemodel_p.cpp:295
#15 0x00007f304c7a86be in Akonadi::EntityTreeModelPrivate::startFirstListJob() (this=0x555d64f82970) at /usr/src/debug/akonadi-server-20.07.70git.20200603T160120~f7294de07-ku.40.1.x86_64/src/core/models/entitytreemodel_p.cpp:1440
#16 0x00007f304c7aafec in Akonadi::EntityTreeModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/akonadi-server-20.07.70git.20200603T160120~f7294de07-ku.40.1.x86_64/src/core/models/entitytreemodel.h:672
#17 0x00007f304bbbea31 in QObject::event(QEvent*) (this=0x555d64f99450, e=0x555d64f99780) at kernel/qobject.cpp:1314
#18 0x00007f304c0830cf in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=<optimized out>, receiver=0x555d64f99450, e=0x555d64f99780) at kernel/qapplication.cpp:3671
#19 0x00007f304bb92b0a in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x555d64f99450, event=0x555d64f99780) at ../../include/QtCore/5.15.0/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#20 0x00007f304bb95531 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=0x0, event_type=0, data=0x555d64b0cb60) at kernel/qcoreapplication.cpp:1815
#21 0x00007f304bbea8c3 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x555d64c3ea90) at kernel/qeventdispatcher_glib.cpp:277
#22 0x00007f3048c802c7 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
#23 0x00007f3048c80648 in  () at /usr/lib64/libglib-2.0.so.0
#24 0x00007f3048c806ff in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
#25 0x00007f304bbe9f4f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x555d64c465e0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#26 0x00007f304bb914cb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffee050dd30, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#27 0x00007f304bb99730 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#28 0x00007f304cb8e96e in Akonadi::AgentBase::init(Akonadi::AgentBase&) (r=...) at /usr/include/qt5/QtCore/qcoreapplication.h:116
#29 0x0000555d63d82c9a in Akonadi::AgentBase::init<ArchiveMailAgent>(int, char**) (argv=<optimized out>, argc=<optimized out>) at /usr/src/debug/kmail-20.07.70git.20200602T090355~248993415-ku.59.1.x86_64/agents/archivemailagent/archivemailagent.cpp:75
#30 0x0000555d63d82c9a in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kmail-20.07.70git.20200602T090355~248993415-ku.59.1.x86_64/agents/archivemailagent/archivemailagent.cpp:152
[Inferior 1 (process 7518) detached]

Reported using DrKonqi
Comment 1 Justin Zobel 2022-10-10 11:16:39 UTC
Thank you for reporting this crash in KDE software. As it has been a while since this issue was reported, can we please ask you to see if you can reproduce the crash with a recent software version?

If you can reproduce the issue, please change the status to "CONFIRMED" when replying. Thank you!
Comment 2 Bug Janitor Service 2022-10-25 05:00:51 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2022-11-09 05:12:13 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!