Bug 438883 - Re-implement Desktop Cube effect with modern effects API
Summary: Re-implement Desktop Cube effect with modern effects API
Status: CLOSED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 5.23.0
Platform: Neon Linux
: HI wishlist
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 443410 455130 462475 462982 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-06-18 19:08 UTC by Patrick Silva
Modified: 2024-03-01 04:16 UTC (History)
62 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0


Attachments
attachment-3402-0.html (2.11 KB, text/html)
2022-06-22 08:07 UTC, Marek Brunda
Details
attachment-1217957-0.html (1.54 KB, text/html)
2023-06-22 08:43 UTC, triffid.hunter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2021-06-18 19:08:44 UTC
STEPS TO REPRODUCE
1. open Desktop Effects KCM
2. search for "cube"
3. 

OBSERVED RESULT
Nothing found. Also it's impossible to set Desktop Cube effect in
Screen Edges, Touchpad and Virtual Desktops KCMs.

EXPECTED RESULT
Desktop Cube effect should be available

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 1 Nate Graham 2021-07-28 19:39:27 UTC
This was intentional; see https://invent.kde.org/plasma/kwin/-/merge_requests/1075

It may be possible to rewrite it in the future. Tracking that with this bug report.
Comment 2 Nate Graham 2021-10-08 15:29:33 UTC
*** Bug 443410 has been marked as a duplicate of this bug. ***
Comment 3 Scott Newton 2021-10-16 02:22:56 UTC
I would certainly like to see this back again. I've been using it for years and I cannot remember the last time it gave me any sort of issue, so not sure why it was removed in 5.23. I could understand if it was buggy, but, as I've said, it's been rock solid for me and I use it everyday. Personally I dislike both the fade and slide effects, so have always used the desktop cube effect. At the moment I'm back to using no effect. Thanks.
Comment 4 Petr 2021-10-16 10:15:21 UTC
(In reply to Nate Graham from comment #1)
> This was intentional; see
> https://invent.kde.org/plasma/kwin/-/merge_requests/1075
> 
> It may be possible to rewrite it in the future. Tracking that with this bug
> report.

this unique feature i have used since ... at least 10 years and it is the most distinguishing feature of any desktop sw. it has been the only feature, which hindered me to go for activities to have different widgets on different screens (since it has been abandoned from kde4). not having the cube is a totally different experience and i don't understand, why these nice features are just not taken care of in first place. so, so, so sad. please bring it back!
Comment 5 Petr 2021-10-16 16:20:03 UTC
workaround: downgrade to plasma 5.22.5 (about 85 packages) and insert an exception into dnf (/etc/dnf/dnf.conf) for all the packages. i will never update plasma until cube is back.
-> it is really sad, to see all my beloved features from kde4 going away. be it "keramik" window decorations, different backgrounds on desktops or now cube switcher.
Comment 6 Thomas Bettler 2021-10-16 19:01:53 UTC
I agree: it would be good if cube animation was restored
Comment 7 Paul Hands 2021-10-17 21:33:15 UTC
I want to add my voice to the list of people who hate that the Desktop Cube has been removed. I did a routine (246 items, no way to read all the change notes) update yesterday, which required a reboot, and when it came back up, that effect was just gone...no warning or option to not upgrade...how very like windows or apple..total disdain for the user. A KDE user since KDE 3 (way back in 2002) I've been using cube exclusively for at least 10 years, and it is, to me, one of the defining features that made KDE the best in its class.  I use it every day, all day.  Multiple desktops on the cube, each with a different focus...development, testing, documentation, multimedia, games...  This is likely to make me stop using KDE completely.  Is there any sign of a plan and timeline to rebuild it in QML, or shall I just try to go back to Compiz?  I guess it's time to see if Gnome is any good these days.
Comment 8 rbnmndz 2021-10-18 08:20:01 UTC
I also regret the lack of this effect. I'm adding here my voice because the assumption given at https://invent.kde.org/plasma/kwin/-/merge_requests/1075

"given that they are not used widely based on support information from various bug reports"

I've been using it long ago, and I had no reason to apply for a bug until now. 
I hope the dropping of this cube effect would be reconsiderate.
Comment 9 Maximilian Böhm 2021-10-18 17:50:04 UTC
Avid cube user here too. I have been using this effect since the Compiz days in 2007, switched over to Plasma 4’s Kwin in 2011 and used this effect ever since – including the switch animation and even associated a mouse button to activate cube view to turn the cube. It has been a tremendous effective demo for potential Linux switchers. I have even loved the 3D stacked view of floating windows in the cube view. ;((
The slide animation has no soul to it. It’s terribly sterile. And I’m loosing my mental concept of windows stacked in a virtual space.
What’s next, remove wobbly windows? Guys, that’s a bummer! ;((
If it had low statistic usage, maybe because it wasn’t the default? Just a wild guess.
If there is potential of a feature bounty, count me in to invest in restoring this jewel.

Addendum: Now discovered that the 3D window switch effect is gone too. Guuuys, I’m crying, that’s no overstatement. This better reproduction of Vista’s Flip 3D effect was my standard switcher and I LOOOOVED it SO MUCH! Such a great representation of all my windows in 3D space, it was truly a masterpiece with its swift & elegant animations and drew much attention of potential Linux switchers. You are crippling the user experience of your power users with this horrible premature choice.
(Copy of my text in bug 443410)
Comment 10 Nate Graham 2021-10-18 17:52:38 UTC
They will be added back, not to worry. I believe the Flip Switch effect is currently in progress, in fact.
Comment 11 Dean Schaf 2021-10-20 02:28:47 UTC
I am very disappointed that you have removed the coolest eye-candy
features from KDE Plasma, (Flip Switch and Desktop Cube).  They were
two of the gems that made me like KDE.  I used the glitz-n-glam
features since long ago, and now my KDE Plasma usage is utterly
boring, disjointed, and ugly.

Please bring back the 3-D Desktop Cube and Flip Switch (in all their
former glory).

Dismayed and gloomy,
Keltonix
Comment 12 Nate Graham 2021-10-20 02:34:49 UTC
They will be brought back; no need to add more, "Please bring them back!" comments. We know you folks expect this do be done and we'll do our best. :)
Comment 13 Scott Newton 2021-10-20 03:13:57 UTC
Thanks Nate. Much appreciated.
Comment 14 Felipe Gustavo de Oliveira 2021-10-24 13:10:23 UTC
Its the most usefull effect for usability. I use it since it was released for compiz.

Hope it gets love soon. I don't wanna see it burried like other usefull tools like superkaramba.
Comment 15 gtx.swift 2021-10-24 13:43:14 UTC
YeziR!?! Bringa backa the Flipetty Switchery!
Comment 16 Eugene 2021-10-29 14:18:04 UTC
A am also for that! Please, bring the cube back!
Comment 17 Mircea Kitsune 2021-11-19 22:39:19 UTC
Although I've no longer been using the desktop cube animation for a while, I second this request: Please don't actually remove it! The last thing an user wants to deal with, alongside running into any major bugs, is features they enjoy going away because someone wise thought it's too obscure to matter. Code cleanness and optimization is a great target to go by in everything, but I strongly believe it must be done without removing entire features with no alternative in place.

A bonus thought: This might be a good chance to implement a new and even better desktop cube. I always thought it would be nice if we could have proper 3D effects for windows, such as being able to drag them in full 3D space like sheets of paper. It would be a different feature and unrelated to this discussion, but goes well with the thought of putting something better in place if an older alternative felt less than optimal.
Comment 18 Marek Brunda 2021-11-22 08:18:39 UTC
Please return this feature. I have been using it for many years and I have never had a single problem with it. So far, I have downgraded and will not upgrade as long as possible. Then I will have to look for alternative solutions.
Comment 19 Grief 2021-11-23 10:45:58 UTC
KDE is going the way microsoft went with 11. Or gnome goes. Who had that brilliant idea to drop the feature without providing an alternative first?
Comment 20 Nate Graham 2021-12-25 21:22:44 UTC
The Cover Switch and Flip Switch effects were just rewritten in QML for Plasma 5.24; see Bug 443757. The Desktop Cube effect will be next! I doubt it will be ready for 5.24, but hopefully it'll be back for 5.24.
Comment 21 Terry Wang 2022-01-09 01:48:05 UTC
Only discovered the removal of several 

Ref: https://kde.org/announcements/changelogs/plasma/5/5.22.5-5.23.0/

Removed
- Effects: Remove Desktop Cube Animation effect. Commit.
- Effects: Remove Desktop Cube effect. Commit.
- Effects: Remove Cover Switch effect. Commit.
- Effects: Remove Flip Switch effect. Commit.

I understand the motivation behind the refactor / rewrite to modernize APIs and etc., however, how do you (dev team) conclude that "they are not used widely based on support information from various bug reports and our available man power is sparse, the most reasonable thing is to drop the effect, unfortunately." ???

This engineering mindset - "We've built great things, if users don't know how to use / adapt, it's their problem" can't be accepted.

This reminds me the removal of GNOME 3.8 fallback mode, where integration with Compiz (Fusion) went completely broken. It appears that the GNOME developers know more about user behaviours than their users and therefore made the decision on their behalf without consulting users.

I've switched to KDE 4.10 SC because of the disappointment at GNOME 3 (3.8 to be accurate). I was surprised to find most of the effects - eye-candies that I care about, embedded to my daily routine were implemented by KWin, happy till recently when I found the cube effect when switching workspaces (virtual desktops) were gone in KWin 5.23 (I run Manjaro with KDE on Pi 4 8GB model and an old MacBook).

Please reimplement these effects when appropriate. We don't want to see the classic representation of Linux desktop eye-candies fade away.
Comment 22 Adam Wenocur 2022-02-11 20:40:31 UTC
long-time Plasma user here, since KDE 3.0.

I created an account on this bugzilla, having never had complaints about KDE in the past twenty years. My first issue is to add my voice to this list requesting the cube transition be returned. I started running 5.23.5 last month, as it was declared stable in the Gentoo main portage tree. I appreciate the reason for it and look forward to better compositing, but the 3D animated transitions are not a niche feature.
Comment 23 Mircea Kitsune 2022-02-11 22:12:43 UTC
Can anyone confirm if this was successfully reimplemented in Plasma 5.24 as I understand the planning was? I'm still on 5.23 while waiting for the new release to reach Manjaro stable.
Comment 24 Nate Graham 2022-02-11 22:16:25 UTC
No, 5.24 has the re-implemented Cover Switch and Flip Switch effects, but the Desktop Cube effect has not been re-done yet.
Comment 25 Josesk Volpe 2022-02-14 07:07:59 UTC
I tried to replace Kwin with Compiz recently to bring back this effect, but then i gave up since i've knew from Arch Wiki Compiz is incompatible with Plasma because of the window decoration engine
I would really appreciate to have this feature re-implemented or replaced
Since i have already exceeded my 1 vote limit (yeah, 1 vote, really, ¿why can't i vote for 2 bugs?) because of bug 443757 that's not really solved since Cover Switch and Flip Switch replacements, although reasonable and somewhat acceptable, are very poor, i'm only adding me to CC list
Comment 26 Diego 2022-02-28 17:44:10 UTC
I also ask that the desktop cube be put back, and also the Virtual Desktops with different wallpapers, different icons, and with different widgets on each virtual desktop.
Although I know that the developers ignore us, the users, and for proof, they removed the virtual desktops. And that the users complained and asked that it be put back on.
Comment 27 Paul Hands 2022-03-12 00:17:56 UTC
While we wait for a loved feature to come back, Gnome is making me wonder about a switch for the first time in a decade....

https://www.omgubuntu.co.uk/2022/03/desktop-cube-gnome-extension-panoramas
Comment 28 Maximilian Böhm 2022-03-13 23:08:36 UTC
Guys, the tone in some of the comments here is not helpful for our request. Please remain friendly towards the hobbyists who are developing our beloved desktop.
Comment 29 Maximilian Böhm 2022-03-13 23:27:13 UTC
But I have to admit, the Gnome extension looks neat. I wouldn’t switch to Gnome (LOL) but it demonstrates the UX potential the cube effect has. Look at its GitHub page: https://github.com/schneegans/Desktop-Cube – there are a couple of really great UI/UX ideas in the GIFs. Combine this with touch, like in the video demo and it gets astonishing. Nobody wanted to touch the cube effect in Kwin for a decade, which effectively made it freeze in its 2010ish code base and UI paradigms, but this effect holds so much potential if you think it through.
Comment 30 Josesk Volpe 2022-03-14 03:23:44 UTC
Wow, really nice
That is really a lesson for KDE, and i'm not saying it as something pejorative
Comment 31 mrbinitie 2022-04-24 02:55:16 UTC
Seriously the Cube, Cylinder and Orb need to be reintroduced. They've been great eye-candy, but more to the point, important organisational and navigation aids. I'm seriously considering reinstalling 20.04 so I still have access to these features
Comment 32 Angelos Pikoulas 2022-05-09 13:17:21 UTC
Bring back the Cube! Maybe some volunteer would like to jump in and re-adjust the old code to the new API?
Comment 33 Maximilian Böhm 2022-05-09 16:24:19 UTC
I’m considering creating a bounty for a good reimplementation of the Kwin Cube with the new Gnome extension as a feature blueprint. I personally would put 200 € into it. What would be a good online platform for this?
Comment 34 K.J. Petrie 2022-06-01 09:53:25 UTC
Any word on progress here? I had heard it was hoped to reintroduce some form of cube effect in 5.25, but there's no mention of it in the Beta announcement so it looks as if it won't be ready then.
I did try to teach myself QML but it's a long way from learning how to change a window's background colour to implementing complex animation effects involving all the virtual desktops.
Comment 35 Angelos Pikoulas 2022-06-01 13:17:59 UTC
(In reply to Maximilian Böhm from comment #33)
> I’m considering creating a bounty for a good reimplementation of the Kwin
> Cube with the new Gnome extension as a feature blueprint. I personally would
> put 200 € into it. What would be a good online platform for this?

https://bountysource.com/ should do - we'll then need to seed it (put more money in) & also promote it to the right developer eyes!
Comment 36 Thomas Bettler 2022-06-01 13:44:00 UTC
consider joining efforts with 
https://app.bountysource.com/issues/92875316-bring-back-per-virtual-desktop-wallpapers
Comment 37 Angelos Pikoulas 2022-06-01 13:52:00 UTC
(In reply to Thomas Bettler from comment #36)
> consider joining efforts with 
> https://app.bountysource.com/issues/92875316-bring-back-per-virtual-desktop-
> wallpapers

ΙΜΗΟ each issue deserves its own bounty.
Comment 38 Angelos Pikoulas 2022-06-01 13:52:19 UTC
(In reply to Thomas Bettler from comment #36)
> consider joining efforts with 
> https://app.bountysource.com/issues/92875316-bring-back-per-virtual-desktop-
> wallpapers

ΙΜΗΟ each issue deserves its own bounty.
Comment 39 Maximilian Böhm 2022-06-19 21:47:43 UTC
(In reply to Angelos Pikoulas from comment #38)
> (In reply to Thomas Bettler from comment #36)
> > consider joining efforts with 
> > https://app.bountysource.com/issues/92875316-bring-back-per-virtual-desktop-
> > wallpapers
> 
> ΙΜΗΟ each issue deserves its own bounty.

Yes…

I would like to hear a voice from the Kwin developers about what bounty platform they would prefer.
Comment 40 aditsu 2022-06-20 01:55:51 UTC
I've just been hit by this catastrophe too.
"they are not used widely based on support information from various bug reports" - this is extremely wrong. If it didn't show up in bug reports, it means it was working very well.
This is a SEVERE degradation of user experience. I would consider volunteering to help fix this disaster, if it didn't involve learning an entirely new framework (or multiple frameworks?) from scratch.
Comment 41 Marek Brunda 2022-06-22 08:07:18 UTC
Created attachment 150039 [details]
attachment-3402-0.html

"they are not used widely based on support information from various bug
reports" - this is extremely wrong. If it didn't show up in bug reports, it
means it was working very well." - You're right, I've used it on several
computers for a number of years even with various Linux distributions and
never had a problem, even when using it with Wine or OpenGL full screen
applications and games. Everything worked as expected.

On Mon, Jun 20, 2022 at 3:55 AM aditsu <bugzilla_noreply@kde.org> wrote:

> https://bugs.kde.org/show_bug.cgi?id=438883
>
> aditsu <aditsu@yahoo.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |aditsu@yahoo.com
>
> --- Comment #40 from aditsu <aditsu@yahoo.com> ---
> I've just been hit by this catastrophe too.
> "they are not used widely based on support information from various bug
> reports" - this is extremely wrong. If it didn't show up in bug reports, it
> means it was working very well.
> This is a SEVERE degradation of user experience. I would consider
> volunteering
> to help fix this disaster, if it didn't involve learning an entirely new
> framework (or multiple frameworks?) from scratch.
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
> You voted for the bug.
Comment 42 Josesk Volpe 2022-06-22 12:58:18 UTC
Yeah, i can confirm that. Cover switch, flip switch and cube effect were the most stable ones in Kwin, the only bug i had with it was that window contents weren't being drawn on every switches when they were minimized .
Its code may be huge, but if that were really that hard to maintain (wich was the reason of the removal), then i doubt it would keep that stability if it had to be messed a lot to keep working. I don't know about how it worked in Wayland tho.
What is probably true is that they were making it hard to maintain *other features*, not themselves. So they have to be re-implemented in a future release.
Comment 43 Bug Janitor Service 2022-07-04 15:05:34 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kdeplasma-addons/-/merge_requests/188
Comment 44 Paul Hands 2022-07-04 15:23:09 UTC
(In reply to Bug Janitor Service from comment #43)
> A possibly relevant merge request was started @
> https://invent.kde.org/plasma/kdeplasma-addons/-/merge_requests/188

This is great news!   If you're looking for a tester, I'm in.

Paul
Comment 45 Ken D'Ambrosio 2022-08-02 06:47:56 UTC
Yeah, throw me on the list.  I'm still using Compiz, but it's woooooo growing long in the tooth, and obviously not making the jump to lightspee... err, Wayland.  If you guys get a cube that works in Wayland, I'll be on KDE for the first time since I got Compiz working back in '06.  Wonder if anything's changed in the past 16 years? ;-)

Thanks!!
Comment 46 Ed Huott 2022-08-30 15:06:53 UTC
Very sorry to see the loss of the Desktop Cube effect. For me, it's a real regression in the KDE Desktop experience. I hope that it will be brought back in the near future.
Comment 47 JC Casiano 2022-09-02 00:02:19 UTC
Please bring back the Cube, the Fade and Slide effects don't even compare.  It was odd hearing my friend even mention it and express his disappointment the other day.  I was surprised he even noticed my Linux effects, and he thought it was one of the coolest effects that he couldn't get on Windows.
Comment 48 Don Robertson 2022-09-03 04:08:29 UTC
Hi - would love to see the desktop cube back, but I believe the problem is that the new api's mean the effect would have to be completely re-written, and that it is not an easy task. 

The KDE desktop is brilliant, and although in the past I have found things like pulse audio to be frustrating, it is still the best desktop around. I switched to KDE from Afterstep back in the days of the Kandalf mascot. SO really appreciate all the hard work that has gone into the desktop, and, while I'm sad to see the cube go, if we need to loose some eye-candy to keep the desktop evolving, I'll have to live with it.
Comment 49 Vlad Zahorodnii 2022-09-14 10:04:39 UTC
FTR while kdeplasma-addons MR is not merged, you could use https://github.com/zzag/kwin-effects-cube. Contributions are welcome!
Comment 50 K.J. Petrie 2022-09-17 20:15:51 UTC
Can we have an indication of when this will be added into the release, please? It's now 2.5 months since July and still not there.
Comment 51 Petr 2022-09-24 13:52:34 UTC
(In reply to Vlad Zahorodnii from comment #49)
> FTR while kdeplasma-addons MR is not merged, you could use
> https://github.com/zzag/kwin-effects-cube. Contributions are welcome!

well, i tested (as of instructions in https://github.com/zzag/kwin-effects-cube/issues/3) and i can agree to the 2 commenters there. it can be installed, i can see the checkmark, but (at least on my fedora36 updated to all recent packages) it does do nothing. i also cannot add it to the desktop-switcher or the activities-switcher

Operating System: Fedora Linux 36
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.5
Kernel Version: 5.19.10-200.fc36.x86_64 (64-bit)
Graphics Platform: X11
Comment 52 Prajna Sariputra 2022-09-24 14:12:22 UTC
(In reply to Petr from comment #51)
> (In reply to Vlad Zahorodnii from comment #49)
> > FTR while kdeplasma-addons MR is not merged, you could use
> > https://github.com/zzag/kwin-effects-cube. Contributions are welcome!
> 
> well, i tested (as of instructions in
> https://github.com/zzag/kwin-effects-cube/issues/3) and i can agree to the 2
> commenters there. it can be installed, i can see the checkmark, but (at
> least on my fedora36 updated to all recent packages) it does do nothing. i
> also cannot add it to the desktop-switcher or the activities-switcher

You may need to install qt5-quick3d (or the equivalent package for your distro) for the effect to work, although at the current state the effect is only standalone, as in it can't be used for the switcher animations. It works fine for me once I installed the aforementioned package on Arch.

If it still doesn't work you may need to restart KWin, alternatively running `journalctl -f` in a terminal and watching it when you press the shortcut key should tell you what the issue is.
Comment 53 Zubin Singh Parihar 2022-11-06 18:39:43 UTC
I too would like the Desktop cube effect back!
I'm using Kubuntu 20.04 with Plasma 5.18.7 and one of my biggest hesitations of upgrading to Kubuntu 22.04 with Plasma 5.24.6 is that I'll lose the Desktop Cube effect.

I see that this person has been able to bring the Desktop Cube effect to Plasma 5.24:

https://www.youtube.com/watch?v=-uDRSUdftZE
Comment 54 Nate Graham 2022-12-01 21:11:43 UTC
*** Bug 462475 has been marked as a duplicate of this bug. ***
Comment 55 Nate Graham 2023-01-03 21:33:28 UTC
*** Bug 462982 has been marked as a duplicate of this bug. ***
Comment 56 Dalix 2023-01-10 23:40:27 UTC
Hey Nate - any eta on the new desk cub code? Cheers!
Comment 57 Paul Hands 2023-01-11 02:12:07 UTC
Also...let me reiterate my total willingness to be a tester.  I have multiple machines (including Virtualbox VMs) on a reasonable setup - 3 x 4k monitors on a 12 core AMD Ryzen box with a Radeon RX 6600 graphics card.  I can't wait for the Cube to come back!

I tried the cube effect at https://github.com/zzag/kwin-effects-cube a few months back, and although it seemed to install OK, it didn't work...I now see more recent work, so I'll have anbother go on a spare machine.

Paul
Comment 58 RobinK 2023-01-11 02:26:03 UTC
Re Comment #57, I have that version working in both Leap 15.4 and Tumbleweed, but it's really only a demo of possibilities - which is very encouraging but it's of limited practical use in its present form.
Comment 59 Paul Hands 2023-01-11 02:35:10 UTC
(In reply to RobinK from comment #58)
> Re Comment #57, I have that version working in both Leap 15.4 and
> Tumbleweed, but it's really only a demo of possibilities - which is very
> encouraging but it's of limited practical use in its present form.

Thanks, @RobinK!

Do you know if it will work on a Virtualbox guest?  The hardware emulation on VBox makes me wonder.

In the meantime, I'll build a spare laptop to an Ubuntu or KDE Neon recent distro, and try the github demo on that - good practice!
Comment 60 RobinK 2023-01-11 07:57:47 UTC
In reply to Paul Hands, Comment #58

Sorry; I've no VBox Linux guest, only Windows, and therefore can't say.....
Comment 61 h.k.ghost 2023-01-29 04:21:41 UTC
(In reply to Nate Graham from comment #20)
> The Cover Switch and Flip Switch effects were just rewritten in QML for
> Plasma 5.24; see Bug 443757. The Desktop Cube effect will be next! I doubt
> it will be ready for 5.24, but hopefully it'll be back for 5.24.

What's the ETA for this feature restoration? I'm running:

Plasma: 5.25.5
KDE Framework: 5.98.0
Qt: 5.15.6

and it's not here, either.

On another note, I'm not sure why an effect that has been stable for years and has a good track record of working correctly would be removed *prior* to having an actual replacement... it could've just been left alone. Also, Bug 450230 shows that, whatever it is that got implemented, falls very short and does not really come close to replicating the original.
Comment 62 Neal Gompa 2023-01-29 11:07:31 UTC
(In reply to h.k.ghost from comment #61)
> (In reply to Nate Graham from comment #20)
> > The Cover Switch and Flip Switch effects were just rewritten in QML for
> > Plasma 5.24; see Bug 443757. The Desktop Cube effect will be next! I doubt
> > it will be ready for 5.24, but hopefully it'll be back for 5.24.
> 
> What's the ETA for this feature restoration? I'm running:
> 
> Plasma: 5.25.5
> KDE Framework: 5.98.0
> Qt: 5.15.6
> 
> and it's not here, either.
> 

While I also want it back (and it's not back yet in 5.26 either),...

> On another note, I'm not sure why an effect that has been stable for years
> and has a good track record of working correctly would be removed *prior* to
> having an actual replacement... it could've just been left alone. 

I know that it *couldn't* have been left alone because the old way was buggy and difficult to keep working...

> Also, Bug
> 450230 shows that, whatever it is that got implemented, falls very short and
> does not really come close to replicating the original.

and this is very rude. It takes time to reimplement things. It happens in phases.

If you're not satisfied with the state of things, ask about how you can help make it get to where you want it to be.
Comment 63 Nate Graham 2023-02-19 20:11:22 UTC
*** Bug 443410 has been marked as a duplicate of this bug. ***
Comment 64 Petr 2023-05-20 20:03:25 UTC
could somebody please write an update on this?
Comment 65 Sadi 2023-06-22 08:01:58 UTC
Has anyone tried the third-party alternative?
https://github.com/zzag/kwin-effects-cube
Comment 66 triffid.hunter 2023-06-22 08:43:02 UTC
Created attachment 159828 [details]
attachment-1217957-0.html

I just gave it a quick try - compiles and installs fine, it shows up in
system settings and I can see the kwin shortcut it adds, but nothing
happens when I actually hit the key combo.

On Thu, 22 Jun 2023 at 08:02, Sadi <bugzilla_noreply@kde.org> wrote:

> https://bugs.kde.org/show_bug.cgi?id=438883
>
> Sadi <sadiyumusak@gmail.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |sadiyumusak@gmail.com
>
> --- Comment #65 from Sadi <sadiyumusak@gmail.com> ---
> Has anyone tried the third-party alternative?
> https://github.com/zzag/kwin-effects-cube
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
> You voted for the bug.
Comment 67 Maximilian Böhm 2023-06-22 13:05:38 UTC
kwin-effects-cube works for me on Arch (there is a "kwin-effects-cube" AUR script for Plasma 5). Already tried it a year ago.
Glad about its existence but… Currently, it’s just a demo. Maybe viable to wow Windows users but that’s not why I was using the old cube effect. It’s not possible to use this effect as virtual desktops switching transition, there are no stacked windows in 3D, you cannot drag the desktop with a key combo + mouse without centering the view first, there is no transparency, no reflection, you need an extra click to get to a certain virtual desktop, there are glitches with background images, I’m not a big fan of the open spaced borders… It’s great someone made this plugin but currently, it isn’t there yet.

I want to cite my comment here about the Gnome extension "Desktop-Cube":
https://bugs.kde.org/show_bug.cgi?id=438883#c29
»But I have to admit, the Gnome extension looks neat. I wouldn’t switch to Gnome (LOL) but it demonstrates the UX potential the cube effect has. Look at its GitHub page: https://github.com/schneegans/Desktop-Cube – there are a couple of really great UI/UX ideas in the GIFs. Combine this with touch, like in the video demo and it gets astonishing. Nobody wanted to touch the cube effect in Kwin for a decade, which effectively made it freeze in its 2010ish code base and UI paradigms, but this effect holds so much potential if you think it through.«

The Gnome extension currently is at v17. It has integration and transition effects into Gnome’s overview effect, recognizes you holding the desktop, has 3D stacked windows and so much more. This is possible.

I’m even willing to found a bounty for the Plasma cube to get more love: https://bugs.kde.org/show_bug.cgi?id=438883#c33
Comment 68 kolAflash 2023-06-22 14:10:14 UTC
(In reply to Sadi from comment #65)
> Has anyone tried the third-party alternative?
> https://github.com/zzag/kwin-effects-cube

There are some comments above about trying out kwin-effects-cube

I tried it and it's feature set seems much smaller than the old cube effect. But it's the only option currently.
(thanks @Vlad, wishing peace, democracy and freedom for your country!)

Compiling is a little hard on some distros. Especially because of that big qtquick3d dependency.
https://github.com/zzag/kwin-effects-cube#building-from-git
Additional needed for Debian-12:
https://github.com/zzag/kwin-effects-cube/issues/16
Comment 69 Dalix 2023-07-17 16:47:56 UTC
Any progress reports on the re-implementation efforts?

Thanks
Comment 70 RobinK 2023-07-17 21:45:09 UTC
Re Comment # 69 - indeed.  May we know if anyone is working on it at all?
Comment 71 JC Casiano 2023-07-18 01:56:35 UTC
There is a package available in AUR (there are actually 2, but this one is for Plasma5):  https://aur.archlinux.org/packages/kwin-effects-cube

I easily built and installed it, and have been using it for many weeks now.  I'm very appreciative of "zjuyk" for giving us something to work with.  This version gives the basic zoom out and screen flipping, as well as allowing for the 3-D rotation/view.  I think the only thing it didn't like about my setup was the second touchscreen monitor, but otherwise it seems to do what the Cube used to do.  

It did fail after one upgrade, but after recompiling and reinstalling it, I got it to work again.
Comment 72 Dalix 2023-07-25 08:25:36 UTC
(In reply to JC Casiano from comment #71)
> There is a package available in AUR (there are actually 2, but this one is
> for Plasma5):  https://aur.archlinux.org/packages/kwin-effects-cube
> 
> I easily built and installed it, and have been using it for many weeks now. 
> I'm very appreciative of "zjuyk" for giving us something to work with.  This
> version gives the basic zoom out and screen flipping, as well as allowing
> for the 3-D rotation/view.  I think the only thing it didn't like about my
> setup was the second touchscreen monitor, but otherwise it seems to do what
> the Cube used to do.  
> 
> It did fail after one upgrade, but after recompiling and reinstalling it, I
> got it to work again.

This is good to know but I am still really hoping for it to be properly re-integrated into Plasma!
Comment 73 JC Casiano 2023-07-25 19:47:13 UTC
Agreed, this and the burning-windows feature are great distiguishing
effects, and should be re-integrated since they are working again.

> https://bugs.kde.org/show_bug.cgi?id=438883
>
> --- Comment #72 from Dalix <dalixinc@gmail.com> ---
> (In reply to JC Casiano from comment #71)
>> There is a package available in AUR (there are actually 2, but this one
>> is
>> for Plasma5):  https://aur.archlinux.org/packages/kwin-effects-cube
>>
>> I easily built and installed it, and have been using it for many weeks
>> now.
>> I'm very appreciative of "zjuyk" for giving us something to work with.
>> This
>> version gives the basic zoom out and screen flipping, as well as
>> allowing
>> for the 3-D rotation/view.  I think the only thing it didn't like about
>> my
>> setup was the second touchscreen monitor, but otherwise it seems to do
>> what
>> the Cube used to do.
>>
>> It did fail after one upgrade, but after recompiling and reinstalling
>> it, I
>> got it to work again.
>
> This is good to know but I am still really hoping for it to be properly
> re-integrated into Plasma!
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
> You voted for the bug.
Comment 74 Thomas Bettler 2023-09-03 06:08:41 UTC
Seems like voting on this product became disabled this night w/o any announcements :-(
Can someone give more insights?

___

Some or all of your votes have been removed from bug 438883.

You had 1 vote on this bug, but 1 have been removed.

You have no more votes remaining on this bug.

Reason:
  The rules for voting on this product has changed; you had
  too many total votes, so all votes have been removed.


https://bugs.kde.org/show_bug.cgi?id=438883
Comment 75 Paul Hands 2023-09-03 14:21:19 UTC
What's with removing our votes?  I had one vote registered, and it was removed, apparently because I had too many votes???!

Is this a not-so-subtle way of telling us the effect is not going to be restored?
Comment 76 Prajna Sariputra 2023-09-03 14:28:32 UTC
As per Nate in the KDE forums (https://discuss.kde.org/t/strange-category-bug-vote-limits-at-bugs-kde-org/3450/2) voting on bugs never really did much of anything for bug prioritisation anyway, so I think it's been disabled to reflect the way it's always been in reality, and not anything to do with this bug specifically.
Comment 77 João Carlos 2023-10-22 00:46:37 UTC
Ja faz um bom tempo e nada do efeito cube voltar. Sinceramente como podem deixar morrer um efeito que foi e ainda é a marca registrada do KDE?
Comment 78 postix 2023-10-23 13:24:29 UTC
*** Bug 455130 has been marked as a duplicate of this bug. ***
Comment 79 Nate Graham 2023-10-25 22:04:12 UTC
Fixed by Vlad Zahorodnii with https://invent.kde.org/plasma/kdeplasma-addons/-/commit/b50cfab3e50490d95381016e16679242269e9f89 fpr Plasma 6!
Comment 80 Duns 2024-02-15 08:31:09 UTC
So, in Plasma 6 we will find desktop cube effect?
Comment 81 Prajna Sariputra 2024-02-15 09:08:47 UTC
Yes, Plasma 6 has it as Nate said in the comment right before yours, and as noted in the "Version Fixed In" field of the bug.
Comment 82 Scott Newton 2024-03-01 04:08:57 UTC
Just installed Plasma 6 and this is not fixed. While it is true that Cube now appears under Window Management, it does not appear under Virtual Desktop Switching Animation, which was the most important part of the Cube before it was removed. Sadly I don't seem to have permissions to reopen this bug, so may have to create a new one.
Comment 83 Patrick Silva 2024-03-01 04:13:11 UTC
there already is a bug report, see bug 476161
Comment 84 Scott Newton 2024-03-01 04:16:13 UTC
Ahh. Thank you. Following that bug.