Bug 443410 - Please restore the Desktop Cube switching effect
Summary: Please restore the Desktop Cube switching effect
Status: CLOSED DUPLICATE of bug 438883
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 5.24.4
Platform: Kubuntu Linux
: NOR wishlist
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-06 20:11 UTC by K.J. Petrie
Modified: 2023-02-19 20:11 UTC (History)
46 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Please do not remove cube animation!!!! Seriously (226.43 KB, image/jpeg)
2021-11-20 02:05 UTC, Trebor
Details
attachment-11512-0.html (1.53 KB, text/html)
2022-02-28 10:33 UTC, João Carlos
Details
attachment-4022-0.html (1.68 KB, text/html)
2022-03-01 03:58 UTC, Trebor
Details
attachment-25999-0.html (929 bytes, text/html)
2022-11-26 23:52 UTC, Trebor
Details
attachment-32048-0.html (1.26 KB, text/html)
2022-12-14 05:39 UTC, Mike Stefanelli
Details
attachment-27183-0.html (2.24 KB, text/html)
2022-12-14 14:15 UTC, Mike Stefanelli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description K.J. Petrie 2021-10-06 20:11:03 UTC
SUMMARY
The desktop cube is for many the distinguishing feature of KDE Plasma. It marks it out from all the other DEs and makes it more useful and user-friendly than the alternatives. It is the reason I chose KDE. Now I hear it is to be removed in the next release and I must implore you to think again.

Being able to hit a simple key combination and swivel to a fresh workspace is a boon to productivity and makes Plasma such a joy to use, being able to distance and rotate the desktop enables a quick and intuitive overview of layouts and locations in organising work. Without it I, and I'm sure many others, will be much impoverished.

The rest of the template is about technical details and is unnecessary in this case, as those who have taken this vital component out will know precisely what they have done and what needs to be done to put it back. All that is needed is a little good will and understanding.

Without that, I fear KDE will lose favour with its supporters and something else will take its place in due course, but I'd rather not have the upheaval.
Comment 1 Aragorn 2021-10-06 23:48:02 UTC Comment hidden (spam)
Comment 2 Dean Schaf 2021-10-07 05:21:54 UTC Comment hidden (spam)
Comment 3 Vlad Zahorodnii 2021-10-07 07:32:22 UTC
This was discussed back in May. See https://mail.kde.org/pipermail/kwin/2021-May/005222.html for the reason why the effect was dropped.

I'm afraid that we can't bring the effect back because rendering abstractions have changed quite a bit. One would need to rewrite the effect from scratch. As discussed in the mailing list thread, we would like to have the effect reimplemented in qml (like the overview effect), but we don't have man power resources to do so. It will be great if the community helps with the port of the effect to qml.
Comment 4 Bogdan 2021-10-07 07:50:56 UTC Comment hidden (spam)
Comment 5 locutusofborg 2021-10-07 13:20:05 UTC Comment hidden (spam)
Comment 6 Aragorn 2021-10-07 13:47:31 UTC Comment hidden (spam)
Comment 7 Nate Graham 2021-10-07 16:27:41 UTC
I also would have preferred to maintain compatibility with existing effects, but unfortunately what's done is done. At this point it needs to be rewritten from scratch. Marking as CONFIRMED since there is no objection to anyone doing so.
Comment 8 Patrick Silva 2021-10-07 23:15:23 UTC
dupe of bug 438883 ?
Comment 9 K.J. Petrie 2021-10-08 12:46:03 UTC
It appear to be, but since most of the discussion has happened here I'm not sure which is the best way to merge them without risking these comments being lost from sight.

I do think arguing about resources misses the point. The question is what is the purpose of a desktop? Is it to be a vehicle for its authors to write elegant code or to provide functionality to users? I can quite understand the desire to streamline code. that's always a good thing to aim for, but I would question whether that should be done in a way which deprives users of features they need, at least if it doesn't provide something of equivalent utility. If users came first, wouldn't the correct approach be to rewrite or replace functionality first so it were ready for the new streamlined code when that comes along? The approach of break it first and then see whether we can provide something similar later might be OK as a development approach, but not in released production versions.

In my first-year woodworking class at school the teacher gave us the assignment of designing a toast rack. We all set to work drawing things we thought we could make which would do the job, until one boy asked the teacher "How big is a slice of bread?" The teacher congratulated him on his inside. Good design begins with purpose - identifying the required function - and that produces a specification the design needs to fulfil. You shouldn't start from what you want to make, but what it needs to be to achieve its purpose. Form follows function.

It's a good principle to bear in mind.
Comment 10 Nate Graham 2021-10-08 15:29:33 UTC
(In reply to Patrick Silva from comment #8)
> dupe of bug 438883 ?
Oops, indeed.

For the people upset about this, I hear you and I agree. It's simply a sad fact of life that sometimes old things need to get broken to fix other things. It's not about abstractly making the code better, it's to support current and future needs. We'll try to get this effect re-implemented at some point.

*** This bug has been marked as a duplicate of bug 438883 ***
Comment 11 Vladimir Yerilov 2021-10-08 16:40:17 UTC Comment hidden (spam)
Comment 12 RobinK 2021-10-09 21:44:21 UTC Comment hidden (spam)
Comment 13 Duns 2021-10-15 07:35:17 UTC Comment hidden (spam)
Comment 14 João Carlos 2021-10-15 21:08:35 UTC Comment hidden (spam)
Comment 15 Thomas Bettler 2021-10-16 19:01:30 UTC Comment hidden (spam)
Comment 16 Manuel 2021-10-17 20:09:57 UTC Comment hidden (spam)
Comment 17 Paul Hands 2021-10-17 21:31:32 UTC Comment hidden (spam)
Comment 18 Maximilian Böhm 2021-10-18 10:54:23 UTC Comment hidden (spam)
Comment 19 Maximilian Böhm 2021-10-18 11:04:32 UTC Comment hidden (spam)
Comment 20 Maximilian Böhm 2021-10-18 11:34:43 UTC Comment hidden (spam)
Comment 21 Aragorn 2021-10-18 14:45:34 UTC Comment hidden (spam)
Comment 22 Maximilian Böhm 2021-10-18 15:55:49 UTC Comment hidden (spam)
Comment 23 RobinK 2021-10-18 20:05:42 UTC Comment hidden (spam)
Comment 24 Salvo "LtWorf" Tomaselli 2021-10-20 01:00:45 UTC Comment hidden (spam)
Comment 25 Bharadwaj Raju 2021-10-20 06:26:33 UTC
(In reply to Aragorn from comment #6) 
> Forgive me for sounding hostile, and I fully appreciate that the effect(s)
> would need to be rewritten in order to ensure compatibility with the
> evolution of the Plasma desktop, but from the email exchange you've linked
> to here-above, it appears to rather be a matter of not having any motivation
> to do so instead of a matter of not having the manpower or the resources, as
> well as a matter of not being in touch with your user base.
> 
> You are all in control of how Plasma works and how it evolves.  Therefore,
> you are also in control of which aspects of the software you wish to advance
> to the next level first.  
> 
> If the new "scene" ─ as you guys call it ─ requires the rewriting of those
> effects, then perhaps you are pushing out this new "scene" prematurely at
> the cost of breaking existing features, and ─ forgive me for saying this ─
> you guys unfortunately have a history of doing that.  Plasma 4 springs to
> mind, as well as that it took you guys until 5.10 before the global menu ─ a
> feature that had already more or less been present (even if only for Qt
> applications only at the time) in KDE 1.x, 2.x and 3.x ─ was reintroduced,
> in spite of the very popular demand throughout the entire life cycle of
> Plasma 4 and up until 5.10.
> 
> There's an old saying that goes "If it ain't broke, don't fix it", just as
> there is another saying that goes "Whatever you're going to do, if you're
> going to do it, then you should do it well."
> 
> If you break something, then you're also taking the responsibility upon you
> to fix it again.  Don't hide behind the excuse of not having the resources
> and/or the manpower.  Again, I've read the email exchange that you linked
> to, and it's not a matter of "we don't have the resources", but of "let's
> just drop it, because hardly anybody's using it anyway."  
> 
> It's not the resources that are the problem; it's the attitude.

The reworking of the rendering scene introduces many improvements in areas used far more often than the desktop cube. And make no mistake, it *is* a question of resources. Rewriting the cube effect is going to take resources, obviously. And the improvements gained and glitches fixed by reworking the scene code just outweighs the desktop cube, both in importance and in number of people affected.

Even then, it *is* going to be rewritten, have patience.

KDE is a volunteer project. The devs are volunteers. I would ask everyone to be more considerate of that fact.
Comment 26 Satyam 2021-10-26 07:40:48 UTC
(In reply to Bharadwaj Raju from comment #25)
> (In reply to Aragorn from comment #6) 
> 
> KDE is a volunteer project. The devs are volunteers. I would ask everyone to
> be more considerate of that fact.

I agree with everyone. I really like the desktop cube.  I moved to KDE from Compiz many years ago when KDE added the desktop cube and many of the compositing features of Compiz.

That said I also understand that it's a community project of volunteers and don't have expectations, and do have much appreciation.

I'm curious about why it was mentioned that it would be good to rewrite it in QML.  I know a lot of Plasma things are in QML now, but isn't performance a consideration for something like that?
Comment 27 CatKiller 2021-10-26 21:21:10 UTC Comment hidden (spam)
Comment 28 Wolfram Köhn 2021-10-27 15:15:43 UTC Comment hidden (spam)
Comment 29 Dean Schaf 2021-11-05 16:47:12 UTC Comment hidden (spam)
Comment 30 Bharadwaj Raju 2021-11-05 16:58:05 UTC
(In reply to Dean Schaf from comment #29)
> 2011-11-05
> Still no Flip-Switch and still no 3-D Desktop Cube
> 
> They're forever dead!

Greatly exaggerated.

https://invent.kde.org/plasma/kdeplasma-addons/-/merge_requests/91

>  You were loved dearly, but the
> powers that be hate you because you brought your users
> joy.

Wrong reason. The reasoning been explained above, read that.
Comment 31 p.w.stockwell01 2021-11-07 18:51:19 UTC Comment hidden (spam)
Comment 32 Satyam 2021-11-07 19:05:56 UTC Comment hidden (spam)
Comment 33 p.w.stockwell01 2021-11-07 19:25:05 UTC Comment hidden (spam)
Comment 34 Mircea Kitsune 2021-11-19 22:38:25 UTC Comment hidden (spam)
Comment 35 Trebor 2021-11-20 02:05:46 UTC Comment hidden (spam)
Comment 36 Laosom 2021-11-20 14:08:15 UTC Comment hidden (spam)
Comment 37 Bharadwaj Raju 2021-11-20 14:19:17 UTC
It is going to be redone in QML and brought back. The flip and cover switch effects even have am MR in progress.

Adding comments here is not helping. Either write it, or wait and don't spam what basically everyone has already said again and again.
Comment 38 Marek Brunda 2021-11-22 13:05:36 UTC Comment hidden (spam)
Comment 39 jonzn4SUSE 2021-12-25 20:49:11 UTC Comment hidden (spam)
Comment 40 siauderman 2022-02-28 03:17:37 UTC Comment hidden (spam)
Comment 41 David Edmundson 2022-02-28 09:56:22 UTC
Please don't change bug status.
Comment 42 João Carlos 2022-02-28 10:33:13 UTC Comment hidden (spam)
Comment 43 Trebor 2022-03-01 03:56:32 UTC
Hi i know we are boring you but seriously some time ago i writed you that i use it to teach chemiastry my students so to show how awsome was 3d cube that i'm still using thanks to timeshift i did education channel on youtube where the cube is in the center of everything check yourself :
https://www.youtube.com/channel/UCeorXe-KT_Mt-mAXG8_HmaQ
Comment 44 Trebor 2022-03-01 03:58:16 UTC Comment hidden (spam)
Comment 45 OSTW 2022-03-21 15:11:26 UTC Comment hidden (spam)
Comment 46 Wolfram Köhn 2022-04-03 11:28:30 UTC Comment hidden (spam)
Comment 47 mrbinitie 2022-04-23 19:10:54 UTC Comment hidden (spam)
Comment 48 Maximilian Böhm 2022-04-24 00:17:17 UTC Comment hidden (spam)
Comment 49 lgazx 2022-05-16 12:21:41 UTC Comment hidden (spam)
Comment 50 wolf 2022-06-07 17:46:08 UTC Comment hidden (spam)
Comment 51 kolAflash 2022-06-08 18:45:55 UTC Comment hidden (spam)
Comment 52 kolAflash 2022-06-08 19:39:56 UTC
P.S.
Maybe of interest:


Posted on 16. November 2021 by Martin Flöser
Evolving 3D desktop effects in Plasma
https://blog.martin-graesslin.com/blog/2021/11/evolving-3d-desktop-effects-in-plasma/
> The latest Plasma release dropped a few desktop effects: the cube 
> family, CoverSwitch and FlipSwitch. All of those effects were written 
> back in 2008, the early days of KDE 4.x and the early days of desktop 
> effects in KWin. The effects were implemented by me and when Vlad asked 
> about removing them I saw the need for this and supported this step for 
> technical reasons. With this blog post I want to share a little bit of 
> why it was needed to remove them and why this means that they can come 
> back in better ways than ever before.
> [...]
Comment 53 jonzn4SUSE 2022-06-10 10:27:27 UTC Comment hidden (spam)
Comment 54 jonzn4SUSE 2022-06-10 10:28:58 UTC Comment hidden (spam)
Comment 55 Antonio Rojas 2022-06-10 14:05:55 UTC
*** Bug 455130 has been marked as a duplicate of this bug. ***
Comment 56 McWill 2022-06-12 18:06:50 UTC Comment hidden (spam)
Comment 57 Gordon 2022-06-16 21:05:56 UTC Comment hidden (spam)
Comment 58 Ade Malsasa Akbar 2022-07-19 07:01:16 UTC Comment hidden (spam)
Comment 59 Zubin Singh Parihar 2022-11-06 18:29:32 UTC Comment hidden (spam)
Comment 60 Zubin Singh Parihar 2022-11-06 18:37:19 UTC
I see that this person has been able to bring the Desktop Cube effect to Plasma 5.24:

https://www.youtube.com/watch?v=-uDRSUdftZE
Comment 61 K.J. Petrie 2022-11-06 19:55:40 UTC
It's available at https://github.com/zzag/kwin-effects-cube.git and I have packaged it for PCLinuxOS. If your distro doesn't package it yet either package it for them or ask someone to do so. Of course, it's up to the distro whether they do.

Thanks to the developers for doing this. It's really appreciated.
Comment 62 RobinK 2022-11-24 20:44:49 UTC Comment hidden (spam)
Comment 63 Trebor 2022-11-26 23:52:16 UTC Comment hidden (spam)
Comment 64 K.J. Petrie 2022-11-27 00:01:09 UTC
See my comment 61. It's done, but you need to install it yourself as an add-on. If your distro doesn't package it you'll also have to build it, but KDE have done their bit so there's nothing more to do here.
Comment 65 RobinK 2022-11-27 00:27:21 UTC Comment hidden (spam)
Comment 66 Mike Stefanelli 2022-12-13 22:42:15 UTC Comment hidden (spam)
Comment 67 K.J. Petrie 2022-12-13 23:53:49 UTC Comment hidden (spam)
Comment 68 Mike Stefanelli 2022-12-14 05:39:15 UTC Comment hidden (spam)
Comment 69 Duns 2022-12-14 07:11:46 UTC Comment hidden (spam)
Comment 70 Mike Stefanelli 2022-12-14 14:15:09 UTC Comment hidden (spam)
Comment 71 sydney 2022-12-30 18:18:59 UTC Comment hidden (spam)
Comment 72 Vortex 2023-02-11 22:43:45 UTC Comment hidden (spam)
Comment 73 Duns 2023-02-12 10:07:27 UTC Comment hidden (spam)
Comment 74 Philip Booysen 2023-02-19 19:22:17 UTC Comment hidden (spam)
Comment 75 Nate Graham 2023-02-19 20:11:22 UTC

*** This bug has been marked as a duplicate of bug 438883 ***