Bug 428974 - KDE Partition Manager keeps on asking for authentication even if the user presses "cancel"
Summary: KDE Partition Manager keeps on asking for authentication even if the user pre...
Status: RESOLVED FIXED
Alias: None
Product: partitionmanager
Classification: Unclassified
Component: general (show other bugs)
Version: 4.2.0
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Andrius Štikonas
URL: https://invent.kde.org/system/partiti...
Keywords: usability
: 429780 430079 434108 436752 437803 440324 442345 444512 448643 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-11 13:12 UTC by Riccardo Robecchi
Modified: 2022-01-17 12:08 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Robecchi 2020-11-11 13:12:04 UTC
SUMMARY
KDE Partition Manager keeps on asking for elevated permissions even if the user presses "cancel" on the authentication dialogue. This means the user cannot effectively close the application if they don't know the password, unless they terminate/kill the process, which is however bad from a UX perspective. 

STEPS TO REPRODUCE
1. open KDE Partition Manager
2. press "cancel" in the authentication dialogue 

OBSERVED RESULT
The application keeps on asking for credentials to elevate permissions.

EXPECTED RESULT
The application throws a message saying "you need elevated permissions to modify partitions" and either closes or leaves the user with a greyed-out interface.

SOFTWARE/OS VERSIONS

Linux: KDE Neon Focal
KDE Plasma Version: 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.0

ADDITIONAL INFORMATION
Comment 1 Andrius Štikonas 2020-11-11 14:44:14 UTC
Strictly speaking user can close application by clicking Cancel more times, but that's probably not practical.
Comment 2 Riccardo Robecchi 2020-11-12 13:53:51 UTC
(In reply to Andrius Štikonas from comment #1)
> Strictly speaking user can close application by clicking Cancel more times,
> but that's probably not practical.

I pressed it five times before giving up and logging in to then close the application. As you mentioned, this is not ideal and can be frustrating as it is an unexpected behaviour.
Comment 3 Andrius Štikonas 2020-11-28 20:00:30 UTC
*** Bug 429780 has been marked as a duplicate of this bug. ***
Comment 4 Andrius Štikonas 2020-12-06 15:14:13 UTC
*** Bug 430079 has been marked as a duplicate of this bug. ***
Comment 5 Thibault Molleman 2021-03-02 10:15:24 UTC
Just experienced this problem as well. Can confirm that 
- pressing cancel multiple times doesn't work
- Trying to close the window itself also doesn't work
- trying to close the auth window also doesn't work
Comment 6 Andrius Štikonas 2021-03-02 10:35:58 UTC
(In reply to Thibault Molleman from comment #5)
> Just experienced this problem as well. Can confirm that 
> - pressing cancel multiple times doesn't work
It does work, but you need more times for it to go away. Initial scanning tries to run around 100 commands or so (that depends on your configuration and number of devices). That means you have to press Cancel that many time.
> - Trying to close the window itself also doesn't work
> - trying to close the auth window also doesn't work

As a more practical workaround sending SIGINT to partitionmanager process stops it.
Comment 7 Andrius Štikonas 2021-03-07 15:48:31 UTC
*** Bug 434108 has been marked as a duplicate of this bug. ***
Comment 8 Andrius Štikonas 2021-05-08 10:58:00 UTC
*** Bug 436752 has been marked as a duplicate of this bug. ***
Comment 9 Andrius Štikonas 2021-05-28 22:05:14 UTC
*** Bug 437803 has been marked as a duplicate of this bug. ***
Comment 10 Andrius Štikonas 2021-07-27 13:43:18 UTC
*** Bug 440324 has been marked as a duplicate of this bug. ***
Comment 11 Andrius Štikonas 2021-09-12 16:15:46 UTC
*** Bug 442345 has been marked as a duplicate of this bug. ***
Comment 12 Andrius Štikonas 2021-10-28 00:09:55 UTC
*** Bug 444512 has been marked as a duplicate of this bug. ***
Comment 13 Patrick Silva 2022-01-17 12:08:02 UTC
*** Bug 448643 has been marked as a duplicate of this bug. ***