Bug 427542 - [Wayland] Context menu closes and blocks the next two right-clicks when a notification, OSD, or tooltip disappears
Summary: [Wayland] Context menu closes and blocks the next two right-clicks when a not...
Status: RESOLVED UPSTREAM
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.20.90
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL: https://github.com/qt/qtwayland/commi...
Keywords: wayland
: 448508 450145 451020 451599 454195 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-11 13:42 UTC by Patrick Silva
Modified: 2022-09-12 18:13 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: the latest version of the KDE Qt patch collection


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2020-10-11 13:42:41 UTC
SUMMARY
only reproducible on Wayland

STEPS TO REPRODUCE
1. take a screenshot by pressing shift+printscreen (Plasma shows a notification)
2. right-click on desktop
3. wait the notification to disappear

OBSERVED RESULT
context menu closes when the notification disappears

EXPECTED RESULT
a notification should not interfere with any context menu

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.19.90
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.1
Comment 1 Nate Graham 2020-10-12 18:40:33 UTC
Can confirm.
Comment 2 Kai Uwe Broulik 2020-10-12 18:41:21 UTC
Pretty sure that's kwin
Comment 3 Vlad Zahorodnii 2020-10-14 18:04:16 UTC
(In reply to Nate Graham from comment #1)
> Can confirm.

I can't.
Comment 4 Vlad Zahorodnii 2021-01-27 09:24:26 UTC
(In reply to Kai Uwe Broulik from comment #2)
> Pretty sure that's kwin

No, it's plasma. It destroys the xdg_popup surface for some reason.
Comment 5 Nate Graham 2021-03-20 02:54:13 UTC
Ah yes, this. Same as Bug 417939.

*** This bug has been marked as a duplicate of bug 417939 ***
Comment 6 Patrick Silva 2021-10-20 02:28:39 UTC
This bug is still reproducible on Arch Linux (Plasma 5.23.1) and neon unstable.
On neon unstable the context menu also closes when volume or brightness OSD
disappears.
Comment 7 Nate Graham 2021-10-20 17:16:20 UTC
Darn, looks like they'll have to be fixed separately. Can reproduce.
Comment 8 Nate Graham 2022-01-13 19:04:22 UTC
Looks like this is an upstream issue that will be fixed by https://codereview.qt-project.org/c/qt/qtwayland/+/347783.
Comment 9 Patrick Silva 2022-01-16 03:34:45 UTC
*** Bug 448508 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2022-02-16 05:56:37 UTC
*** Bug 450145 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2022-03-26 02:21:30 UTC
*** Bug 451020 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2022-03-26 02:22:23 UTC
*** Bug 451599 has been marked as a duplicate of this bug. ***
Comment 13 Patrick Silva 2022-05-23 02:12:46 UTC
*** Bug 454195 has been marked as a duplicate of this bug. ***
Comment 14 Nate Graham 2022-09-12 18:04:39 UTC
This has been fixed in Qt 6.4 with https://github.com/qt/qtwayland/commit/f8e3257e9b1e22d52e9c221c62b8d9b6dd1151a3.

Ideally we should backport it to the KDE patch collection.
Comment 15 Nate Graham 2022-09-12 18:05:30 UTC
Xuetian, would you be interested in doing that? https://community.kde.org/Qt5PatchCollection#How_do_I_get_a_patch_merged.3F
Comment 16 Patrick Silva 2022-09-12 18:09:00 UTC
I'm unable to reproduce the original observed result. Tested on Wayland sessions of Arch and neon unstable.
Comment 17 Nate Graham 2022-09-12 18:09:55 UTC
It's possible they already manually backported it, or else it was already backported in the Qt patch collection and Fedora is lagging, which is why I can still reproduce it?
Comment 18 Nate Graham 2022-09-12 18:12:15 UTC
Indeed, it was backported a month ago!

https://invent.kde.org/qt/qt/qtwayland/-/commit/f8e3257e9b1e22d52e9c221c62b8d9b6dd1151a3