Bug 420365 - wrong network speed
Summary: wrong network speed
Status: RESOLVED FIXED
Alias: None
Product: plasma-nm
Classification: Unclassified
Component: applet (show other bugs)
Version: 5.20.3
Platform: Manjaro Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Jan Grulich
URL:
Keywords:
: 429438 433632 436635 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-21 06:54 UTC by edcwsxqz
Modified: 2021-06-03 11:28 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.22


Attachments
this is where i get the bug, i'm not sure if it's a kde bug or a manjaro one (10.48 KB, image/png)
2020-04-21 06:54 UTC, edcwsxqz
Details
Wrong upload/download speed (94.58 KB, image/png)
2021-03-22 21:59 UTC, popov895
Details

Note You need to log in before you can comment on or make changes to this bug.
Description edcwsxqz 2020-04-21 06:54:47 UTC
Created attachment 127731 [details]
this is where i get the bug, i'm not sure if it's a kde bug or a manjaro one

SUMMARY


STEPS TO REPRODUCE
1. click the network icon in the panel

OBSERVED RESULT
 speed shows 0 for a second then a false number that's higher than the real one then after a second or 2 you get the real number

EXPECTED RESULT
 you get the actual speed from the first time

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 5.6.5-1-MANJARO
(available in About System)
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.69.0
Qt Version: 5.14.2

ADDITIONAL INFORMATION
Comment 1 Justin Zobel 2020-11-19 23:23:25 UTC
I can sometimes reproduce this on 5.20.3.

I opened it to test and got shown a 1.3Gbit/s number which is impossible due to the network connection only being 1Gbit/s and there would have been very little traffic on my connection at the time I opened it.
Comment 2 Nate Graham 2020-11-19 23:31:56 UTC
Ah yes this bug! It was just fixed a little bit ago.
Comment 3 Nate Graham 2020-11-23 18:27:24 UTC
*** Bug 429438 has been marked as a duplicate of this bug. ***
Comment 4 popov895 2021-03-22 21:59:16 UTC
Created attachment 136956 [details]
Wrong upload/download speed
Comment 5 popov895 2021-03-22 22:03:04 UTC
Network applet shows an incorrect value for the download/upload speed when first opened. Again.

SOFTWARE/OS VERSIONS
 
Linux/KDE Plasma: openSUSE Tumbleweed 20210320 / X11
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
NetworkManager: 1.30.0
Comment 6 Nate Graham 2021-05-05 19:42:32 UTC
*** Bug 436635 has been marked as a duplicate of this bug. ***
Comment 7 David Redondo 2021-05-17 09:47:15 UTC
Git commit d5df9379ef9825a65178d5d2335237cd0f84b90e by David Redondo.
Committed on 17/05/2021 at 09:37.
Pushed by davidre into branch 'master'.

Prevent showing wrong speeds on initial open

Previous attempt was the onCompleted block. However it turns out that
at that point the model still has the old byte amounts.  The order is
showSpeedChanged -> setRefreshRate -> Timer.onCompleted/runningChanged -> model updates
So set the amount to 0 in onCompleted and trigger the Timer on start
(like a Timer with 0 interval). This initial trigger happens after the
 odel gets a new value and we have a correct amount on the first regular
trigger of the Timer.
FIXED-IN:5.22

M  +3    -2    applet/contents/ui/ConnectionItem.qml

https://invent.kde.org/plasma/plasma-nm/commit/d5df9379ef9825a65178d5d2335237cd0f84b90e
Comment 8 David Redondo 2021-05-17 09:47:54 UTC
Git commit c36ab9a29f70986b5672a9f7b2913a18ef1f0aaa by David Redondo.
Committed on 17/05/2021 at 09:47.
Pushed by davidre into branch 'Plasma/5.22'.

Prevent showing wrong speeds on initial open

Previous attempt was the onCompleted block. However it turns out that
at that point the model still has the old byte amounts.  The order is
showSpeedChanged -> setRefreshRate -> Timer.onCompleted/runningChanged -> model updates
So set the amount to 0 in onCompleted and trigger the Timer on start
(like a Timer with 0 interval). This initial trigger happens after the
 odel gets a new value and we have a correct amount on the first regular
trigger of the Timer.
FIXED-IN:5.22


(cherry picked from commit d5df9379ef9825a65178d5d2335237cd0f84b90e)

M  +3    -2    applet/contents/ui/ConnectionItem.qml

https://invent.kde.org/plasma/plasma-nm/commit/c36ab9a29f70986b5672a9f7b2913a18ef1f0aaa
Comment 9 Patrick Silva 2021-06-03 11:28:19 UTC
*** Bug 433632 has been marked as a duplicate of this bug. ***