Bug 410493 - "Drag start distance" configuration option missing when using Libinput
Summary: "Drag start distance" configuration option missing when using Libinput
Status: CONFIRMED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_accessibility (show other bugs)
Version: 5.16.3
Platform: Manjaro Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL: https://bugreports.qt.io/browse/QTBUG...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-01 18:15 UTC by Matthias Mueller
Modified: 2020-10-26 03:44 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Mueller 2019-08-01 18:15:20 UTC
When using libinput, the mouse configuration is pretty limited compared to the evdev mouse KCM.

My personal main issue is the missing "drag start distance" and "drag start time", but there are several other reports about scroll speed:
https://bugs.kde.org/show_bug.cgi?id=403843
https://bugs.kde.org/show_bug.cgi?id=403842

There have been other related reports:
https://bugs.kde.org/show_bug.cgi?id=398610
https://bugs.kde.org/show_bug.cgi?id=374311

And a corresponding report over at QT:
https://bugreports.qt.io/browse/QTBUG-57849

As it sounded like it was not possible to access this configurations with libinput, i filed a report there, in which nate corrected me:
https://gitlab.freedesktop.org/libinput/libinput/issues/333

So i'm creating this one as a kind of "collect all" report ;)
Comment 1 Nate Graham 2019-08-01 19:29:00 UTC
Let's use this to track just the issue of "drag start distance"  being missing.
Comment 2 Nate Graham 2019-08-01 19:30:01 UTC
*** Bug 387459 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2019-08-01 19:30:06 UTC
*** Bug 410236 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2019-08-01 19:30:23 UTC
*** Bug 374311 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2019-08-01 19:32:38 UTC
UI-wise, one issue here is that this isn't just a mouse setting; it affects touchpad right-clicking too. So it wouldn't really be appropriate to put it in either the mouse KCM or the touchpad KCM. If we had a combined Mouse & Touchpad KCM like GNOME has, then we could use that to locate options that affect both mice and touchpads, like the "Drag start distance" setting as well as the single-click/double-click setting that got moved to Workspace Behavior a year or so ago.
Comment 6 Matthias Mueller 2019-08-01 19:53:47 UTC
As this won't be too many configuration options (if i understood correct?), i see no issue in adding them to workspace behaviour.
One thing to consider might be hiding these options in workspace behaviour when evdev is used though.
Comment 7 Christoph Feck 2019-08-01 21:57:06 UTC
Nate, re-adding the missing configuration for the time/distance values won't fix the Qt bug of not respecting them in the first place.
Comment 8 Nate Graham 2019-08-01 22:24:04 UTC
True enough, but without a user-visible setting, once the Qt issue is fixed, we'll still need some way for people to twiddle with it, right?

Should https://bugreports.qt.io/browse/QTBUG-57849 be renamed?
Comment 9 Mark Smith 2020-10-24 10:11:48 UTC
Has this been solved upstream? It doesn't happen anymore on my freshly reinstalled and updated KDE Neon.
Comment 10 Raghavendra kamath 2020-10-24 11:04:26 UTC
@Mark Smith No the upstream bug is not solved yet and I can still reproduce this on plasma 5.20.1 on arch
Comment 11 Nate Graham 2020-10-24 16:09:06 UTC
Moving to the accessibility KCM, since that's where the other click-related tweaks now live, and there is no logical reason to put this in the mouse settings since it's not a mouse-specific setting (it affects touchpads too).
Comment 12 Mark Smith 2020-10-25 15:42:01 UTC
(In reply to Raghavendra kamath from comment #10)
> @Mark Smith No the upstream bug is not solved yet and I can still reproduce
> this on plasma 5.20.1 on arch

I know for sure this doesn't happen anymore on 
Operating System: KDE neon 5.20
KDE Plasma Version: 5.20.1
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.0
Kernel Version: 5.4.0-52-generic

It still happens in certain apps such as Firefox. But in every KDE app it doesn't happen anymore. 

Insert confused face emoji here.
Comment 13 Raghavendra kamath 2020-10-25 16:29:47 UTC
For me it happens in krita and the problem is more highlighted when you use a graphic tablet where your cursor won't be as static as the mouse.

In krita right clicking on a layer would instantly trigger a miss click and activate the first context menu item.
Comment 14 Christoph Feck 2020-10-26 03:44:17 UTC
> doesn't happen anymore on 
> Qt Version: 5.15.0

There is a regression in Qt 5.15.0 that prevents the down-move-up menu selection to no longer work, you need to use down-up-move-down-up. This is fixed in Qt 5.15.1, so if you update Qt, then you will see QTBUG-57849 bug again.