Bug 398610 - Mouse settings have lost lot of settings
Summary: Mouse settings have lost lot of settings
Status: RESOLVED DUPLICATE of bug 403842
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_mouse (show other bugs)
Version: 5.13.1
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-14 09:17 UTC by DeMus
Modified: 2021-04-12 16:46 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DeMus 2018-09-14 09:17:34 UTC
Since sometime now, the mouse-settings have been reduced to almost nothing. Where in previous versions you could adjust the mouse the way you wanted, you can adjust nothing now anymore. This results in unexpected and unwanted behavior.
Example: scrolling in Dolphin with mouse-wheel. Where I could set to scroll 1 or 2 lines per notch of the wheel, I can adjust nothing now. Moving the mouse-wheel one notch now results in a totally new screen contents since the content of the window is scrolled way too much.
Please bring back the old settings and let KDE be KDE, where everything is adjustable.
Comment 1 Patrick Silva 2018-09-14 11:57:45 UTC
probably you are using mouse kcm for libinput.
many features are not available in libinput, you can replace libinput with evdev under X11.
Comment 2 Nate Graham 2018-09-14 17:51:58 UTC
KDE didn't remove these features, Libinput did. What changed is that in Plasma 5.13, we now support Libinput when used as a mouse driver. So if you have Libinput installed, you will see the Libinput-specific configuration interface that lacks controls for features Libinput doesn't support.

If you preferred the old interface and set of settings, you'll need to remove Libinput, which will make the mouse KCM fall back to the old evdev driver that did support those features.
Comment 3 Rog131 2018-09-23 08:24:58 UTC
Don't remove nothing. Add /etc/X11/xorg.conf.d/xorg.conf with the:

Section "InputClass"
    Identifier "evdev-mouse"
    MatchIsPointer "yes"
    Driver "evdev"
EndSection

More: https://www.reddit.com/r/archlinux/comments/6ce1ks/pacman_rs_xf86inputlibinput_fails/
Comment 4 Nate Graham 2019-08-01 19:33:42 UTC

*** This bug has been marked as a duplicate of bug 403842 ***
Comment 5 Alex Abakumov 2021-04-12 16:46:07 UTC
(In reply to Rog131 from comment #3)
> Don't remove nothing. Add /etc/X11/xorg.conf.d/xorg.conf with the:
> 
> Section "InputClass"
>     Identifier "evdev-mouse"
>     MatchIsPointer "yes"
>     Driver "evdev"
> EndSection
> 
> More:
> https://www.reddit.com/r/archlinux/comments/6ce1ks/
> pacman_rs_xf86inputlibinput_fails/

I have KDE Plasma 5.20.5. I switched Xorg to use the evdev driver:
[  5457.753] (II) Using input driver 'evdev' for 'Logitech M705'
But the Mouse config section still doesn't any tabs including the Advanced tab.
Could you advuce, please?