Bug 407125 - Korganizer crashes on startup
Summary: Korganizer crashes on startup
Status: RESOLVED DUPLICATE of bug 406411
Alias: None
Product: korgac
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-05-01 13:36 UTC by Chris Prior
Modified: 2019-05-01 14:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Prior 2019-05-01 13:36:10 UTC
Application: korgac (5.10.3)
 (Compiled from sources)
Qt Version: 5.11.3
Frameworks Version: 5.54.0
Operating System: Linux 4.19.27-gentoo-r1 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
Immediately on login to plasma desktop, the segfault occurs. Data stored in postgresql-11 database.

The crash can be reproduced every time.

-- Backtrace:
Application: KOrganizer Reminder Daemon (korgac), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f158058b840 (LWP 28737))]

Thread 5 (Thread 0x7f1574b03700 (LWP 28757)):
#0  0x00007f1594852db3 in poll () from /lib64/libc.so.6
#1  0x00007f158bbfc4f6 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f158bbfc62c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f15953e5253 in QEventDispatcherGlib::processEvents (this=0x7f156c000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1595392953 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#5  0x00007f1595201756 in QThread::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#6  0x00007f159520adfb in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:367
#7  0x00007f158e13a253 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f159485f5af in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f1575304700 (LWP 28754)):
#0  0x00007f158bbcc9b5 in g_ptr_array_set_size () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f158bbfb8d8 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f158bbfc42b in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f158bbfc62c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f15953e5253 in QEventDispatcherGlib::processEvents (this=0x7f1568000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f1595392953 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#6  0x00007f1595201756 in QThread::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#7  0x00007f159520adfb in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:367
#8  0x00007f158e13a253 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f159485f5af in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f157671f700 (LWP 28753)):
#0  0x00007f1594852db3 in poll () from /lib64/libc.so.6
#1  0x00007f158bbfc4f6 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f158bbfc62c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f15953e5253 in QEventDispatcherGlib::processEvents (this=0x7f1570000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1595392953 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#5  0x00007f1595201756 in QThread::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#6  0x00007f15961a5e35 in ?? () from /usr/lib64/libQt5DBus.so.5
#7  0x00007f159520adfb in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:367
#8  0x00007f158e13a253 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f159485f5af in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f157d9e0700 (LWP 28749)):
#0  0x00007f1594852db3 in poll () from /lib64/libc.so.6
#1  0x00007f158e56284f in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f158e56460a in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f157ff6e289 in QXcbEventReader::run (this=0x5618fa65c860) at qxcbconnection.h:409
#4  0x00007f159520adfb in QThreadPrivate::start(void*) () at thread/qthread_unix.cpp:367
#5  0x00007f158e13a253 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f159485f5af in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f158058b840 (LWP 28737)):
[KCrash Handler]
#6  0x00007f1599cbd328 in Akonadi::BlockAlarmsAttribute::isAlarmTypeBlocked (this=this@entry=0x5618fa877250, type=<optimized out>) at /var/tmp/portage/kde-apps/akonadi-calendar-18.12.3-r1/work/akonadi-calendar-18.12.3/src/blockalarmsattribute.cpp:84
#7  0x00007f1599cd07cc in Akonadi::ETMCalendar::alarms(QDateTime const&, QDateTime const&, bool) const () at /usr/include/qt5/QtCore/qsharedpointer_impl.h:312
#8  0x00005618f9629c69 in KOAlarmClient::checkAlarms() () at /usr/include/qt5/QtCore/qsharedpointer_impl.h:312
#9  0x00005618f962aac4 in KOAlarmClient::deferredInit() () at /var/tmp/portage/kde-apps/korganizer-18.12.3-r1/work/korganizer-18.12.3/korgac/koalarmclient.cpp:169
#10 0x00007f15953bc872 in QtPrivate::QSlotObjectBase::call (a=0x7ffc55fa82a0, r=0x7ffc55fa8b60, this=0x5618fa74c1b0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:376
#11 QMetaObject::activate(QObject*, int, int, void**) () at kernel/qobject.cpp:3754
#12 0x00007f15953bcd4f in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7f1597eedba0 <Akonadi::EntityTreeModel::staticMetaObject>, local_signal_index=22040, local_signal_index@entry=1, argv=0x7ffc55fa82e8, argv@entry=0x7ffc55fa82a0) at kernel/qobject.cpp:3633
#13 0x00007f1597e370c2 in Akonadi::EntityTreeModel::collectionPopulated (this=<optimized out>, _t1=<optimized out>) at src/core/KF5AkonadiCore_autogen/include/moc_entitytreemodel.cpp:509
#14 0x00007f1597e42d6b in Akonadi::EntityTreeModelPrivate::itemFetchJobDone(KJob*) () at /var/tmp/portage/kde-apps/akonadi-18.12.3-r1/work/akonadi-18.12.3/src/core/models/entitytreemodel_p.cpp:1384
#15 0x00007f1597e39340 in Akonadi::EntityTreeModel::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () at /var/tmp/portage/kde-apps/akonadi-18.12.3-r1/work/akonadi-18.12.3/src/core/models/entitytreemodel.h:681
#16 0x00007f15953bc746 in QMetaObject::activate(QObject*, int, int, void**) () at kernel/qobject.cpp:3771
#17 0x00007f15953bcd4f in QMetaObject::activate (sender=sender@entry=0x5618fa75f170, m=m@entry=0x7f1599c7d500 <KJob::staticMetaObject>, local_signal_index=22040, local_signal_index@entry=3, argv=0x1, argv@entry=0x7ffc55fa84c0) at kernel/qobject.cpp:3633
#18 0x00007f1599c249ec in KJob::result (this=this@entry=0x5618fa75f170, _t1=<optimized out>, _t1@entry=0x5618fa75f170, _t2=...) at /var/tmp/portage/kde-frameworks/kcoreaddons-5.54.0/work/kcoreaddons-5.54.0_build/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:569
#19 0x00007f1599c25613 in KJob::finishJob (this=0x5618fa75f170, emitResult=<optimized out>) at /var/tmp/portage/kde-frameworks/kcoreaddons-5.54.0/work/kcoreaddons-5.54.0/src/lib/jobs/kjob.cpp:109
#20 0x00007f15953c8536 in QtPrivate::QSlotObjectBase::call (a=0x7ffc55fa8510, r=<optimized out>, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:376
#21 QSingleShotTimer::timerEvent (this=0x5618fa7c3950) at kernel/qtimer.cpp:318
#22 0x00007f15953bd39b in QObject::event(QEvent*) () at kernel/qobject.cpp:1232
#23 0x00007f1595c79861 in QApplicationPrivate::notify_helper (this=this@entry=0x5618fa64c610, receiver=receiver@entry=0x5618fa7c3950, e=e@entry=0x7ffc55fa87c0) at kernel/qapplication.cpp:3726
#24 0x00007f1595c812d0 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3485
#25 0x00007f1595393b61 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at kernel/qcoreapplication.cpp:1047
#26 0x00007f15953e4491 in QCoreApplication::sendEvent (event=0x7ffc55fa87c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#27 QTimerInfoList::activateTimers() () at kernel/qtimerinfo_unix.cpp:643
#28 0x00007f15953e4d81 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:182
#29 0x00007f158bbfc2dd in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f158bbfc580 in ?? () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f158bbfc62c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f15953e523f in QEventDispatcherGlib::processEvents (this=0x5618fa69b700, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f1580000cf1 in QPAEventDispatcherGlib::processEvents (this=0x5618fa69b700, flags=...) at qeventdispatcher_glib.cpp:69
#34 0x00007f1595392953 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#35 0x00007f159539ac2f in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#36 0x00005618f96284ff in main () at /var/tmp/portage/kde-apps/korganizer-18.12.3-r1/work/korganizer-18.12.3/korgac/korgacmain.cpp:68
#37 0x00007f159477a70e in __libc_start_main () from /lib64/libc.so.6
#38 0x00005618f962866a in _start () at /var/tmp/portage/kde-apps/korganizer-18.12.3-r1/work/korganizer-18.12.3/korgac/korgacmain.cpp:68

Possible duplicates by query: bug 406521.

Reported using DrKonqi
Comment 1 Wolfgang Bauer 2019-05-01 14:27:05 UTC
Fixed in akonadi-calendar 5.11.0 (KDE Applications 19.04.0).

*** This bug has been marked as a duplicate of bug 406411 ***