Bug 406521 - korgac crash on start up
Summary: korgac crash on start up
Status: CLOSED DUPLICATE of bug 406411
Alias: None
Product: korgac
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-14 08:20 UTC by Chili81
Modified: 2019-04-29 18:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
crash log (8.19 KB, text/plain)
2019-04-14 08:20 UTC, Chili81
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chili81 2019-04-14 08:20:25 UTC
Created attachment 119407 [details]
crash log

SUMMARY


STEPS TO REPRODUCE
1. restart PC
2. 
3. 

OBSERVED RESULT
crash: korgac PID: 1719 Signal: Segmentation fault (11) 

EXPECTED RESULT
normal start without crash

SOFTWARE/OS VERSIONS
Windows: -
macOS: -
Linux/KDE Plasma: KDE Neon 5.15
(available in About System)
KDE Plasma Version:  5.15.4
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.0
Kernel 4.15.0-47-generic
64bit OS

ADDITIONAL INFORMATION
Application: KOrganizer-Erinnerungsmodul (korgac), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fdc2c86e880 (LWP 1719))]

Thread 5 (Thread 0x7fdc05423700 (LWP 1815)):
#0  0x00007fdc2664cbf9 in __GI___poll (fds=0x7fdbfc003ce0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fdc1d5c4539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdc1d5c464c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdc271a715b in QEventDispatcherGlib::processEvents (this=0x7fdbfc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fdc2714864a in QEventLoop::exec (this=this@entry=0x7fdc05422d20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007fdc26f7041a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#6  0x00007fdc26f71bc2 in QThreadPrivate::start (arg=0x558489c18a80) at thread/qthread_unix.cpp:361
#7  0x00007fdc1f33f6db in start_thread (arg=0x7fdc05423700) at pthread_create.c:463
#8  0x00007fdc2665988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fdc05c24700 (LWP 1810)):
#0  0x00007fdc2664cbf9 in __GI___poll (fds=0x7fdbf80049b0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fdc1d5c4539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdc1d5c464c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdc271a715b in QEventDispatcherGlib::processEvents (this=0x7fdbf8000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fdc2714864a in QEventLoop::exec (this=this@entry=0x7fdc05c23d20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007fdc26f7041a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#6  0x00007fdc26f71bc2 in QThreadPrivate::start (arg=0x558489c3a1c0) at thread/qthread_unix.cpp:361
#7  0x00007fdc1f33f6db in start_thread (arg=0x7fdc05c24700) at pthread_create.c:463
#8  0x00007fdc2665988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fdc0703e700 (LWP 1804)):
#0  0x00007fdc2664cbf9 in __GI___poll (fds=0x558489c79920, nfds=1, timeout=7169) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fdc1d5c4539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdc1d5c464c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdc271a715b in QEventDispatcherGlib::processEvents (this=0x7fdc00000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fdc2714864a in QEventLoop::exec (this=this@entry=0x7fdc0703dcf0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#5  0x00007fdc26f7041a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#6  0x00007fdc27615015 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007fdc26f71bc2 in QThreadPrivate::start (arg=0x7fdc2788cd80) at thread/qthread_unix.cpp:361
#8  0x00007fdc1f33f6db in start_thread (arg=0x7fdc0703e700) at pthread_create.c:463
#9  0x00007fdc2665988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fdc0dc13700 (LWP 1785)):
#0  0x00007fdc2664cbf9 in __GI___poll (fds=0x7fdc0dc12c38, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fdc1f96d747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fdc1f96f36a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fdc0ef8732a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fdc26f71bc2 in QThreadPrivate::start (arg=0x558489b6aa90) at thread/qthread_unix.cpp:361
#5  0x00007fdc1f33f6db in start_thread (arg=0x7fdc0dc13700) at pthread_create.c:463
#6  0x00007fdc2665988f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fdc2c86e880 (LWP 1719)):
[KCrash Handler]
#6  0x00007fdc2b96f9c9 in Akonadi::BlockAlarmsAttribute::isAlarmTypeBlocked (this=this@entry=0x55848a21e7a0, type=KCalCore::Alarm::Display) at ./src/blockalarmsattribute.cpp:84
#7  0x00007fdc2b982b70 in Akonadi::ETMCalendar::alarms (this=<optimized out>, from=..., to=..., excludeBlockedAlarms=<optimized out>) at ./src/etmcalendar.cpp:579
#8  0x0000558488cca850 in KOAlarmClient::checkAlarms (this=this@entry=0x7ffdbcab8e80) at ./korgac/koalarmclient.cpp:223
#9  0x0000558488ccb883 in KOAlarmClient::deferredInit (this=0x7ffdbcab8e80) at ./korgac/koalarmclient.cpp:169
#10 0x00007fdc27179f3f in QtPrivate::QSlotObjectBase::call (a=0x7ffdbcab8540, r=0x7ffdbcab8e80, this=0x558489c43bc0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#11 QMetaObject::activate (sender=0x7fdc0001d8c0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffdbcab8540) at kernel/qobject.cpp:3759
#12 0x00007fdc2717a4f7 in QMetaObject::activate (sender=<optimized out>, m=m@entry=0x7fdc2a552c20 <Akonadi::EntityTreeModel::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7ffdbcab8540) at kernel/qobject.cpp:3631
#13 0x00007fdc2a2a75f2 in Akonadi::EntityTreeModel::collectionPopulated (this=<optimized out>, _t1=<optimized out>) at ./obj-x86_64-linux-gnu/src/core/KF5AkonadiCore_autogen/include/moc_entitytreemodel.cpp:513
#14 0x00007fdc2a2b3730 in Akonadi::EntityTreeModelPrivate::itemFetchJobDone (this=0x558489c466c0, job=<optimized out>) at ./src/core/models/entitytreemodel_p.cpp:1384
#15 0x00007fdc2a2a8450 in Akonadi::EntityTreeModel::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./obj-x86_64-linux-gnu/src/core/KF5AkonadiCore_autogen/include/moc_entitytreemodel.cpp:214
#16 0x00007fdc27179e25 in QMetaObject::activate (sender=sender@entry=0x558489ca29c0, signalOffset=<optimized out>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffdbcab8780) at kernel/qobject.cpp:3778
#17 0x00007fdc2717a4f7 in QMetaObject::activate (sender=sender@entry=0x558489ca29c0, m=m@entry=0x7fdc28dc3500 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffdbcab8780) at kernel/qobject.cpp:3631
#18 0x00007fdc28b6bd9c in KJob::result (this=this@entry=0x558489ca29c0, _t1=<optimized out>, _t1@entry=0x558489ca29c0, _t2=...) at ./obj-x86_64-linux-gnu/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:573
#19 0x00007fdc28b6c8d1 in KJob::finishJob (this=0x558489ca29c0, emitResult=<optimized out>) at ./src/lib/jobs/kjob.cpp:109
#20 0x00007fdc27186d04 in QtPrivate::QSlotObjectBase::call (a=0x7ffdbcab87e0, r=<optimized out>, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#21 QSingleShotTimer::timerEvent (this=0x558489ca85c0) at kernel/qtimer.cpp:318
#22 0x00007fdc2717a94b in QObject::event (this=0x558489ca85c0, e=<optimized out>) at kernel/qobject.cpp:1271
#23 0x00007fdc2842f83c in QApplicationPrivate::notify_helper (this=this@entry=0x558489b65760, receiver=receiver@entry=0x558489ca85c0, e=e@entry=0x7ffdbcab8b20) at kernel/qapplication.cpp:3752
#24 0x00007fdc28436dd0 in QApplication::notify (this=0x7ffdbcab8e50, receiver=0x558489ca85c0, e=0x7ffdbcab8b20) at kernel/qapplication.cpp:3499
#25 0x00007fdc2714a328 in QCoreApplication::notifyInternal2 (receiver=0x558489ca85c0, event=0x7ffdbcab8b20) at kernel/qcoreapplication.cpp:1061
#26 0x00007fdc271a65a9 in QTimerInfoList::activateTimers (this=0x558489bb3e60) at kernel/qtimerinfo_unix.cpp:643
#27 0x00007fdc271a6d71 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:182
#28 0x00007fdc1d5c4387 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fdc1d5c45c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fdc1d5c464c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fdc271a713f in QEventDispatcherGlib::processEvents (this=0x558489bc0040, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fdc2714864a in QEventLoop::exec (this=this@entry=0x7ffdbcab8d70, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#33 0x00007fdc27151800 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1364
#34 0x0000558488cc908f in main (argc=<optimized out>, argv=<optimized out>) at ./korgac/korgacmain.cpp:68
Comment 1 Chili81 2019-04-14 08:21:21 UTC
Version 5.10.3
Comment 2 Wolfgang Bauer 2019-04-14 18:42:29 UTC

*** This bug has been marked as a duplicate of bug 406411 ***
Comment 3 Chili81 2019-04-29 18:32:24 UTC
Does not crash anymore - seems to be resolved.