Bug 406475 - Artist view grid is visually overwhelming
Summary: Artist view grid is visually overwhelming
Status: RESOLVED FIXED
Alias: None
Product: Elisa
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Matthieu Gallien
URL:
Keywords:
: 434350 434698 458559 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-12 15:01 UTC by Nate Graham
Modified: 2022-08-31 19:58 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.12


Attachments
Artist view grid is overwhelming (233.33 KB, image/png)
2019-04-12 15:01 UTC, Nate Graham
Details
How lollypop handles Artist view (943.10 KB, image/png)
2019-04-12 15:03 UTC, Nate Graham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2019-04-12 15:01:04 UTC
Created attachment 119379 [details]
Artist view grid is overwhelming

The Artist view grid is visually overwhelming and very difficult to navigate due to the use of the same icon for every artist. It suffers from the same problem as Bug 406474. See screenshot.

Lollypop automatically fetches artist artwork, which would be nice (see screenshot). Alternatively, just making it a list-style view with no icons would work too.
Comment 1 Nate Graham 2019-04-12 15:03:29 UTC
Created attachment 119380 [details]
How lollypop handles Artist view

Here's how Lollypop handles artist view, which I quite like. It's a flat list with automatically downloaded art for each artist. Also, I can see three levels of navigation: a list of genres, then a list of artists in that genre, then finally that artist's genres. It's really nice and very compact; as you can see, all three levels of navigation are visible for a window that's not very wide.
Comment 2 Matthieu Gallien 2019-05-02 20:58:39 UTC
Thanks for your report.
I have tried Lollypop (there is also the design work done by Andrew Lake) and saw an artist image made of up to 1 album cover and genre image is made of up to 4 albums cover. This is quite similar to the design at the origin of Elisa.
This should probably be a good fallback for the case where no artist image exists.
Comment 3 James Cain 2020-02-22 06:07:48 UTC
I agree - something needs to be done here. The album view looks great, but that artist view...uhm...pretty jarring!

AmaroK had Wikipedia integration as an option...having such a thing would also provide the hooks to use the default artist picture as the default in Elisa, in addition to being a really nice plugin for those who want some more detail on their "now playing" view.*

Hopefully something can be decided soon - even if the only option is to force no icons for artists; only a list view until a proper solution can be found :)

* See "Wikipedia integration" section at https://community.kde.org/Amarok/Archives/Amarokfeatures for context and example
Comment 4 Nate Graham 2020-02-22 16:46:45 UTC
Yeah, that would be nice.
Comment 5 Morbid 2020-04-25 14:18:57 UTC
How about an interim fallback to the picture in the artist's folder? Similar to fallbacks for album art for a song?
Comment 6 Nate Graham 2021-03-16 03:15:50 UTC
*** Bug 434350 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2021-03-21 13:23:45 UTC
*** Bug 434698 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2022-08-15 15:31:32 UTC
Git commit e6b0c7215a63396a147ecfc58f176d508bc84ef8 by Nate Graham, on behalf of Stefan Vukanović.
Committed on 15/08/2022 at 15:31.
Pushed by ngraham into branch 'master'.

Use up to four latest album or track covers as artist cover

When retrieving artist data, find up to four latest album or track covers
and display them as the artist's cover in a grid layout. If four covers
can't be found, display only the latest one.

This should improve the UX of the Artists view, which right now is a sea
of identical icons.
FIXED-IN: 22.12

M  +94   -17   src/databaseinterface.cpp
M  +2    -0    src/databaseinterface.h
M  +5    -0    src/datatypes.h
M  +29   -11   src/embeddedcoverageimageprovider.cpp
M  +1    -0    src/models/datamodel.cpp
M  +1    -0    src/qml/DataGridView.qml
M  +55   -23   src/qml/GridBrowserDelegate.qml
M  +1    -1    src/viewslistdata.cpp

https://invent.kde.org/multimedia/elisa/commit/e6b0c7215a63396a147ecfc58f176d508bc84ef8
Comment 9 Nate Graham 2022-08-31 19:58:14 UTC
*** Bug 458559 has been marked as a duplicate of this bug. ***