Bug 404546 - KCrash: Arguments: /usr/bin/gwenview
Summary: KCrash: Arguments: /usr/bin/gwenview
Status: RESOLVED DUPLICATE of bug 395198
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 18.12.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-02-19 09:03 UTC by jimmyzoe
Modified: 2019-02-19 16:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jimmyzoe 2019-02-19 09:03:45 UTC
Application: gwenview (18.12.2)

Qt Version: 5.12.0
Frameworks Version: 5.55.0
Operating System: Linux 4.15.0-45-generic x86_64
Distribution: KDE neon User Edition 5.15

-- Information about the crash:
i was opening photos 
axenx@axenx:~$ gwenview
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = gwenview path = /usr/bin pid = 2657
KCrash: Arguments: /usr/bin/gwenview
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0

[1]+  Fermato                 gwenview

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f79e72ac8c0 (LWP 15088))]

Thread 4 (Thread 0x7f79b2c62700 (LWP 15092)):
#0  0x00007f79dc2a39f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55ced3dfa3a8) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x55ced3dfa358, cond=0x55ced3dfa380) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x55ced3dfa380, mutex=0x55ced3dfa358) at pthread_cond_wait.c:655
#3  0x00007f79b36e5b1b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f79b36e5847 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f79dc29d6db in start_thread (arg=0x7f79b2c62700) at pthread_create.c:463
#6  0x00007f79e213788f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f79c3bf0700 (LWP 15090)):
#0  0x00007f79da7984a2 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f79da79864c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f79e2a6d15b in QEventDispatcherGlib::processEvents (this=0x7f79bc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007f79e2a0e64a in QEventLoop::exec (this=this@entry=0x7f79c3befcb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#4  0x00007f79e283641a in QThread::exec (this=<optimized out>) at thread/qthread.cpp:531
#5  0x00007f79e10bb015 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#6  0x00007f79e2837bc2 in QThreadPrivate::start (arg=0x7f79e1332d80) at thread/qthread_unix.cpp:361
#7  0x00007f79dc29d6db in start_thread (arg=0x7f79c3bf0700) at pthread_create.c:463
#8  0x00007f79e213788f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f79caba3700 (LWP 15089)):
#0  0x00007f79e212abf9 in __GI___poll (fds=0x7f79caba2bf8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f79da52f747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f79da53136a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f79cd533d4a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f79e2837bc2 in QThreadPrivate::start (arg=0x55ced3d11780) at thread/qthread_unix.cpp:361
#5  0x00007f79dc29d6db in start_thread (arg=0x7f79caba3700) at pthread_create.c:463
#6  0x00007f79e213788f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f79e72ac8c0 (LWP 15088)):
[KCrash Handler]
#6  0x00007f79e080f0ad in Exiv2::ExifData::findKey(Exiv2::ExifKey const&) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#7  0x00007f79e0853496 in Exiv2::Internal::PentaxMakerNote::printShutterCount(std::ostream&, Exiv2::Value const&, Exiv2::ExifData const*) () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#8  0x00007f79e080d957 in Exiv2::Exifdatum::write(std::ostream&, Exiv2::ExifData const*) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#9  0x00007f79e6957c4f in Exiv2::operator<< (md=..., os=...) at /usr/include/exiv2/metadatum.hpp:305
#10 Gwenview::ImageMetaInfoModelPrivate::fillExivGroup<Exiv2::ExifData, std::_List_const_iterator<Exiv2::Exifdatum> > (this=0x55ced4347cd0, parent=..., group=group@entry=0x55ced43483a0, container=...) at ./lib/imagemetainfomodel.cpp:284
#11 0x00007f79e6953611 in Gwenview::ImageMetaInfoModel::setExiv2Image (this=<optimized out>, image=0x7f79b40060a0) at ./lib/imagemetainfomodel.cpp:444
#12 0x00007f79e6906347 in Gwenview::Document::setExiv2Image (this=0x55ced4349110, image=...) at ./lib/document/document.cpp:394
#13 0x00007f79e6905361 in Gwenview::AbstractDocumentImpl::setDocumentExiv2Image (this=this@entry=0x55ced43490b0, image=...) at ./lib/document/abstractdocumentimpl.cpp:82
#14 0x00007f79e6915451 in Gwenview::LoadingDocumentImpl::slotMetaInfoLoaded (this=0x55ced43490b0) at ./lib/document/loadingdocumentimpl.cpp:489
#15 0x00007f79e2a3fe25 in QMetaObject::activate (sender=0x55ced4175828, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3778
#16 0x00007f79e2843863 in QFutureWatcherBase::event (this=<optimized out>, event=0x55ced4348b70) at thread/qfuturewatcher.cpp:334
#17 0x00007f79e41f183c in QApplicationPrivate::notify_helper (this=this@entry=0x55ced3d0eb00, receiver=receiver@entry=0x55ced4175828, e=e@entry=0x55ced4348b70) at kernel/qapplication.cpp:3752
#18 0x00007f79e41f8dd0 in QApplication::notify (this=0x7fffe3663720, receiver=0x55ced4175828, e=0x55ced4348b70) at kernel/qapplication.cpp:3499
#19 0x00007f79e2a10328 in QCoreApplication::notifyInternal2 (receiver=0x55ced4175828, event=0x55ced4348b70) at kernel/qcoreapplication.cpp:1061
#20 0x00007f79e2a104fe in QCoreApplication::sendEvent (receiver=<optimized out>, event=event@entry=0x55ced4348b70) at kernel/qcoreapplication.cpp:1451
#21 0x00007f79e2a12e87 in QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x55ced3d03d80) at kernel/qcoreapplication.cpp:1800
#22 0x00007f79e2a13428 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1654
#23 0x00007f79e2a6db23 in postEventSourceDispatch (s=0x55ced3d5b3f0) at kernel/qeventdispatcher_glib.cpp:276
#24 0x00007f79da798387 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f79da7985c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f79da79864c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f79e2a6d13f in QEventDispatcherGlib::processEvents (this=0x55ced3d6c7e0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#28 0x00007f79e2a0e64a in QEventLoop::exec (this=this@entry=0x7fffe3663620, flags=..., flags@entry=...) at kernel/qeventloop.cpp:225
#29 0x00007f79e2a17800 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1364
#30 0x000055ced2b696a1 in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:163

Possible duplicates by query: bug 403615, bug 400952.

Reported using DrKonqi
Comment 1 Nate Graham 2019-02-19 16:35:29 UTC
Must be fixed with a new version of Exiv2. See Bug 404033.

*** This bug has been marked as a duplicate of bug 395198 ***