Bug 403615 - Gwenview crash after open some tif image.
Summary: Gwenview crash after open some tif image.
Status: RESOLVED DUPLICATE of bug 395198
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 18.12.1
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-01-26 08:52 UTC by kaleckir
Modified: 2019-02-06 04:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kaleckir 2019-01-26 08:52:11 UTC
Application: gwenview (18.12.1)

Qt Version: 5.11.2
Frameworks Version: 5.54.0
Operating System: Linux 4.15.0-43-generic x86_64
Distribution: KDE neon User Edition 5.14

-- Information about the crash:
- What I was doing when the application crashed:
Open .tif image. Tif are generated from Pentax .PEF RAW format.
Sample tif:
https://drive.google.com/open?id=1IgTSnkigt7tjHJWaM2BIztN90eM1mlfv

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ff7f0cbc8c0 (LWP 5026))]

Thread 3 (Thread 0x7ff7d0ad9700 (LWP 5028)):
#0  0x00007ff7ebbadbf9 in __GI___poll (fds=0x7ff7c4012a80, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007ff7e422c539 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff7e422c64c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff7ec4e804b in QEventDispatcherGlib::processEvents (this=0x7ff7c4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff7ec48c30a in QEventLoop::exec (this=this@entry=0x7ff7d0ad8cb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#5  0x00007ff7ec2b7bba in QThread::exec (this=<optimized out>) at thread/qthread.cpp:525
#6  0x00007ff7eab3de45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007ff7ec2c2adb in QThreadPrivate::start (arg=0x7ff7eadb5d60) at thread/qthread_unix.cpp:367
#8  0x00007ff7e5d316db in start_thread (arg=0x7ff7d0ad9700) at pthread_create.c:463
#9  0x00007ff7ebbba88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7ff7d40e2700 (LWP 5027)):
#0  0x00007ff7ebbadbf9 in __GI___poll (fds=0x7ff7d40e1be8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007ff7e3fc3747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007ff7e3fc536a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007ff7d6e70ed9 in QXcbEventReader::run (this=0x556672502810) at qxcbconnection.cpp:1391
#4  0x00007ff7ec2c2adb in QThreadPrivate::start (arg=0x556672502810) at thread/qthread_unix.cpp:367
#5  0x00007ff7e5d316db in start_thread (arg=0x7ff7d40e2700) at pthread_create.c:463
#6  0x00007ff7ebbba88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7ff7f0cbc8c0 (LWP 5026)):
[KCrash Handler]
#6  0x00007ff7ea2920ad in Exiv2::ExifData::findKey(Exiv2::ExifKey const&) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#7  0x00007ff7ea2d6496 in Exiv2::Internal::PentaxMakerNote::printShutterCount(std::ostream&, Exiv2::Value const&, Exiv2::ExifData const*) () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#8  0x00007ff7ea290957 in Exiv2::Exifdatum::write(std::ostream&, Exiv2::ExifData const*) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#9  0x00007ff7f0365baf in Exiv2::operator<< (md=..., os=...) at /usr/include/exiv2/metadatum.hpp:305
#10 Gwenview::ImageMetaInfoModelPrivate::fillExivGroup<Exiv2::ExifData, std::_List_const_iterator<Exiv2::Exifdatum> > (this=0x5566728786b0, parent=..., group=group@entry=0x556672c7d6f0, container=...) at ./lib/imagemetainfomodel.cpp:284
#11 0x00007ff7f0361571 in Gwenview::ImageMetaInfoModel::setExiv2Image (this=<optimized out>, image=0x7ff7bc00dfc0) at ./lib/imagemetainfomodel.cpp:444
#12 0x00007ff7f03142c7 in Gwenview::Document::setExiv2Image (this=0x556672c382d0, image=...) at ./lib/document/document.cpp:394
#13 0x00007ff7f03132e1 in Gwenview::AbstractDocumentImpl::setDocumentExiv2Image (this=this@entry=0x5566738458a0, image=...) at ./lib/document/abstractdocumentimpl.cpp:82
#14 0x00007ff7f03233d1 in Gwenview::LoadingDocumentImpl::slotMetaInfoLoaded (this=0x5566738458a0) at ./lib/document/loadingdocumentimpl.cpp:489
#15 0x00007ff7ec4bd075 in QMetaObject::activate (sender=0x556672a3e5d8, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3771
#16 0x00007ff7ec2c0223 in QFutureWatcherBase::event (this=<optimized out>, event=0x7ff7bc026510) at thread/qfuturewatcher.cpp:332
#17 0x00007ff7edc05e1c in QApplicationPrivate::notify_helper (this=this@entry=0x5566724f0180, receiver=receiver@entry=0x556672a3e5d8, e=e@entry=0x7ff7bc026510) at kernel/qapplication.cpp:3727
#18 0x00007ff7edc0d3ef in QApplication::notify (this=0x7ffe1b1567b0, receiver=0x556672a3e5d8, e=0x7ff7bc026510) at kernel/qapplication.cpp:3486
#19 0x00007ff7ec48dfe8 in QCoreApplication::notifyInternal2 (receiver=0x556672a3e5d8, event=event@entry=0x7ff7bc026510) at kernel/qcoreapplication.cpp:1048
#20 0x00007ff7ec490b2d in QCoreApplication::sendEvent (event=0x7ff7bc026510, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x5566724e5c50) at kernel/qcoreapplication.cpp:1745
#22 0x00007ff7ec4910e8 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1599
#23 0x00007ff7ec4e89f3 in postEventSourceDispatch (s=0x55667253a2c0) at kernel/qeventdispatcher_glib.cpp:276
#24 0x00007ff7e422c387 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007ff7e422c5c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007ff7e422c64c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007ff7ec4e802f in QEventDispatcherGlib::processEvents (this=0x556672538620, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#28 0x00007ff7d6efc761 in QPAEventDispatcherGlib::processEvents (this=0x556672538620, flags=...) at qeventdispatcher_glib.cpp:69
#29 0x00007ff7ec48c30a in QEventLoop::exec (this=this@entry=0x7ffe1b1566b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#30 0x00007ff7ec4954d0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1336
#31 0x000055667201f6a1 in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:163

Possible duplicates by query: bug 400952.

Reported using DrKonqi
Comment 1 Nate Graham 2019-02-06 04:03:15 UTC

*** This bug has been marked as a duplicate of bug 395198 ***