Bug 400952 - gwenview crashes when trying to open desktop picture
Summary: gwenview crashes when trying to open desktop picture
Status: RESOLVED DUPLICATE of bug 395198
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 18.08.3
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2018-11-12 07:20 UTC by hj
Modified: 2018-11-14 07:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hj 2018-11-12 07:20:12 UTC
Application: gwenview (18.08.3)

Qt Version: 5.11.2
Frameworks Version: 5.51.0
Operating System: Linux 4.15.0-38-generic x86_64
Distribution: KDE neon User Edition 5.14

-- Information about the crash:
When left clicking for opening desktop picture in Desktop, gwenview unexpextedly stops.

- It looks like gwenview is going to open, then it just stops.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4059d938c0 (LWP 1571))]

Thread 5 (Thread 0x7f401bfff700 (LWP 1583)):
#0  0x00007f404ee2e9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x557aaf9af738) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x557aaf9af6e8, cond=0x557aaf9af710) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x557aaf9af710, mutex=0x557aaf9af6e8) at pthread_cond_wait.c:655
#3  0x00007f4029d1a46b in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#4  0x00007f4029d1a197 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#5  0x00007f404ee286db in start_thread (arg=0x7f401bfff700) at pthread_create.c:463
#6  0x00007f4054cae88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f4028b31700 (LWP 1582)):
#0  0x00007f404ee2e9f3 in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x557aafb1d4d0) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  __pthread_cond_wait_common (abstime=0x0, mutex=0x557aafb1d480, cond=0x557aafb1d4a8) at pthread_cond_wait.c:502
#2  __pthread_cond_wait (cond=0x557aafb1d4a8, mutex=0x557aafb1d480) at pthread_cond_wait.c:655
#3  0x00007f4029d1a46b in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#4  0x00007f4029d1a197 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#5  0x00007f404ee286db in start_thread (arg=0x7f4028b31700) at pthread_create.c:463
#6  0x00007f4054cae88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f4035c9e700 (LWP 1573)):
#0  0x00007f4054c9d0b4 in __GI___libc_read (fd=7, buf=0x7f4035c9daa0, nbytes=16) at ../sysdeps/unix/sysv/linux/read.c:27
#1  0x00007f404d368a00 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f404d323f27 in g_main_context_check () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f404d3243e0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f404d32454c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f40555dc04b in QEventDispatcherGlib::processEvents (this=0x7f4030000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f405558030a in QEventLoop::exec (this=this@entry=0x7f4035c9dcb0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#7  0x00007f40553abbba in QThread::exec (this=<optimized out>) at thread/qthread.cpp:525
#8  0x00007f4054913e45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#9  0x00007f40553b6adb in QThreadPrivate::start (arg=0x7f4054b8bd60) at thread/qthread_unix.cpp:367
#10 0x00007f404ee286db in start_thread (arg=0x7f4035c9e700) at pthread_create.c:463
#11 0x00007f4054cae88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f403d309700 (LWP 1572)):
#0  0x00007f4054ca1bf9 in __GI___poll (fds=0x7f403d308be8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f404ce6e747 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f404ce7036a in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f4040097ed9 in QXcbEventReader::run (this=0x557aaf66eec0) at qxcbconnection.cpp:1391
#4  0x00007f40553b6adb in QThreadPrivate::start (arg=0x557aaf66eec0) at thread/qthread_unix.cpp:367
#5  0x00007f404ee286db in start_thread (arg=0x7f403d309700) at pthread_create.c:463
#6  0x00007f4054cae88f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f4059d938c0 (LWP 1571)):
[KCrash Handler]
#6  0x00007f40533860ad in Exiv2::ExifData::findKey(Exiv2::ExifKey const&) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#7  0x00007f40533ca496 in Exiv2::Internal::PentaxMakerNote::printShutterCount(std::ostream&, Exiv2::Value const&, Exiv2::ExifData const*) () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#8  0x00007f4053384957 in Exiv2::Exifdatum::write(std::ostream&, Exiv2::ExifData const*) const () from /usr/lib/x86_64-linux-gnu/libexiv2.so.26
#9  0x00007f40591fd9df in Exiv2::operator<< (md=..., os=...) at /usr/include/exiv2/metadatum.hpp:305
#10 Gwenview::ImageMetaInfoModelPrivate::fillExivGroup<Exiv2::ExifData, std::_List_const_iterator<Exiv2::Exifdatum> > (this=0x557aafc47cd0, parent=..., group=group@entry=0x557aafc0a710, container=...) at ./lib/imagemetainfomodel.cpp:284
#11 0x00007f40591f80a9 in Gwenview::ImageMetaInfoModel::setExiv2Image (this=<optimized out>, image=0x7f4024005bf0) at ./lib/imagemetainfomodel.cpp:444
#12 0x00007f40591abd47 in Gwenview::Document::setExiv2Image (this=0x557aafc79d80, image=...) at ./lib/document/document.cpp:394
#13 0x00007f40591aad61 in Gwenview::AbstractDocumentImpl::setDocumentExiv2Image (this=this@entry=0x557aafc7a7d0, image=...) at ./lib/document/abstractdocumentimpl.cpp:82
#14 0x00007f40591bae11 in Gwenview::LoadingDocumentImpl::slotMetaInfoLoaded (this=0x557aafc7a7d0) at ./lib/document/loadingdocumentimpl.cpp:491
#15 0x00007f40555b1075 in QMetaObject::activate (sender=0x557aafc0ef88, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3771
#16 0x00007f40553b4223 in QFutureWatcherBase::event (this=<optimized out>, event=0x7f4024016050) at thread/qfuturewatcher.cpp:332
#17 0x00007f4056cf1e1c in QApplicationPrivate::notify_helper (this=this@entry=0x557aaf65b1d0, receiver=receiver@entry=0x557aafc0ef88, e=e@entry=0x7f4024016050) at kernel/qapplication.cpp:3727
#18 0x00007f4056cf93ef in QApplication::notify (this=0x7ffc5051d6c0, receiver=0x557aafc0ef88, e=0x7f4024016050) at kernel/qapplication.cpp:3486
#19 0x00007f4055581fe8 in QCoreApplication::notifyInternal2 (receiver=0x557aafc0ef88, event=event@entry=0x7f4024016050) at kernel/qcoreapplication.cpp:1048
#20 0x00007f4055584b2d in QCoreApplication::sendEvent (event=0x7f4024016050, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x557aaf650ca0) at kernel/qcoreapplication.cpp:1745
#22 0x00007f40555850e8 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1599
#23 0x00007f40555dc9f3 in postEventSourceDispatch (s=0x557aaf6b1650) at kernel/qeventdispatcher_glib.cpp:276
#24 0x00007f404d324287 in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f404d3244c0 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f404d32454c in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f40555dc02f in QEventDispatcherGlib::processEvents (this=0x557aaf6c2c70, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#28 0x00007f4040123761 in QPAEventDispatcherGlib::processEvents (this=0x557aaf6c2c70, flags=...) at qeventdispatcher_glib.cpp:69
#29 0x00007f405558030a in QEventLoop::exec (this=this@entry=0x7ffc5051d5c0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:214
#30 0x00007f40555894d0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1336
#31 0x0000557aad4fd5a1 in main (argc=<optimized out>, argv=<optimized out>) at ./app/main.cpp:167

Reported using DrKonqi
Comment 1 Nate Graham 2018-11-13 15:24:54 UTC
> When left clicking for opening desktop picture in Desktop

I'm not sure what this means exactly. Can you rephrase it in term of Steps To Reproduce? See https://community.kde.org/Get_Involved/Bug_Reporting#Steps_to_Reproduce
Comment 2 hj 2018-11-13 16:23:52 UTC
When I try to open/view a picture from my NAS drive gwenview closes unexpected.
As in:
1. open Dolphin and browse to a directory.
2. Right click to open file with gwenview
3. Gwenview crashes / closes unexpectedly and error message appears.
Comment 3 Christoph Feck 2018-11-13 18:09:49 UTC

*** This bug has been marked as a duplicate of bug 382842 ***
Comment 4 Christoph Feck 2018-11-13 18:14:37 UTC

*** This bug has been marked as a duplicate of bug 395198 ***
Comment 5 hj 2018-11-14 07:47:14 UTC
Looks like bug is resolved with latest updates!