Bug 403159 - Blank page on print and print preview
Summary: Blank page on print and print preview
Status: RESOLVED UPSTREAM
Alias: None
Product: kmail2
Classification: Applications
Component: message list (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 407366 412180 412504 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-12 23:24 UTC by Sergey Okhapkin
Modified: 2019-11-04 10:25 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Okhapkin 2019-01-12 23:24:25 UTC
SUMMARY


STEPS TO REPRODUCE
1. Select any email message
2. File/Print Preview.


OBSERVED RESULT
Preview window is blank.

EXPECTED RESULT
email message text

SOFTWARE/OS VERSIONS
Windows: 
MacOS: 
Linux/KDE Plasma: Gentoo
(available in About System)
KDE Plasma Version: 5.14.3
KDE Frameworks Version: 5.52.0
Qt Version: 5.11.3

ADDITIONAL INFORMATION
Comment 1 MAG4 2019-01-16 14:53:31 UTC
We also confirm it for Kmail 5.9.1 (Plasma 5.14.3, Frameworks 5.51.0, Qt 5.11.3) in Debian Testing ...
Comment 2 Laurent Montel 2019-01-16 15:57:26 UTC
I confirm it too with some html emails.
For plain text it's ok.
Comment 3 Sergey Okhapkin 2019-01-16 16:00:54 UTC
I'm getting blank preview on all messages, plain text and html.
Comment 4 MAG4 2019-01-17 08:24:12 UTC
We also on all messages, plain text and html ...
Comment 5 Garry Williams 2019-01-31 22:21:58 UTC
Same on Fedora and also crashed kmail without a usable dump each time doing File -> Print Preview:

Jan 31 15:26:55 ifr systemd[1]: Created slice system-systemd\x2dcoredump.slice.
Jan 31 15:26:55 ifr systemd[1]: Started Process Core Dump (PID 17269/UID 0).
Jan 31 15:26:56 ifr systemd-coredump[17270]: Core file was truncated to 2147483648 bytes.
Jan 31 15:26:57 ifr abrt-dump-journal-core[955]: Failed to obtain all required information from journald
Jan 31 15:26:57 ifr systemd-coredump[17270]: Process 16616 (kontact) of user 1000 dumped core.
                                             
                                             Stack trace of thread 16616:
                                             #0  0x00007ff59b54f53f n/a (n/a)
Jan 31 15:27:00 ifr abrt-server[17279]: Error: No segments found in coredump './coredump'
Jan 31 15:27:01 ifr abrt-server[17279]: Can't open file 'core_backtrace' for reading: No such file or directory
Jan 31 15:27:05 ifr abrt-notification[17320]: Process 16616 (kontact) crashed in ??()

garry@ifr$ rpm -q kmail plasma-desktop qt5-qtbase
kmail-18.08.3-1.fc29.x86_64
plasma-desktop-5.14.4-2.fc29.x86_64
qt5-qtbase-5.11.3-1.fc29.x86_64
Comment 6 Jeff Fitzmaurice 2019-02-05 00:10:21 UTC
I confirm this is happening in Fedora 29 64bit KDE using Kmail and Kontact.  Print Preview turns a blank page.  Also, attempting a physical printed copy turns a physical blank page.  I have all the latest updates.  Printing does not work from Kmail via Kontact.
Comment 7 Kevin Kofler 2019-02-05 00:44:57 UTC
I suspect that this is a bug in the QtWebEngine print method. I am seeing this with QtWebEngine 5.11.3. Falkon also spits out a blank page when I try to print directly to the printer. Printing to PDF works in Falkon (which uses the dedicated printToPdf method in that case, which is a good idea, by the way, because it will produce a normal PDF, whereas using the normal print method will render that PDF to a bitmap per page and then produce a PDF containing the bitmap(s)), but not in KMail (which, I guess, always uses the generic print method).

This probably needs to be reported to Qt upstream if it isn't yet.

It would also be important to know whether it works with QtWebEngine 5.12.x. I cannot easily test it at this time because we have no QtWebEngine 5.12.x builds in Fedora yet.
Comment 8 Kevin Kofler 2019-02-05 00:45:58 UTC
I'm updating the summary because, sadly, not only the preview is blank.
Comment 9 Kevin Funk 2019-03-14 11:22:46 UTC
Also now getting this on Kubuntu 19.04. Can confirm: "I'm getting blank preview on all messages, plain text and html."

Using KMail 5.8.3, KF5 5.56, Qt version 5.11.3.
Comment 10 Laurent Montel 2019-03-14 12:17:56 UTC
(In reply to Kevin Funk from comment #9)
> Also now getting this on Kubuntu 19.04. Can confirm: "I'm getting blank
> preview on all messages, plain text and html."
> 
> Using KMail 5.8.3, KF5 5.56, Qt version 5.11.3.

Did you try to compile in a file ?
I just tested here KMAil 5.10 Qt 5.13 and it's ok for me.
Comment 11 Kevin Kofler 2019-03-14 12:20:55 UTC
As I wrote, I think this is a bug in QtWebEngine 5.11. Looks like it's fixed in 5.13. Somebody needs to test 5.12.
Comment 12 Florian Evers 2019-03-19 15:10:18 UTC
I'm working with Gentoo Linux and today I updated to qt* 5.12 with qtwebengine-5.12.2. I confirm that both print preview and printing work again after updating to Qt version 5.12.

BTW:
- kde-apps 18.12.3
- kde-frameworks 5.56.0
- kde-plasma 5.15.3

Regards,
Florian
Comment 13 Allen Winter 2019-04-05 13:15:31 UTC
Got an update to qtwebengine Qt5.12.2 today on Fedora 29 and indeed printing from KMail works again!

this is not a kmail bug.
Comment 14 Jeff Fitzmaurice 2019-04-11 23:56:37 UTC
After I did my recent updates, Fedora 29 is now printing using kmail via Kontact.
Comment 15 Wolfgang Bauer 2019-05-10 08:16:33 UTC
*** Bug 407366 has been marked as a duplicate of this bug. ***
Comment 16 Wolfgang Bauer 2019-09-22 08:00:58 UTC
*** Bug 412180 has been marked as a duplicate of this bug. ***
Comment 17 Wolfgang Bauer 2019-10-01 12:53:54 UTC
*** Bug 412504 has been marked as a duplicate of this bug. ***