Bug 398440 - plasmashell crashes on wayland in DeclarativeMimeData::DeclarativeMimeData() when dragging a file from dolphin over a panel
Summary: plasmashell crashes on wayland in DeclarativeMimeData::DeclarativeMimeData() ...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: 5.18.4
Platform: Archlinux Linux
: NOR crash
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: wayland
: 396100 409493 420835 423559 425666 427823 430212 430772 431565 431786 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-09 20:17 UTC by Mayeul Cantan
Modified: 2021-04-19 16:22 UTC (History)
28 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.21.5


Attachments
Backtrace of the crash (5.08 KB, text/plain)
2018-09-10 13:36 UTC, Mayeul Cantan
Details
gdb backtrace with debug symbols (55.86 KB, text/plain)
2020-10-17 15:29 UTC, Alexander
Details
Recent backtrace from master. (9.16 KB, text/plain)
2020-11-12 04:29 UTC, Tony
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mayeul Cantan 2018-09-09 20:17:33 UTC
I do not seem to hit 390430, but when dragging a folder from Dolphin on the panel (not releasing the mouse), plasmashell crashes.

Steps to reproduce:

Open two maximized Dolphin windows
Try to drag a folder from one to another:
* Click and start dragging the folder from one Dolphin window,
* hover a panel (I'm using a standard task manager) to focus on the background Dolphin window
* Observe plasmashell crashing.
Comment 1 Alexander Mentyu 2018-09-10 09:23:14 UTC
Please attach a backtrack of the crash
Comment 2 Mayeul Cantan 2018-09-10 13:36:42 UTC
Created attachment 114882 [details]
Backtrace of the crash

Here is a backtrace obtained manually from gdb after recompiling with debug symbols.

Dr Konqui somehow was unable to generate the backtrace, and asked me about debug symbols for /usr/bin/plasmashell, although those weren't stripped.
Comment 3 Mayeul Cantan 2018-09-10 13:38:59 UTC
It looks like some symbols are missing, though. I'm unsure of the library. Would that be part of Qt or the frameworks? Would it be useful at all to produce another backtrace with those debug symbols?
Comment 4 Alexander Mentyu 2018-09-28 15:13:31 UTC
What is there right way to gdb of plasmashell?

I'm trying:
sudo gdb --pid $(pidof plasmashell)
thread apply all bt

but Plasma and panel hangs and i cannot drag files or do any actions in them
Comment 5 Patrick Silva 2018-09-29 12:28:21 UTC
probably duplicate of bug 377210
Comment 6 Mayeul Cantan 2018-10-02 09:29:10 UTC
(In reply to Alexander Mentyu from comment #4)
> What is there right way to gdb of plasmashell?
> 
> I'm trying:
> sudo gdb --pid $(pidof plasmashell)
> thread apply all bt
> 
> but Plasma and panel hangs and i cannot drag files or do any actions in them

I am not sure this is the right way, but I didn't bother with this, and just killed plasmashell and ran it within GDB. (gdb /path/to/plasmashell, and then > run)
Comment 7 Mayeul Cantan 2018-10-02 09:31:51 UTC
Also, bug 377210 is marked as a duplicate of bug 385605. This could be a duplicate, but I do not have the expertise to say so.
Comment 8 Patrick Silva 2019-04-29 12:49:36 UTC
Crash reproducible on both Arch Linux and Neon dev unstable.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.15.4
KDE Frameworks Version: 5.57.0
Qt Version: 5.12.3

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.15.80
KDE Frameworks Version: 5.58.0
Qt Version: 5.12.0
Comment 9 Patrick Silva 2019-05-17 16:12:26 UTC
Crash reproducible on Plasma 5.16 beta.

Operating System: Arch Linux 
KDE Plasma Version: 5.15.90
KDE Frameworks Version: 5.58.0
Qt Version: 5.13.0 beta3
Comment 10 Patrick Silva 2020-01-31 02:27:24 UTC
This crash is still reproducible on Arch Linux (Plasma 5.18 beta) and Neon unstable edition.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux 
KDE Plasma Version: 5.17.90
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.1


Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.18.80
KDE Frameworks Version: 5.67.0
Qt Version: 5.13.2
Comment 11 Rainer Finke 2020-04-21 18:12:02 UTC
Same issue here

Operating System: Arch Linux 
KDE Plasma Version: 5.18.4
KDE Frameworks Version: 5.69.0
Qt Version: 5.15.0
Kernel Version: 5.6.5-arch3-1
Comment 12 Patrick Silva 2020-05-14 21:28:40 UTC
On plasma 5.19 beta plasma and kwin_wayland crashed together when I tried to drag a text file from Dolphin to Kate hovering over Kate entry in task manager.

Operating System: Arch Linux 
KDE Plasma Version: 5.18.90
KDE Frameworks Version: 5.70.0
Qt Version: 5.15.0 rc2
Comment 13 Christoph Feck 2020-08-17 16:54:29 UTC
*** Bug 396100 has been marked as a duplicate of this bug. ***
Comment 14 Patrick Silva 2020-10-16 23:28:20 UTC
*** Bug 427823 has been marked as a duplicate of this bug. ***
Comment 15 Alexander 2020-10-17 15:29:49 UTC
Created attachment 132477 [details]
gdb backtrace with debug symbols

1. start dragging file from some window (dolphin)
2. hover over sys tray
3. crash

EXPECTED RESULT
open file in application below the mouse pointer

Operating System: openSUSE Tumbleweed 20201014
KDE Plasma Version: 5.20.0
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Kernel Version: 5.8.14-1-default
OS Type: 64-bit
Processors: 8 × AMD Ryzen 7 2700U with Radeon Vega Mobile Gfx
Memory: 15.3 GiB of RAM
Graphics Processor: AMD RAVEN
Comment 16 Tony 2020-11-12 04:27:10 UTC
*** Bug 425666 has been marked as a duplicate of this bug. ***
Comment 17 Tony 2020-11-12 04:29:20 UTC
Created attachment 133252 [details]
Recent backtrace from master.
Comment 18 Tony 2020-11-12 04:30:36 UTC
*** Bug 423559 has been marked as a duplicate of this bug. ***
Comment 19 Gerald Cox 2020-12-25 02:00:17 UTC
*** Bug 430772 has been marked as a duplicate of this bug. ***
Comment 20 Nate Graham 2021-01-19 16:27:05 UTC
*** Bug 409493 has been marked as a duplicate of this bug. ***
Comment 21 Nate Graham 2021-01-19 16:27:11 UTC
*** Bug 420835 has been marked as a duplicate of this bug. ***
Comment 22 Nate Graham 2021-01-19 16:27:18 UTC
*** Bug 430212 has been marked as a duplicate of this bug. ***
Comment 23 Nate Graham 2021-01-19 16:28:35 UTC
Pasting the backtrace here for searchability:


Thread 1 (Thread 0x7fbe2737d840 (LWP 13224)):
[KCrash Handler]
#4  DeclarativeMimeData::DeclarativeMimeData (this=<optimized out>, copy=<optimized out>, this=<optimized out>, copy=<optimized out>) at /usr/src/debug/kdeclarative-5.75.0git.20201107T113549~21e4085-ku.9.1.x86_64/src/qmlcontrols/draganddrop/DeclarativeMimeData.cpp:39
#5  0x00007fbe18162081 in DeclarativeDragDropEvent::mimeData (this=0x7ffe84fb51b0) at /usr/include/qt5/QtGui/qevent.h:667
#6  DeclarativeDragDropEvent::qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _c=<optimized out>, _o=0x7ffe84fb51b0) at /usr/src/debug/kdeclarative-5.75.0git.20201107T113549~21e4085-ku.9.1.x86_64/build/src/qmlcontrols/draganddrop/draganddropplugin_autogen/EWIEGA46WW/moc_DeclarativeDragDropEvent.cpp:121
#7  DeclarativeDragDropEvent::qt_static_metacall (_o=0x7ffe84fb51b0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdeclarative-5.75.0git.20201107T113549~21e4085-ku.9.1.x86_64/build/src/qmlcontrols/draganddrop/draganddropplugin_autogen/EWIEGA46WW/moc_DeclarativeDragDropEvent.cpp:93
#8  0x00007fbe270b4221 in QQmlPropertyData::readPropertyWithArgs (args=0x7ffe84fb3340, target=0x7ffe84fb51b0, this=0x55eb62159f08) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/include/QtQml/5.15.1/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:363
#9  QQmlPropertyData::readProperty (property=0x7ffe84fb3320, target=0x7ffe84fb51b0, this=0x55eb62159f08) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/include/QtQml/5.15.1/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#10 loadProperty (v4=0x55eb5e7bef00, object=0x7ffe84fb51b0, property=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:138
#11 0x00007fbe270d2c29 in QV4::Moth::VME::interpret (frame=0x7ffe84fb3540, engine=0x55eb5e7bef00, code=0x7fbe049484a2 ":\004:\005\030\b\022<\030\v\246\006\b\001\v\030\b\006b\bL\005\246\a\006") at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:638
#12 0x00007fbe270d7087 in QV4::Moth::VME::exec (frame=frame@entry=0x7ffe84fb3540, engine=engine@entry=0x55eb5e7bef00) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/qml/jsruntime/qv4vme_moth.cpp:463
#13 0x00007fbe270728dd in QV4::Function::call (this=this@entry=0x55eb5f70b670, thisObject=<optimized out>, argv=argv@entry=0x7fbe20229508, argc=<optimized out>, context=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/qml/jsruntime/qv4function.cpp:69
#14 0x00007fbe271ea795 in QQmlJavaScriptExpression::evaluate (this=this@entry=0x55eb5f702110, callData=callData@entry=0x7fbe202294d8, isUndefined=isUndefined@entry=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/include/QtQml/5.15.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:343
#15 0x00007fbe2719d99b in QQmlBoundSignalExpression::evaluate (this=<optimized out>, a=<optimized out>) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/include/QtQml/5.15.1/QtQml/private/../../../../../src/qml/jsruntime/qv4jscall_p.h:95
#16 0x00007fbe2719de80 in QQmlBoundSignal_callback (e=0x55eb5f6bc970, a=0x7ffe84fb51e0) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/include/QtQml/5.15.1/QtQml/private/../../../../../src/qml/qml/qqmlboundsignalexpressionpointer_p.h:69
#17 0x00007fbe271cd5bd in QQmlNotifier::emitNotify (endpoint=<optimized out>, a=0x7ffe84fb51e0) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/qml/qml/qqmlnotifier.cpp:104
#18 0x00007fbe25b6b695 in doActivate<false> (sender=0x55eb5f7024a0, signal_index=30, argv=argv@entry=0x7ffe84fb51e0) at kernel/qobject_p.h:110
#19 0x00007fbe25b64e60 in QMetaObject::activate (sender=sender@entry=0x55eb5f7024a0, m=m@entry=0x7fbe1816ccc0 <DeclarativeDropArea::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe84fb51e0) at kernel/qobject.cpp:3946
#20 0x00007fbe181619fb in DeclarativeDropArea::dragEnter (_t1=0x7ffe84fb51b0, this=0x55eb5f7024a0) at /usr/src/debug/kdeclarative-5.75.0git.20201107T113549~21e4085-ku.9.1.x86_64/build/src/qmlcontrols/draganddrop/draganddropplugin_autogen/EWIEGA46WW/moc_DeclarativeDropArea.cpp:265
#21 DeclarativeDropArea::dragEnterEvent (this=0x55eb5f7024a0, event=0x7ffe84fb5420) at /usr/src/debug/kdeclarative-5.75.0git.20201107T113549~21e4085-ku.9.1.x86_64/src/qmlcontrols/draganddrop/DeclarativeDropArea.cpp:46
#22 0x00007fbe276e8328 in QQuickItem::event (this=0x55eb5f7024a0, ev=0x7ffe84fb5420) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/quick/items/qquickitem.cpp:8128
#23 0x00007fbe268c44ff in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55eb5f7024a0, e=0x7ffe84fb5420) at kernel/qapplication.cpp:3630
#24 0x00007fbe25b3551a in QCoreApplication::notifyInternal2 (receiver=0x55eb5f7024a0, event=0x7ffe84fb5420) at ../../include/QtCore/5.15.1/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#25 0x00007fbe277072e1 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=<optimized out>, event=<optimized out>, currentGrabItems=0x0) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/quick/items/qquickwindow.cpp:3076
#26 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5f70a890, event=0x7ffe84fb56a0, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#27 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5f6a8e10, event=0x7ffe84fb5810, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#28 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5ea56230, event=0x7ffe84fb5980, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#29 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5f8752d0, event=0x7ffe84fb5af0, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#30 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5f869120, event=0x7ffe84fb5c60, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#31 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5f6776d0, event=0x7ffe84fb5dd0, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#32 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5e9f5f70, event=0x7ffe84fb5f40, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#33 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5f42cc00, event=0x7ffe84fb60b0, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#34 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5f42a7b0, event=0x7ffe84fb6220, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#35 0x00007fbe27707092 in QQuickWindowPrivate::deliverDragEvent (this=0x55eb5f1189e0, grabber=0x55eb5f41cb70, item=0x55eb5f431710, event=0x7ffe84fb63f0, currentGrabItems=0x0) at /usr/include/qt5/QtCore/qlist.h:570
#36 0x00007fbe27707992 in QQuickWindowPrivate::deliverDragEvent (this=this@entry=0x55eb5f1189e0, grabber=0x55eb5f41cb70, event=event@entry=0x55eb606909f0) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/quick/items/qquickwindow.cpp:3024
#37 0x00007fbe27708342 in QQuickWindow::event (this=0x55eb5eb75b10, e=0x55eb606909f0) at /usr/src/debug/libqt5-qtdeclarative-5.15.1-ku.2.1.x86_64/src/quick/items/qquickwindow.cpp:1801
#38 0x00007fbe268c44ff in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x55eb5eb75b10, e=0x55eb606909f0) at kernel/qapplication.cpp:3630
#39 0x00007fbe25b3551a in QCoreApplication::notifyInternal2 (receiver=0x55eb5eb75b10, event=0x55eb606909f0) at ../../include/QtCore/5.15.1/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#40 0x00007fbe25b37f51 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x55eb5e6bc650) at kernel/qcoreapplication.cpp:1817
#41 0x00007fbe25b8d3e3 in postEventSourceDispatch (s=0x55eb5e73fa50) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007fbe23edcca7 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#43 0x00007fbe23edd028 in ?? () from /usr/lib64/libglib-2.0.so.0
#44 0x00007fbe23edd0df in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#45 0x00007fbe25b8ca6f in QEventDispatcherGlib::processEvents (this=0x55eb5e73f920, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#46 0x00007fbe25b33edb in QEventLoop::exec (this=this@entry=0x7ffe84fb6a30, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#47 0x00007fbe25b3c150 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#48 0x000055eb5d9cf127 in main (argc=<optimized out>, argv=0x7ffe84fb6c30) at /usr/src/debug/plasma5-workspace-5.20.80git.20201110T140138~1cda2516f-ku.35.1.x86_64/shell/main.cpp:244
[Inferior 1 (process 13224) detached]
Comment 24 Nate Graham 2021-01-19 17:40:07 UTC
*** Bug 431565 has been marked as a duplicate of this bug. ***
Comment 25 Nate Graham 2021-01-26 19:19:23 UTC
*** Bug 431786 has been marked as a duplicate of this bug. ***
Comment 26 David Edmundson 2021-02-09 17:57:56 UTC
Drag and drop had multiple fixed made today. The trace of things I fixed doesn't quite match up here, but it's in the same area and I fixed some hypothetical issues which would cause undefined behaviour.

If we have no dupes after 5.21.0 we can close this.
Comment 27 Claudius Ellsel 2021-02-09 18:16:48 UTC
Sounds promising :)
Comment 28 Nate Graham 2021-02-09 19:20:59 UTC
Awesome. Let's close and re-open if anyone can still experience it. :)
Comment 29 Patrick Silva 2021-02-13 10:47:59 UTC
Bug persists on neon unstable.

1. open Kate and minimize its window
2. open Dolphin
3. drag a text file from Dolphin and drop it on Kate

Plasma crashes.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.21.80
KDE Frameworks Version: 5.79.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 30 Alex 2021-02-19 05:18:31 UTC
(In reply to Patrick Silva from comment #29)
> Bug persists on neon unstable.
> 
> 1. open Kate and minimize its window
> 2. open Dolphin
> 3. drag a text file from Dolphin and drop it on Kate
> 
> Plasma crashes.
> 
> Operating System: KDE neon Unstable Edition
> KDE Plasma Version: 5.21.80
> KDE Frameworks Version: 5.79.0
> Qt Version: 5.15.2
> Graphics Platform: Wayland

I was unable to reproduce this on Plasma 5.21. I might set up a Neon VM and try to reproduce it there later
Comment 31 remcoluit 2021-02-19 05:44:40 UTC
(In reply to Alex from comment #30)
> (In reply to Patrick Silva from comment #29)
> > Bug persists on neon unstable.
> > 
> > 1. open Kate and minimize its window
> > 2. open Dolphin
> > 3. drag a text file from Dolphin and drop it on Kate
> > 
> > Plasma crashes.
> > 
> > Operating System: KDE neon Unstable Edition
> > KDE Plasma Version: 5.21.80
> > KDE Frameworks Version: 5.79.0
> > Qt Version: 5.15.2
> > Graphics Platform: Wayland
> 
> I was unable to reproduce this on Plasma 5.21. I might set up a Neon VM and
> try to reproduce it there later

Or Slackware-current where the KDE Plasma, Frameworks and Qt are currently on the same version as mentioned above and KDE still crashes when dragging to a window in the task manager.
Comment 32 Alex 2021-02-19 10:33:01 UTC
After doing some more testing, I still cannot reproduce this on Plasma 5.21, but in my Neon Unstable VM with Plasma 5.21.80, I could reproduce the issue...
Comment 33 Alex 2021-02-26 07:36:12 UTC
Still occurs in 5.21.1. :/
Comment 34 Nate Graham 2021-03-04 20:57:06 UTC
Cannot reproduce on current git master.
Comment 35 remcoluit 2021-03-04 21:29:50 UTC
Dragging a text file from Dolphin to a minimized Kate shows a red icon (red round with a diagonal line) that it is not possible, but it is no longer crashing and opens the file in Kate.

The issue as described in https://bugs.kde.org/show_bug.cgi?id=431565 is still reproducible in Slackware-current on Wayland. Open Thunderbird, open new message (2 windows), open Dolphin and drag a file to new message window in the task panel, KDE crashes.
Comment 36 Patrick Silva 2021-03-04 21:37:27 UTC
Humm, the crash is still reproducible on my neon unstable.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.21.80
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 37 remcoluit 2021-03-04 21:41:46 UTC
Forgot to mention (In reply to rl@rlit.nl from comment #35)
> Dragging a text file from Dolphin to a minimized Kate shows a red icon (red
> round with a diagonal line) that it is not possible, but it is no longer
> crashing and opens the file in Kate.
> 
> The issue as described in https://bugs.kde.org/show_bug.cgi?id=431565 is
> still reproducible in Slackware-current on Wayland. Open Thunderbird, open
> new message (2 windows), open Dolphin and drag a file to new message window
> in the task panel, KDE crashes.

Forgot to mention i was using 5.21.2, before 5.21.1 where it was reproducible.
Comment 38 Marco Martin 2021-03-05 13:46:57 UTC
(In reply to Patrick Silva from comment #29)
> Bug persists on neon unstable.
> 
> 1. open Kate and minimize its window
> 2. open Dolphin
> 3. drag a text file from Dolphin and drop it on Kate

still same backtrace?
Comment 39 Patrick Silva 2021-03-05 14:48:19 UTC
Here is a new backtrace generated on neon unstable right now.

Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: [Current thread is 1 (Thread 0x7fea41ac42c0 (LWP 19837))]
[New LWP 19882]
[New LWP 19929]
[New LWP 19930]
[New LWP 19931]
[New LWP 19932]
[New LWP 19975]
[New LWP 19991]
[New LWP 19994]
[New LWP 19996]
[New LWP 19997]
[New LWP 20004]
[New LWP 20011]
[New LWP 20057]
[New LWP 20060]
[New LWP 20069]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007fea45878aff in __GI___poll (fds=fds@entry=0x7ffe752ce428, nfds=nfds@entry=1, timeout=timeout@entry=1000) at ../sysdeps/unix/sysv/linux/poll.c:29

Thread 16 (Thread 0x7fe9d7ca9700 (LWP 20069)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597bd256400) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597bd2563b0, cond=0x5597bd2563d8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597bd2563d8, mutex=0x5597bd2563b0) at pthread_cond_wait.c:638
#3  0x00007fea45c0bd1b in QWaitConditionPrivate::wait(QDeadlineTimer) (deadline=..., this=0x5597bd2563b0) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait(QMutex*, QDeadlineTimer) (this=this@entry=0x5597b5273888, mutex=mutex@entry=0x5597b5273880, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007fea47858814 in QSGRenderThreadEventQueue::takeEvent(bool) (wait=true, this=0x5597b5273878) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  QSGRenderThread::processEventsAndWaitForMore() (this=this@entry=0x5597b52737e0) at scenegraph/qsgthreadedrenderloop.cpp:936
#7  0x00007fea47858c89 in QSGRenderThread::run() (this=0x5597b52737e0) at scenegraph/qsgthreadedrenderloop.cpp:1053
#8  0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597b52737e0) at thread/qthread_unix.cpp:329
#9  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 15 (Thread 0x7fea0483e700 (LWP 20060)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597ba0f7674) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597ba0f7620, cond=0x5597ba0f7648) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597ba0f7648, mutex=0x5597ba0f7620) at pthread_cond_wait.c:638
#3  0x00007fea45c0bd1b in QWaitConditionPrivate::wait(QDeadlineTimer) (deadline=..., this=0x5597ba0f7620) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait(QMutex*, QDeadlineTimer) (this=this@entry=0x5597bd514008, mutex=mutex@entry=0x5597bd514000, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007fea47858814 in QSGRenderThreadEventQueue::takeEvent(bool) (wait=true, this=0x5597bd513ff8) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  QSGRenderThread::processEventsAndWaitForMore() (this=this@entry=0x5597bd513f60) at scenegraph/qsgthreadedrenderloop.cpp:936
#7  0x00007fea47858c89 in QSGRenderThread::run() (this=0x5597bd513f60) at scenegraph/qsgthreadedrenderloop.cpp:1053
#8  0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597bd513f60) at thread/qthread_unix.cpp:329
#9  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 14 (Thread 0x7fea05483700 (LWP 20057)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597b524d640) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597b524d5f0, cond=0x5597b524d618) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597b524d618, mutex=0x5597b524d5f0) at pthread_cond_wait.c:638
#3  0x00007fea45c0bd1b in QWaitConditionPrivate::wait(QDeadlineTimer) (deadline=..., this=0x5597b524d5f0) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait(QMutex*, QDeadlineTimer) (this=this@entry=0x5597b9eec448, mutex=mutex@entry=0x5597b9eec440, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007fea47858814 in QSGRenderThreadEventQueue::takeEvent(bool) (wait=true, this=0x5597b9eec438) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  QSGRenderThread::processEventsAndWaitForMore() (this=this@entry=0x5597b9eec3a0) at scenegraph/qsgthreadedrenderloop.cpp:936
#7  0x00007fea47858c89 in QSGRenderThread::run() (this=0x5597b9eec3a0) at scenegraph/qsgthreadedrenderloop.cpp:1053
#8  0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597b9eec3a0) at thread/qthread_unix.cpp:329
#9  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 13 (Thread 0x7fea077c4700 (LWP 20011)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597ba65bdd4) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597ba65bd80, cond=0x5597ba65bda8) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597ba65bda8, mutex=0x5597ba65bd80) at pthread_cond_wait.c:638
#3  0x00007fea45c0bd1b in QWaitConditionPrivate::wait(QDeadlineTimer) (deadline=..., this=0x5597ba65bd80) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait(QMutex*, QDeadlineTimer) (this=this@entry=0x5597ba65bc88, mutex=mutex@entry=0x5597ba65bc80, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007fea47858814 in QSGRenderThreadEventQueue::takeEvent(bool) (wait=true, this=0x5597ba65bc78) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  QSGRenderThread::processEventsAndWaitForMore() (this=this@entry=0x5597ba65bbe0) at scenegraph/qsgthreadedrenderloop.cpp:936
#7  0x00007fea47858c89 in QSGRenderThread::run() (this=0x5597ba65bbe0) at scenegraph/qsgthreadedrenderloop.cpp:1053
#8  0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597ba65bbe0) at thread/qthread_unix.cpp:329
#9  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 12 (Thread 0x7fea0db38700 (LWP 20004)):
#0  __GI___libc_read (nbytes=16, buf=0x7fea0db37ad0, fd=33) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=33, buf=buf@entry=0x7fea0db37ad0, nbytes=nbytes@entry=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007fea441e589f in read (__nbytes=16, __buf=0x7fea0db37ad0, __fd=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/unistd.h:44
#3  g_wakeup_acknowledge (wakeup=0x7fea00003540) at ../../../glib/gwakeup.c:210
#4  0x00007fea4419ccde in g_main_context_check (context=context@entry=0x7fe9f8000c20, max_priority=2147483647, fds=fds@entry=0x7fe9f8005240, n_fds=n_fds@entry=1) at ../../../glib/gmain.c:3825
#5  0x00007fea4419d132 in g_main_context_iterate (context=context@entry=0x7fe9f8000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4044
#6  0x00007fea4419d2c3 in g_main_context_iteration (context=0x7fe9f8000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#7  0x00007fea45e45fbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fe9f8000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#8  0x00007fea45dea1ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fea0db37ce0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#9  0x00007fea45c04a12 in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#10 0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597b960f1a0) at thread/qthread_unix.cpp:329
#11 0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#12 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 11 (Thread 0x7fea0f14b700 (LWP 19997)):
#0  __GI___libc_read (nbytes=16, buf=0x7fea0f14aa90, fd=27) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=27, buf=buf@entry=0x7fea0f14aa90, nbytes=nbytes@entry=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007fea441e589f in read (__nbytes=16, __buf=0x7fea0f14aa90, __fd=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/unistd.h:44
#3  g_wakeup_acknowledge (wakeup=0x7fea08003950) at ../../../glib/gwakeup.c:210
#4  0x00007fea4419ccde in g_main_context_check (context=context@entry=0x7fea00000c20, max_priority=2147483647, fds=fds@entry=0x7fea00006150, n_fds=n_fds@entry=1) at ../../../glib/gmain.c:3825
#5  0x00007fea4419d132 in g_main_context_iterate (context=context@entry=0x7fea00000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4044
#6  0x00007fea4419d2c3 in g_main_context_iteration (context=0x7fea00000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#7  0x00007fea45e45fbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fea00000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#8  0x00007fea45dea1ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fea0f14aca0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#9  0x00007fea45c04a12 in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#10 0x00007fea0f64307c in KCupsConnection::run() () at /lib/x86_64-linux-gnu/libkcupslib.so
#11 0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597b96bde90) at thread/qthread_unix.cpp:329
#12 0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#13 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 10 (Thread 0x7fea0ff23700 (LWP 19996)):
#0  g_main_context_prepare (context=context@entry=0x7fea08000c20, priority=priority@entry=0x7fea0ff22ba0) at ../../../glib/gmain.c:3683
#1  0x00007fea4419d0bb in g_main_context_iterate (context=context@entry=0x7fea08000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4027
#2  0x00007fea4419d2c3 in g_main_context_iteration (context=0x7fea08000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#3  0x00007fea45e45fbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fea08000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007fea45dea1ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fea0ff22ce0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007fea45c04a12 in QThread::exec() (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597b542f0f0) at thread/qthread_unix.cpp:329
#7  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 9 (Thread 0x7fea2ad05700 (LWP 19994)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597b4663e80) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597b4663e30, cond=0x5597b4663e58) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597b4663e58, mutex=0x5597b4663e30) at pthread_cond_wait.c:638
#3  0x00007fea45c0bd1b in QWaitConditionPrivate::wait(QDeadlineTimer) (deadline=..., this=0x5597b4663e30) at thread/qwaitcondition_unix.cpp:146
#4  QWaitCondition::wait(QMutex*, QDeadlineTimer) (this=this@entry=0x7fea3c012c58, mutex=mutex@entry=0x7fea3c012c50, deadline=...) at thread/qwaitcondition_unix.cpp:225
#5  0x00007fea47858814 in QSGRenderThreadEventQueue::takeEvent(bool) (wait=true, this=0x7fea3c012c48) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qdeadlinetimer.h:68
#6  QSGRenderThread::processEventsAndWaitForMore() (this=this@entry=0x7fea3c012bb0) at scenegraph/qsgthreadedrenderloop.cpp:936
#7  0x00007fea47858c89 in QSGRenderThread::run() (this=0x7fea3c012bb0) at scenegraph/qsgthreadedrenderloop.cpp:1053
#8  0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x7fea3c012bb0) at thread/qthread_unix.cpp:329
#9  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#10 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 8 (Thread 0x7fea309ce700 (LWP 19991)):
#0  __GI___libc_read (nbytes=16, buf=0x7fea309cda90, fd=18) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=18, buf=buf@entry=0x7fea309cda90, nbytes=nbytes@entry=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007fea441e589f in read (__nbytes=16, __buf=0x7fea309cda90, __fd=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/unistd.h:44
#3  g_wakeup_acknowledge (wakeup=0x7fea200039c0) at ../../../glib/gwakeup.c:210
#4  0x00007fea4419ccde in g_main_context_check (context=context@entry=0x7fea14035850, max_priority=2147483647, fds=fds@entry=0x7fea140395d0, n_fds=n_fds@entry=1) at ../../../glib/gmain.c:3825
#5  0x00007fea4419d132 in g_main_context_iterate (context=context@entry=0x7fea14035850, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4044
#6  0x00007fea4419d2c3 in g_main_context_iteration (context=0x7fea14035850, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#7  0x00007fea45e45fbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fea1400e060, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#8  0x00007fea45dea1ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fea309cdca0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#9  0x00007fea45c04a12 in QThread::exec() (this=this@entry=0x5597b5c06330) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#10 0x00007fea4779338a in QQuickPixmapReader::run() (this=0x5597b5c06330) at util/qquickpixmapcache.cpp:1024
#11 0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597b5c06330) at thread/qthread_unix.cpp:329
#12 0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#13 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7fea32c03700 (LWP 19975)):
#0  __GI___libc_read (nbytes=16, buf=0x7fea32c02ab0, fd=12) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=12, buf=buf@entry=0x7fea32c02ab0, nbytes=nbytes@entry=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007fea441e589f in read (__nbytes=16, __buf=0x7fea32c02ab0, __fd=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/unistd.h:44
#3  g_wakeup_acknowledge (wakeup=0x7fea3c003eb0) at ../../../glib/gwakeup.c:210
#4  0x00007fea4419ccde in g_main_context_check (context=context@entry=0x7fea20000c20, max_priority=2147483647, fds=fds@entry=0x7fea20004e60, n_fds=n_fds@entry=1) at ../../../glib/gmain.c:3825
#5  0x00007fea4419d132 in g_main_context_iterate (context=context@entry=0x7fea20000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4044
#6  0x00007fea4419d2c3 in g_main_context_iteration (context=0x7fea20000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#7  0x00007fea45e45fbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fea20000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#8  0x00007fea45dea1ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fea32c02cc0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#9  0x00007fea45c04a12 in QThread::exec() (this=this@entry=0x5597b3d64b40) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#10 0x00007fea474ddfa9 in QQmlThreadPrivate::run() (this=0x5597b3d64b40) at qml/ftw/qqmlthread.cpp:155
#11 0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x5597b3d64b40) at thread/qthread_unix.cpp:329
#12 0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#13 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7fea399b9700 (LWP 19932)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597b37f0718) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597b37f06c8, cond=0x5597b37f06f0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597b37f06f0, mutex=0x5597b37f06c8) at pthread_cond_wait.c:638
#3  0x00007fea3b717e6b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fea3b717a6b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fea3a1ba700 (LWP 19931)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597b37f071c) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597b37f06c8, cond=0x5597b37f06f0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597b37f06f0, mutex=0x5597b37f06c8) at pthread_cond_wait.c:638
#3  0x00007fea3b717e6b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fea3b717a6b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fea3a9bb700 (LWP 19930)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597b37f071c) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597b37f06c8, cond=0x5597b37f06f0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597b37f06f0, mutex=0x5597b37f06c8) at pthread_cond_wait.c:638
#3  0x00007fea3b717e6b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fea3b717a6b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fea3b1bc700 (LWP 19929)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5597b37f0718) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5597b37f06c8, cond=0x5597b37f06f0) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5597b37f06f0, mutex=0x5597b37f06c8) at pthread_cond_wait.c:638
#3  0x00007fea3b717e6b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fea3b717a6b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fea4116f700 (LWP 19882)):
#0  0x00007fea45c06143 in QMutex::unlock() (this=this@entry=0x5597b37b9a70) at /usr/include/c++/9/bits/atomic_base.h:769
#1  0x00007fea45e45ec2 in QMutexLocker::unlock() (this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:270
#2  QMutexLocker::~QMutexLocker() (this=<synthetic pointer>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:243
#3  QThreadData::canWaitLocked() (this=0x5597b37b9a40) at ../../include/QtCore/5.15.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:272
#4  postEventSourcePrepare(GSource*, gint*) (s=0x7fea3c004fe0, timeout=timeout@entry=0x7fea4116eae4) at kernel/qeventdispatcher_glib.cpp:260
#5  0x00007fea4419c70f in g_main_context_prepare (context=context@entry=0x7fea3c000c20, priority=priority@entry=0x7fea4116eb70) at ../../../glib/gmain.c:3619
#6  0x00007fea4419d0bb in g_main_context_iterate (context=context@entry=0x7fea3c000c20, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4027
#7  0x00007fea4419d2c3 in g_main_context_iteration (context=0x7fea3c000c20, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#8  0x00007fea45e45fbb in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7fea3c000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#9  0x00007fea45dea1ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fea4116ecb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#10 0x00007fea45c04a12 in QThread::exec() (this=this@entry=0x7fea467f8d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#11 0x00007fea46774f4b in QDBusConnectionManager::run() (this=0x7fea467f8d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:179
#12 0x00007fea45c05bac in QThreadPrivate::start(void*) (arg=0x7fea467f8d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:329
#13 0x00007fea44c5d609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#14 0x00007fea45885293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fea41ac42c0 (LWP 19837)):
[KCrash Handler]
#6  0x00005597b37b9540 in  ()
#7  0x00007fea30196cb1 in DeclarativeMimeData::DeclarativeMimeData(QMimeData const*) (this=0x5597bd5a6240, copy=0x5597bd710fd0) at ./src/qmlcontrols/draganddrop/DeclarativeMimeData.cpp:40
#8  0x00007fea30196510 in DeclarativeDragDropEvent::mimeData() (this=0x7ffe752d0c50) at /usr/include/x86_64-linux-gnu/qt5/QtGui/qevent.h:667
#9  0x00007fea30190c65 in DeclarativeDragDropEvent::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_c=QMetaObject::ReadProperty, _a=<optimized out>, _id=<optimized out>, _o=<optimized out>) at ./obj-x86_64-linux-gnu/src/qmlcontrols/draganddrop/draganddropplugin_autogen/EWIEGA46WW/moc_DeclarativeDragDropEvent.cpp:121
#10 DeclarativeDragDropEvent::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./obj-x86_64-linux-gnu/src/qmlcontrols/draganddrop/draganddropplugin_autogen/EWIEGA46WW/moc_DeclarativeDragDropEvent.cpp:93
#11 0x00007fea47337a52 in QQmlPropertyData::readPropertyWithArgs(QObject*, void**) const (args=0x7ffe752ced10, target=0x7ffe752d0c50, this=0x5597b9f246a8) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:363
#12 QQmlPropertyData::readProperty(QObject*, void*) const (property=0x7ffe752cecf0, target=0x7ffe752d0c50, this=0x5597b9f246a8) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#13 loadProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData const&) (v4=0x5597b39d62e0, object=0x7ffe752d0c50, property=...) at jsruntime/qv4qobjectwrapper.cpp:138
#14 0x00007fea47359b07 in QV4::Moth::VME::interpret(QV4::CppStackFrame*, QV4::ExecutionEngine*, char const*) (frame=0x7ffe752cef10, engine=0x5597b39d62e0, code=0x7fea293304a2 ":\004:\005\030\b\022<\030\v\246\006\b\001\v\030\b\006b\bL\005\246\a\006") at jsruntime/qv4vme_moth.cpp:638
#15 0x00007fea4735f02f in QV4::Moth::VME::exec(QV4::CppStackFrame*, QV4::ExecutionEngine*) (frame=frame@entry=0x7ffe752cef10, engine=engine@entry=0x5597b39d62e0) at jsruntime/qv4vme_moth.cpp:463
#16 0x00007fea472ec24d in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) (this=this@entry=0x5597b5687d40, thisObject=<optimized out>, argv=argv@entry=0x7fea3836a508, argc=<optimized out>, context=<optimized out>) at jsruntime/qv4function.cpp:69
#17 0x00007fea47491fa7 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) (this=this@entry=0x5597b396b1e0, callData=callData@entry=0x7fea3836a4d8, isUndefined=isUndefined@entry=0x0) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:343
#18 0x00007fea474358ae in QQmlBoundSignalExpression::evaluate(void**) (this=<optimized out>, a=<optimized out>) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/jsruntime/qv4jscall_p.h:95
#19 0x00007fea47436948 in QQmlBoundSignal_callback(QQmlNotifierEndpoint*, void**) (e=0x5597b567f260, a=0x7ffe752d0c20) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlboundsignalexpressionpointer_p.h:69
#20 0x00007fea4747164d in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) (endpoint=<optimized out>, a=a@entry=0x7ffe752d0c20) at qml/qqmlnotifier.cpp:104
#21 0x00007fea47413fbf in QQmlData::signalEmitted(QAbstractDeclarativeData*, QObject*, int, void**) (object=0x5597b567eea0, index=30, a=0x7ffe752d0c20) at qml/qqmlengine.cpp:834
#22 0x00007fea45e22245 in doActivate<false>(QObject*, int, void**) (sender=0x5597b567eea0, signal_index=30, argv=0x7ffe752d0c20) at kernel/qobject_p.h:110
#23 0x00007fea45e1ba87 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) (sender=sender@entry=0x5597b567eea0, m=m@entry=0x7fea3019d920 <DeclarativeDropArea::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7ffe752d0c20) at kernel/qobject.cpp:3946
#24 0x00007fea30190653 in DeclarativeDropArea::dragEnter(DeclarativeDragDropEvent*) (this=this@entry=0x5597b567eea0, _t1=<optimized out>, _t1@entry=0x7ffe752d0c50) at ./obj-x86_64-linux-gnu/src/qmlcontrols/draganddrop/draganddropplugin_autogen/EWIEGA46WW/moc_DeclarativeDropArea.cpp:268
#25 0x00007fea3019668b in DeclarativeDropArea::dragEnterEvent(QDragEnterEvent*) (this=0x5597b567eea0, event=0x7ffe752d1060) at ./src/qmlcontrols/draganddrop/DeclarativeDropArea.cpp:45
#26 0x00007fea478a45a8 in QQuickItem::event(QEvent*) (this=0x5597b567eea0, ev=0x7ffe752d1060) at items/qquickitem.cpp:8131
#27 0x00007fea46ae7dc3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x5597b379f180, receiver=receiver@entry=0x5597b567eea0, e=e@entry=0x7ffe752d1060) at kernel/qapplication.cpp:3632
#28 0x00007fea46af0bb8 in QApplication::notify(QObject*, QEvent*) (this=0x7ffe752d2a30, receiver=0x5597b567eea0, e=0x7ffe752d1060) at kernel/qapplication.cpp:3156
#29 0x00007fea45deb69a in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x5597b567eea0, event=0x7ffe752d1060) at ../../include/QtCore/5.15.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#30 0x00007fea478c1b35 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=<optimized out>, event=<optimized out>, currentGrabItems=0x0) at items/qquickwindow.cpp:3100
#31 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b56807f0, event=0x7ffe752d12e0, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#32 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b5673750, event=0x7ffe752d1450, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#33 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b3dbe500, event=0x7ffe752d15c0, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#34 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b9523820, event=0x7ffe752d1730, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#35 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b951a6b0, event=0x7ffe752d18a0, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#36 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b5751f70, event=0x7ffe752d1a10, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#37 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b3d75be0, event=0x7ffe752d1b80, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#38 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b546f630, event=0x7ffe752d1cf0, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#39 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b53ff950, event=0x7ffe752d1e60, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#40 0x00007fea478c18e2 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QQuickItem*, QDragMoveEvent*, QVarLengthArray<QQuickItem*, 64>*) (this=0x5597b5abbf60, grabber=0x5597b5919970, item=0x5597b53fae50, event=0x7ffe752d2030, currentGrabItems=0x0) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qlist.h:117
#41 0x00007fea478c2222 in QQuickWindowPrivate::deliverDragEvent(QQuickDragGrabber*, QEvent*) (this=this@entry=0x5597b5abbf60, grabber=0x5597b5919970, event=event@entry=0x5597b953fb50) at items/qquickwindow.cpp:3048
#42 0x00007fea478c2d5d in QQuickWindow::event(QEvent*) (this=this@entry=0x5597b53fb5f0, e=e@entry=0x5597b953fb50) at items/qquickwindow.cpp:1825
#43 0x00005597b346f28f in PanelView::event(QEvent*) (this=0x5597b53fb5f0, e=0x5597b953fb50) at ./shell/panelview.cpp:1024
#44 0x00007fea46ae7dc3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x5597b379f180, receiver=receiver@entry=0x5597b53fb5f0, e=e@entry=0x5597b953fb50) at kernel/qapplication.cpp:3632
#45 0x00007fea46af0bb8 in QApplication::notify(QObject*, QEvent*) (this=0x7ffe752d2a30, receiver=0x5597b53fb5f0, e=0x5597b953fb50) at kernel/qapplication.cpp:3156
#46 0x00007fea45deb69a in QCoreApplication::notifyInternal2(QObject*, QEvent*) (receiver=0x5597b53fb5f0, event=0x5597b953fb50) at ../../include/QtCore/5.15.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#47 0x00007fea45dedfa1 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) (receiver=0x0, event_type=0, data=0x5597b37941b0) at kernel/qcoreapplication.cpp:1817
#48 0x00007fea45e46947 in postEventSourceDispatch(GSource*, GSourceFunc, gpointer) (s=0x5597b3810ba0) at kernel/qeventdispatcher_glib.cpp:277
#49 0x00007fea4419cf9d in g_main_dispatch (context=0x5597b37d4980) at ../../../glib/gmain.c:3309
#50 g_main_context_dispatch (context=context@entry=0x5597b37d4980) at ../../../glib/gmain.c:3974
#51 0x00007fea4419d220 in g_main_context_iterate (context=context@entry=0x5597b37d4980, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:4047
#52 0x00007fea4419d2c3 in g_main_context_iteration (context=0x5597b37d4980, may_block=may_block@entry=1) at ../../../glib/gmain.c:4108
#53 0x00007fea45e45fa2 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x5597b3810b80, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#54 0x00007fea45dea1ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffe752d28e0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#55 0x00007fea45df2354 in QCoreApplication::exec() () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#56 0x00005597b3454e5e in main(int, char**) (argc=<optimized out>, argv=<optimized out>) at ./shell/main.cpp:251
[Inferior 1 (process 19837) detached]
Comment 40 Ismael Asensio 2021-03-26 16:04:28 UTC
Can confirm on current git master with the same backtrace
Comment 41 Abhijeet Viswa 2021-04-15 07:23:07 UTC
This sill happens on 5.21+Wayland.
Comment 42 Alois Wohlschlager 2021-04-15 10:20:45 UTC
I got an interesting variant of the backtrace today, pasting it here:

#0  __GI___pthread_sigmask (how=how@entry=1, newmask=<optimized out>, 
    newmask@entry=0x7ffe050704d0, oldmask=oldmask@entry=0x0) at pthread_sigmask.c:44
#1  0x00007f313694b76d in __GI___sigprocmask (how=how@entry=1, set=set@entry=0x7ffe050704d0, oset=oset@entry=0x0)
    at ../sysdeps/unix/sysv/linux/sigprocmask.c:25
#2  0x00007f3138392feb in KCrash::setCrashHandler(void (*)(int)) (handler=handler@entry=0x0)
    at /usr/src/debug/kcrash-5.80.0-1.1.x86_64/src/kcrash.cpp:379
#3  0x00007f3138394e8a in KCrash::defaultCrashHandler(int) (sig=11)
    at /usr/src/debug/kcrash-5.80.0-1.1.x86_64/src/kcrash.cpp:575
#4  0x00007f313694b530 in <signal handler called> () at /lib64/libc.so.6
#5  DeclarativeMimeData::DeclarativeMimeData(QMimeData const*)
    (this=0x55b90fd7f7b0, copy=0x55b912b99a70, this=<optimized out>, copy=<optimized out>)
    at /usr/src/debug/kdeclarative-5.80.0-1.1.x86_64/src/qmlcontrols/draganddrop/DeclarativeMimeData.cpp:40
#6  0x00007f3114509081 in DeclarativeDragDropEvent::mimeData() (this=0x7ffe05072c20)
    at /usr/src/debug/kdeclarative-5.80.0-1.1.x86_64/src/qmlcontrols/draganddrop/DeclarativeDragDropEvent.cpp:52
#7  DeclarativeDragDropEvent::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)
    (_a=<optimized out>, _id=<optimized out>, _c=<optimized out>, _o=0x7ffe05072c20)
    at /usr/src/debug/kdeclarative-5.80.0-1.1.x86_64/build/src/qmlcontrols/draganddrop/draganddropplugin_autogen/EWIEGA46WW/moc_DeclarativeDragDropEvent.cpp:121
#8  DeclarativeDragDropEvent::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)
    (_o=0x7ffe05072c20, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>)
    at /usr/src/debug/kdeclarative-5.80.0-1.1.x86_64/build/src/qmlcontrols/draganddrop/draganddropplugin_autogen/EWIEGA46WW/moc_DeclarativeDragDropEvent.cpp:93
#9  0x00007f3138545071 in QQmlPropertyData::readPropertyWithArgs(QObject*, void**) const
    (args=0x7ffe05070e90, target=0x7ffe05072c20, this=0x55b913501508)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2-3.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:363
#10 QQmlPropertyData::readProperty(QObject*, void*) const
    (property=0x7ffe05070e70, target=0x7ffe05072c20, this=0x55b913501508)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2-3.1.x86_64/include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#11 loadProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData const&)
    (v4=0x55b90d45cf60, object=0x7ffe05072c20, property=...)
    at /usr/src/debug/libqt5-qtdeclarative-5.15.2-3.1.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:138
#12 0x00007f30f095a944 in  ()
#13 0x0000000000000000 in  ()

I think #0-#4 can be explained by KCrash interfering, but the corruption starting at #12 might be relevant.
Comment 43 Bug Janitor Service 2021-04-17 09:12:04 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/793
Comment 44 David Edmundson 2021-04-17 22:17:41 UTC
Git commit c19d8de7a7b9dc504c329111b812c943a0bd1ec0 by David Edmundson, on behalf of Alois Wohlschlager.
Committed on 17/04/2021 at 22:17.
Pushed by davidedmundson into branch 'master'.

Fix crash on drag-and-drop over panel

The fake drag-and-drop events caused by the panel reuse the real event's
mimeData, and were handled asynchronously. By the time the fake event
has been dispatched from the event loop, the mimeData may already have
been freed. Send the fake events synchronously again.

A guard is added to avoid the original potential bug of infinite recursion.

M  +56   -46   shell/panelview.cpp
M  +1    -0    shell/panelview.h

https://invent.kde.org/plasma/plasma-workspace/commit/c19d8de7a7b9dc504c329111b812c943a0bd1ec0
Comment 45 David Edmundson 2021-04-17 22:18:29 UTC
Git commit 9e986f8c85ad79e75ed43c1af751ded44afbbc5b by David Edmundson, on behalf of Alois Wohlschlager.
Committed on 17/04/2021 at 22:18.
Pushed by davidedmundson into branch 'Plasma/5.21'.

Fix crash on drag-and-drop over panel

The fake drag-and-drop events caused by the panel reuse the real event's
mimeData, and were handled asynchronously. By the time the fake event
has been dispatched from the event loop, the mimeData may already have
been freed. Send the fake events synchronously again.

A guard is added to avoid the original potential bug of infinite recursion.


(cherry picked from commit c19d8de7a7b9dc504c329111b812c943a0bd1ec0)

M  +56   -46   shell/panelview.cpp
M  +1    -0    shell/panelview.h

https://invent.kde.org/plasma/plasma-workspace/commit/9e986f8c85ad79e75ed43c1af751ded44afbbc5b