Bug 385791 - kde-gtk-config does not remember changes
Summary: kde-gtk-config does not remember changes
Status: RESOLVED DUPLICATE of bug 382291
Alias: None
Product: kde-gtk-config
Classification: Unclassified
Component: general (show other bugs)
Version: 5.11.0
Platform: Slackware Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Manuel Tortosa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-10-15 20:39 UTC by sombragris
Modified: 2017-10-25 18:43 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sombragris 2017-10-15 20:39:47 UTC
After an user sets their preferences as a kcmshell5 module, changes are put into effect. However, on a second run, all values are reset to the lowest value. That is, GTK3 theme is set to Adwaita, GTK2 to whatever comes first in an alphabetical list, and this also applies to the font.

The expected behavior is that this module should remember the previous choice made by the user.
Comment 1 Nate Graham 2017-10-15 23:17:20 UTC

*** This bug has been marked as a duplicate of bug 385744 ***
Comment 2 Nate Graham 2017-10-16 03:15:14 UTC
*** Bug 385744 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2017-10-16 12:18:30 UTC
Looks like this is happening for more than just GTK: https://bugs.kde.org/show_bug.cgi?id=385776

*** This bug has been marked as a duplicate of bug 385776 ***
Comment 4 Patrick Silva 2017-10-16 13:29:28 UTC
I think this report is not a duplicate of bug 385776.

kcm-gtk applies the changes since the first try. The problem is that the changes are not reflected in the next time that kcm-gtk is started.

My bug 385776 says that the change is NOT applied on first try.
Comment 5 Nate Graham 2017-10-16 16:05:33 UTC
*** Bug 385744 has been marked as a duplicate of this bug. ***
Comment 6 Rik Mills 2017-10-24 07:30:29 UTC

*** This bug has been marked as a duplicate of bug 382291 ***
Comment 7 Rik Mills 2017-10-24 07:35:23 UTC
(In reply to Dr. Chapatin from comment #4)
> I think this report is not a duplicate of bug 385776.
> 
> kcm-gtk applies the changes since the first try. The problem is that the
> changes are not reflected in the next time that kcm-gtk is started.
> 
> My bug 385776 says that the change is NOT applied on first try.

Correct in this specific case for the kde-gtk-config. This is a dupe of bug 382291 instead