Bug 382291 - System settings GTK apps configurations resets.
Summary: System settings GTK apps configurations resets.
Status: RESOLVED FIXED
Alias: None
Product: kde-gtk-config
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: NOR normal with 8 votes (vote)
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
: 385744 385791 386148 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-07-13 06:12 UTC by Tony
Modified: 2017-10-29 10:19 UTC (History)
17 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony 2017-07-13 06:12:59 UTC
I got this regression on Opensuse tumbleweed at first, switch to Neon updated and the same happens.

To reproduce:
Change GTK apps style on systemsettings.
Either close systemsettings or hit back ("All Settings"). The settings will be applied/saved.
Go back to GTk style. Noticed options are set to default.

Plasma 5.10.90
Frameworks 5.37
Qt 5.9.1
Comment 1 Tony 2017-08-05 20:47:44 UTC
Latest "systemsettings" update from the unstable repos kde on tumbleweed fixed it for me.
Comment 2 Patrick Silva 2017-08-06 19:14:44 UTC
I have this bug on neon dev unstable.
Comment 3 Patrick Silva 2017-09-14 21:02:57 UTC
this bug affects plasma 5.11 beta on Arch.
Comment 4 Richard Ullger 2017-09-19 09:10:51 UTC
Confirm this issue is present in 5.10.95 in the Arch kde-unstable repo.

Although the settings have reverted to some default in the Gnome Application Style (GTK) window, the correct settings are still present in the local files $[HOME}/.GTKRC-2.0 and $[HOME}/.GTKRC-2.0-kde4 and reflected in the GTK apps.

However, if a change is made to any setting in that window, all the other settings will revert to default in the local files. The workaround for this is to change all the settings required in the window each time and apply the changes. You will then have the correct settings in the local files.
Comment 5 Texstar 2017-10-10 12:59:13 UTC
Confirm this issue is present in 5.11.0 as well. :-(
Comment 6 Rik Mills 2017-10-10 14:51:53 UTC
Affects 5.11.0 here

As described, even though the config files are sett to the correct plasma defaults, the GTK KCM shows weird other defaults instead.

On changing back to what they should show and applying, on returning to the GTK KCM, they again show incorrect entries.
Comment 7 Fabian Vogt 2017-10-10 15:43:52 UTC
Likely a regression introduced by 34357f74ee2d98128ff423b0ec6ddcbf4232c475 ("Make the kde-gtk-config kcm better at checking global gtk settings").
Comment 8 Rik Mills 2017-10-13 15:39:07 UTC
(In reply to Fabian Vogt from comment #7)
> Likely a regression introduced by 34357f74ee2d98128ff423b0ec6ddcbf4232c475
> ("Make the kde-gtk-config kcm better at checking global gtk settings").

Seems likely, though need to test behaviour on reverting to see if so, and if that is viable as a last resort. Obviously fixing would be better, so hopefully Aleix Pol can chime in.
Comment 9 Rik Mills 2017-10-24 07:30:29 UTC
*** Bug 385791 has been marked as a duplicate of this bug. ***
Comment 10 Rik Mills 2017-10-24 07:38:27 UTC
*** Bug 385744 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2017-10-24 12:52:06 UTC
There's a patch for this at https://phabricator.kde.org/D8443
Comment 12 Fabian Vogt 2017-10-24 12:57:32 UTC
Git commit 0d0f812a1704c62c014bc87162b1280224b64f93 by Fabian Vogt.
Committed on 24/10/2017 at 12:54.
Pushed by fvogt into branch 'Plasma/5.11'.

Revert "Make the kde-gtk-config kcm better at checking global gtk settings"

Summary:
This reverts commit 34357f74ee2d98128ff423b0ec6ddcbf4232c475.

Reverting this fixes loading of the actually used GTK settings.

Test Plan:
Opened kcmshell5 kde-gtk-config with and without this revert.
Without, it shows Adwaita as theme, with it shows breeze.
GTK uses breeze, so the behaviour with the revert is correct.

Reviewers: #plasma, apol

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D8443

M  +1    -1    CMakeLists.txt
M  +2    -3    src/abstractappearance.h
M  +40   -63   src/appearancegtk2.cpp
M  +2    -9    src/appearancegtk2.h
M  +63   -80   src/appearancegtk3.cpp
M  +1    -9    src/appearancegtk3.h
M  +2    -2    src/appearencegtk.cpp
M  +1    -1    tests/CMakeLists.txt
M  +28   -47   tests/configsavetest.cpp
M  +4    -4    tests/configsavetest.h

https://commits.kde.org/kde-gtk-config/0d0f812a1704c62c014bc87162b1280224b64f93
Comment 13 Aleix Pol 2017-10-24 15:32:01 UTC
Git commit efa8c4df5b567d382317bd6f375cd1763737ff95 by Aleix Pol.
Committed on 24/10/2017 at 15:28.
Pushed by apol into branch 'Plasma/5.11'.

Properly access the system's GTK settings

M  +4    -6    src/appearancegtk3.cpp

https://commits.kde.org/kde-gtk-config/efa8c4df5b567d382317bd6f375cd1763737ff95
Comment 14 Patrick Silva 2017-10-24 21:01:16 UTC
Just updated to plasma 5.11.2 on Arch...
This bug is not completely fixed,
it affects GTK2 theme drop down yet.
Comment 15 Patrick Silva 2017-10-24 21:39:55 UTC
It affects "on left-clicking scroll bar" preference too.
Comment 16 Texstar 2017-10-24 22:11:00 UTC
I updated from git a couple of hours ago from 5.11.2 and the GTK2 theme drop down is fixed there.
Comment 17 Rik Mills 2017-10-25 06:31:21 UTC
(In reply to Dr. Chapatin from comment #14)
> Just updated to plasma 5.11.2 on Arch...
> This bug is not completely fixed,
> it affects GTK2 theme drop down yet.

Can confirm, not fixed on GTK2 dropdown, with latest 5.11.2 tarball OR latest git 5.11 branch that was generated from.

On some systems where the default is breeze-gtk, it can appear to be fixed here, as it reverts to that apparently correct default.

However, if you try to change that to something else, close systemsettings or the KCM completely, then re-open. The GTK2 theme has reverted to whatever system or otherwise default is was reading, and does not see the setting in a user's profile ~/.gtkrc-2.0*
Comment 18 Stéphane Cachemaille 2017-10-25 10:09:19 UTC
(In reply to Dr. Chapatin from comment #14)
> Just updated to plasma 5.11.2 on Arch...
> This bug is not completely fixed,
> it affects GTK2 theme drop down yet.

I confirm this too on manjaro.
Comment 19 Stéphane Cachemaille 2017-10-25 10:11:03 UTC
and it seems the GTK3 preview is not working too. 
whatever theme I choose. the preview is always the same
Comment 20 Aleix Pol 2017-10-25 11:22:53 UTC
Git commit 952ab8f36e3c52a7ac6830ffd5b5c65f71fa0931 by Aleix Pol.
Committed on 25/10/2017 at 11:20.
Pushed by apol into branch 'Plasma/5.11'.

Be flexible to systems without a gtkrc file in /etc

Always load both files and make the best out of them

M  +3    -1    src/appearancegtk2.cpp

https://commits.kde.org/kde-gtk-config/952ab8f36e3c52a7ac6830ffd5b5c65f71fa0931
Comment 21 Nate Graham 2017-10-25 15:46:08 UTC
*** Bug 386148 has been marked as a duplicate of this bug. ***
Comment 22 Rik Mills 2017-10-29 10:19:55 UTC
(In reply to Stéphane Cachemaille from comment #19)
> and it seems the GTK3 preview is not working too. 
> whatever theme I choose. the preview is always the same

I can confirm this.