Bug 376396 - Kmail crashes when starting it
Summary: Kmail crashes when starting it
Status: RESOLVED DUPLICATE of bug 377129
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
: 376420 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-12 12:07 UTC by Stefano Carlesso
Modified: 2017-06-13 19:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.60 KB, text/plain)
2017-02-12 12:27 UTC, Stefano Carlesso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefano Carlesso 2017-02-12 12:07:26 UTC
Application: kmail (5.4.2)

Qt Version: 5.7.1
Frameworks Version: 5.30.0
Operating System: Linux 4.4.0-62-generic x86_64
Distribution: KDE neon LTS User Edition 5.8

-- Information about the crash:
- What I was doing when the application crashed:
Every time I start Kmail fom both the Plasma Application Menu and the terminal, it crashes. 
When starting from terminal, I get this message.
```
ste@pegasus (~): kmail
Pass a valid window to KWallet::Wallet::openWallet().
org.kde.pim.kidentitymanagement: IdentityManager: There was no default identity. Marking first one as default.
Could not find QtWebEngineProcess
*** KMail got signal 6 (Exiting)
*** Dead letters dumped.
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = kmail path = /usr/bin pid = 4885
KCrash: Arguments: /usr/bin/kmail 
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit
sock_file=/run/user/1000/kdeinit5__0

[1]+  Stopped                 kmail
```

- Custom settings of the application:
I've setup two accounts: Yahoo Mail and GMX.com both using the IMAP protocol.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0f4ab0ea00 (LWP 4741))]

Thread 6 (Thread 0x7f0f2ffff700 (LWP 4750)):
#0  0x00007f0f6ee82929 in g_main_context_prepare (context=context@entry=0x7f0f28000990, priority=priority@entry=0x7f0f2fffea80) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3453
#1  0x00007f0f6ee832bb in g_main_context_iterate (context=context@entry=0x7f0f28000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3820
#2  0x00007f0f6ee8349c in g_main_context_iteration (context=0x7f0f28000990, may_block=may_block@entry=1) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3901
#3  0x00007f0f7af5475b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0f280008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f0f7aeff0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0f2fffebc0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#5  0x00007f0f7ad2ef64 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#6  0x00007f0f7ad33b48 in QThreadPrivate::start(void*) (arg=0x1aa7370) at thread/qthread_unix.cpp:368
#7  0x00007f0f70bdc6ba in start_thread (arg=0x7f0f2ffff700) at pthread_create.c:333
#8  0x00007f0f7a42a82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f0f3ce4c700 (LWP 4748)):
#0  0x00007f0f6ee82da0 in g_main_context_check (context=context@entry=0x7f0f34000990, max_priority=2147483647, fds=fds@entry=0x7f0f34003020, n_fds=n_fds@entry=1) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3673
#1  0x00007f0f6ee83330 in g_main_context_iterate (context=context@entry=0x7f0f34000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3837
#2  0x00007f0f6ee8349c in g_main_context_iteration (context=0x7f0f34000990, may_block=may_block@entry=1) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3901
#3  0x00007f0f7af5475b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0f340008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f0f7aeff0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0f3ce4bbc0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#5  0x00007f0f7ad2ef64 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#6  0x00007f0f7ad33b48 in QThreadPrivate::start(void*) (arg=0x1a95910) at thread/qthread_unix.cpp:368
#7  0x00007f0f70bdc6ba in start_thread (arg=0x7f0f3ce4c700) at pthread_create.c:333
#8  0x00007f0f7a42a82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f0f3d6c6700 (LWP 4747)):
#0  0x00007f0f7a41eb5d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f0f6ee8338c in g_main_context_iterate (priority=2147483647, n_fds=1, fds=0x7f0f30002e70, timeout=<optimized out>, context=0x7f0f30000990) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:4135
#2  0x00007f0f6ee8338c in g_main_context_iterate (context=context@entry=0x7f0f30000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3835
#3  0x00007f0f6ee8349c in g_main_context_iteration (context=0x7f0f30000990, may_block=may_block@entry=1) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3901
#4  0x00007f0f7af5475b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0f300008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f0f7aeff0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0f3d6c5bc0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f0f7ad2ef64 in QThread::exec() (this=<optimized out>) at thread/qthread.cpp:507
#7  0x00007f0f7ad33b48 in QThreadPrivate::start(void*) (arg=0x1a6c7c0) at thread/qthread_unix.cpp:368
#8  0x00007f0f70bdc6ba in start_thread (arg=0x7f0f3d6c6700) at pthread_create.c:333
#9  0x00007f0f7a42a82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f0f3e8d7700 (LWP 4746)):
#0  0x00007f0f6eec7a79 in g_mutex_lock (mutex=mutex@entry=0x7f0f38000990) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gthread-posix.c:1335
#1  0x00007f0f6ee82dcc in g_main_context_check (context=context@entry=0x7f0f38000990, max_priority=2147483647, fds=fds@entry=0x7f0f380280f0, n_fds=n_fds@entry=1) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3683
#2  0x00007f0f6ee83330 in g_main_context_iterate (context=context@entry=0x7f0f38000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3837
#3  0x00007f0f6ee8349c in g_main_context_iteration (context=0x7f0f38000990, may_block=may_block@entry=1) at /build/glib2.0-prJhLS/glib2.0-2.48.2/./glib/gmain.c:3901
#4  0x00007f0f7af5475b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f0f380008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f0f7aeff0ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f0f3e8d6b90, flags=..., flags@entry=...) at kernel/qeventloop.cpp:212
#6  0x00007f0f7ad2ef64 in QThread::exec() (this=this@entry=0x7f0f7d058d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:507
#7  0x00007f0f7cfe4735 in QDBusConnectionManager::run() (this=0x7f0f7d058d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#8  0x00007f0f7ad33b48 in QThreadPrivate::start(void*) (arg=0x7f0f7d058d60 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:368
#9  0x00007f0f70bdc6ba in start_thread (arg=0x7f0f3e8d7700) at pthread_create.c:333
#10 0x00007f0f7a42a82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f0f3f7a5700 (LWP 4745)):
#0  0x00007f0f70be2360 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f0f436ec0f3 in  () at /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007f0f436eb817 in  () at /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007f0f70bdc6ba in start_thread (arg=0x7f0f3f7a5700) at pthread_create.c:333
#4  0x00007f0f7a42a82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f0f4ab0ea00 (LWP 4741)):
[KCrash Handler]
#6  0x00007f0f7a359428 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#7  0x00007f0f7a35b02a in __GI_abort () at abort.c:89
#8  0x00007f0f7ad1a811 in QMessageLogger::fatal(char const*, ...) const (context=..., message=<synthetic pointer>) at global/qlogging.cpp:1682
#9  0x00007f0f7ad1a811 in QMessageLogger::fatal(char const*, ...) const (this=this@entry=0x7fff09843930, msg=msg@entry=0x7f0f68ba10ad "Could not find %s") at global/qlogging.cpp:793
#10 0x00007f0f6543cea6 in WebEngineLibraryInfo::getPath(int) () at /workspace/build/src/core/web_engine_library_info.cpp:149
#11 0x00007f0f6543cea6 in WebEngineLibraryInfo::getPath(int) (key=key@entry=4000) at /workspace/build/src/core/web_engine_library_info.cpp:268
#12 0x00007f0f6543841d in QtWebEngineCore::WebEngineContext::WebEngineContext() (this=0x1d242c0) at /workspace/build/src/core/web_engine_context.cpp:276
#13 0x00007f0f65439fa5 in QtWebEngineCore::WebEngineContext::current() () at /workspace/build/src/core/web_engine_context.cpp:207
#14 0x00007f0f6543e850 in QtWebEngineCore::WebEngineSettings::initDefaults(bool) (this=0x1d23ce0, offTheRecord=<optimized out>) at /workspace/build/src/core/web_engine_settings.cpp:228
#15 0x00007f0f7cf6a083 in QWebEngineProfilePrivate::QWebEngineProfilePrivate(QSharedPointer<QtWebEngineCore::BrowserContextAdapter>) () at /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#16 0x00007f0f7cf6a264 in QWebEngineProfile::QWebEngineProfile(QObject*) () at /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#17 0x00007f0f779344bd in MessageViewer::MailWebEngineView::MailWebEngineView(KActionCollection*, QWidget*) (this=0x1d234d0, ac=0x1aa47d0, parent=<optimized out>) at /workspace/build/messageviewer/src/viewer/webengine/mailwebengineview.cpp:92
#18 0x00007f0f778dd3cf in MessageViewer::ViewerPrivate::createWidgets() (this=this@entry=0x1ce8350) at /workspace/build/messageviewer/src/viewer/viewer_p.cpp:1489
#19 0x00007f0f778e5815 in MessageViewer::ViewerPrivate::ViewerPrivate(MessageViewer::Viewer*, QWidget*, KActionCollection*) (this=0x1ce8350, aParent=<optimized out>, mainWindow=<optimized out>, actionCollection=<optimized out>) at /workspace/build/messageviewer/src/viewer/viewer_p.cpp:252
#20 0x00007f0f778d1c90 in MessageViewer::Viewer::Viewer(QWidget*, QWidget*, KActionCollection*) (this=0x1ce7f50, aParent=<optimized out>, mainWindow=0x1b28a20, actionCollection=0x1aa47d0) at /workspace/build/messageviewer/src/viewer/viewer.cpp:54
#21 0x00007f0f7c84d031 in KMReaderWin::KMReaderWin(QWidget*, QWidget*, KActionCollection*) (this=0x1ce2050, aParent=<optimized out>, mainWindow=<optimized out>, actionCollection=<optimized out>) at /workspace/build/src/kmreaderwin.cpp:115
#22 0x00007f0f7c89254e in KMMainWidget::createWidgets() (this=this@entry=0x1b28a20) at /workspace/build/src/kmmainwidget.cpp:1024
#23 0x00007f0f7c89c539 in KMMainWidget::KMMainWidget(QWidget*, KXMLGUIClient*, KActionCollection*, QExplicitlySharedDataPointer<KSharedConfig>) (this=0x1b28a20, parent=<optimized out>, aGUIClient=<optimized out>, actionCollection=0x1aa47d0, config=...) at /workspace/build/src/kmmainwidget.cpp:265
#24 0x00007f0f7c84998a in KMMainWin::KMMainWin(QWidget*) (this=0x1b26700, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /workspace/build/src/kmmainwin.cpp:61
#25 0x00007f0f7c85a118 in KMKernel::openReader(bool) (this=this@entry=0x7fff09845d20, onlyCheck=onlyCheck@entry=false) at /workspace/build/src/kmkernel.cpp:520
#26 0x00007f0f7c86411c in KMKernel::action(bool, bool, QString const&, QString const&, QString const&, QString const&, QString const&, QUrl const&, QList<QUrl> const&, QStringList const&, QString const&, QString const&, QString const&) (this=this@entry=0x7fff09845d20, mailto=mailto@entry=false, check=check@entry=false, to=..., cc=..., bcc=..., subj=..., body=..., messageFile=..., attachURLs=..., customHeaders=..., replyTo=..., inReplyTo=..., identity=...) at /workspace/build/src/kmkernel.cpp:1467
#27 0x00007f0f7c8657fb in KMKernel::handleCommandLine(bool, QStringList const&, QString const&) (this=0x7fff09845d20, noArgsOpensReader=noArgsOpensReader@entry=true, args=..., workingDir=...) at /workspace/build/src/kmkernel.cpp:425
#28 0x0000000000404679 in KMailApplication::activate(QStringList const&, QString const&) (this=this@entry=0x7fff09845d00, args=..., workindDir=...) at /workspace/build/src/main.cpp:98
#29 0x0000000000403b90 in main(int, char**) (workindDir=..., args=..., this=0x7fff09845d00) at /workspace/build/src/main.cpp:107
#30 0x0000000000403b90 in main(int, char**) (argc=1, argv=0x7fff09845f38) at /workspace/build/src/main.cpp:158

Possible duplicates by query: bug 376333, bug 375284, bug 374462, bug 364721, bug 364342.

Reported using DrKonqi
Comment 1 Stefano Carlesso 2017-02-12 12:27:03 UTC
Created attachment 104000 [details]
New crash information added by DrKonqi

kmail (5.4.2) using Qt 5.7.1

- What I was doing when the application crashed:
Starting Kmail both from the Plasma Application Menu and from the terminal result in the application closing unexpectedly.
When Launching from the terminal, I get this message
```
$ kmail                                                                                                                              
org.kde.pim.kidentitymanagement: IdentityManager: There was no default identity. Marking first one as default.                       
Could not find QtWebEngineProcess                                                                                                    
*** KMail got signal 6 (Exiting)                                                                                                     
*** Dead letters dumped.                                                                                                             
KCrash: crashing... crashRecursionCounter = 2                                                                                        
KCrash: Application Name = kmail path = /usr/bin pid = 5983                                                                          
KCrash: Arguments: /usr/bin/kmail                                                                                                    
KCrash: Attempting to start /usr/lib/x86_64-linux-gnu/libexec/drkonqi from kdeinit                                                   
sock_file=/run/user/1001/kdeinit5__0                                                                                                 
[1] + Stopped (signal)           kmail   
```
- Custom settings of the application:
I created a new user to test Kmail. Default settings. I haven't setup any mail account yet.

-- Backtrace (Reduced):
#6  0x00007f8ccd08e428 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#7  0x00007f8ccd09002a in __GI_abort () at abort.c:89
#8  0x00007f8ccda4f811 in QMessageLogger::fatal(char const*, ...) const (context=..., message=<synthetic pointer>) at global/qlogging.cpp:1682
#9  0x00007f8ccda4f811 in QMessageLogger::fatal(char const*, ...) const (this=this@entry=0x7ffdd880ef60, msg=msg@entry=0x7f8cbb8d60ad "Could not find %s") at global/qlogging.cpp:793
#10 0x00007f8cb8171ea6 in WebEngineLibraryInfo::getPath(int) () at /workspace/build/src/core/web_engine_library_info.cpp:149
Comment 2 Christoph Feck 2017-02-23 02:21:44 UTC
*** Bug 376420 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2017-06-13 19:33:51 UTC

*** This bug has been marked as a duplicate of bug 377129 ***