Bug 375284 - Découvrir se plante quand je clique sur Mise à jour
Summary: Découvrir se plante quand je clique sur Mise à jour
Status: RESOLVED DUPLICATE of bug 375052
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-01-19 08:50 UTC by nicolas.religieux
Modified: 2017-01-19 20:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nicolas.religieux 2017-01-19 08:50:40 UTC
Application: plasma-discover (5.7.5)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.8.0-34-generic x86_64
Distribution: Ubuntu 16.10

-- Information about the crash:
- What I was doing when the application crashed:
Après avoir delocké ma session via loginctl unlock-sessions, je lance découvrir pour installer des mises à jour et il plante instantanément.

The crash can be reproduced every time.

-- Backtrace:
Application: Découvrir (plasma-discover), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe4dc386d40 (LWP 7484))]

Thread 5 (Thread 0x7fe4c9413700 (LWP 7488)):
#0  0x00007fe4e666f0bd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fe4e38f09d6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe4e38f0aec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe4e72a64ab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fe4e724e0fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fe4e7073d43 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fe4e7078c68 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007fe4e3e136ca in start_thread (arg=0x7fe4c9413700) at pthread_create.c:333
#8  0x00007fe4e667b0af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 4 (Thread 0x7fe4cb5ef700 (LWP 7487)):
#0  0x00007ffd721edb02 in clock_gettime ()
#1  0x00007fe4e6689846 in __GI___clock_gettime (clock_id=1, tp=0x7fe4cb5eea40) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fe4e7124726 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007fe4e72a4039 in QTimerInfoList::updateCurrentTime() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fe4e72a45e5 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fe4e72a599e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fe4e38efed9 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fe4e38f08fb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fe4e38f0aec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fe4e72a64ab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007fe4e724e0fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007fe4e7073d43 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007fe4e9238c65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#13 0x00007fe4e7078c68 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007fe4e3e136ca in start_thread (arg=0x7fe4cb5ef700) at pthread_create.c:333
#15 0x00007fe4e667b0af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 3 (Thread 0x7fe4d0b01700 (LWP 7486)):
#0  0x00007ffd721edb02 in clock_gettime ()
#1  0x00007fe4e6689846 in __GI___clock_gettime (clock_id=1, tp=0x7fe4d0b00a30) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fe4e7124726 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007fe4e72a4039 in QTimerInfoList::updateCurrentTime() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fe4e72a45e5 in QTimerInfoList::timerWait(timespec&) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fe4e72a599e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fe4e38efed9 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fe4e38f08fb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fe4e38f0aec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fe4e72a64ab in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007fe4e724e0fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007fe4e7073d43 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007fe4e46ab575 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#13 0x00007fe4e7078c68 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007fe4e3e136ca in start_thread (arg=0x7fe4d0b01700) at pthread_create.c:333
#15 0x00007fe4e667b0af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 2 (Thread 0x7fe4d942c700 (LWP 7485)):
#0  0x00007fe4e666f0bd in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007fe4e1a7ac62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fe4e1a7c8d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fe4dbfb6299 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fe4e7078c68 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fe4e3e136ca in start_thread (arg=0x7fe4d942c700) at pthread_create.c:333
#6  0x00007fe4e667b0af in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:105

Thread 1 (Thread 0x7fe4dc386d40 (LWP 7484)):
[KCrash Handler]
#6  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:58
#7  0x00007fe4e65aa3ea in __GI_abort () at abort.c:89
#8  0x00007fe4e705fcc1 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fe4e972fa13 in QSGRenderLoop::handleContextCreationFailure(QQuickWindow*, bool) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fe4e9737b82 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fe4e9737f63 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fe4e7841f65 in QWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#13 0x00007fe4e976ba13 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fe4e7e1e8ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#15 0x00007fe4e7e23d4f in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#16 0x00007fe4e72503b0 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007fe4e783729d in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#18 0x00007fe4e7837e7d in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#19 0x00007fe4e7815b2b in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#20 0x00007fe4dbfec660 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#21 0x00007fe4e38f07d7 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fe4e38f0a40 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fe4e38f0aec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fe4e72a648f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#25 0x00007fe4e724e0fa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007fe4e725690c in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x0000564fbe821699 in ?? ()
#28 0x00007fe4e65933f1 in __libc_start_main (main=0x564fbe820f90, argc=3, argv=0x7ffd720dfdb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd720dfda8) at ../csu/libc-start.c:291
#29 0x0000564fbe8217ba in _start ()

Possible duplicates by query: bug 364721, bug 364342, bug 362635, bug 362228, bug 355096.

Reported using DrKonqi
Comment 1 Christoph Feck 2017-01-19 20:01:24 UTC

*** This bug has been marked as a duplicate of bug 375052 ***