Bug 361213 - Mint would'nt shut down
Summary: Mint would'nt shut down
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Mint (Ubuntu based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-03-31 00:44 UTC by J Coombs
Modified: 2017-01-07 12:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J Coombs 2016-03-31 00:44:38 UTC
Application: akonadi_imap_resource (4.14)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.0-38-generic x86_64
Distribution: Linux Mint 17.2 Rafaela

-- Information about the crash:
- What I was doing when the application crashed:Closed all applications shutdown computer. I noticed it was not shutting down after 10 minutes I forced shutdown.

-- Backtrace:
Application: Google Mail (bigdaddymobaddie) of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8d4bf257c0 (LWP 2442))]

Thread 3 (Thread 0x7f8d37810700 (LWP 2558)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
#1  0x00007f8d4b4277f4 in wait (time=30000, this=0x7f8d30014b80) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=this@entry=0x7f8d300149a0, mutex=mutex@entry=0x7f8d300147d8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f8d4b41b0fa in QThreadPoolThread::run (this=0x7f8d30014990) at concurrent/qthreadpool.cpp:142
#4  0x00007f8d4b42732f in QThreadPrivate::start (arg=0x7f8d30014990) at thread/qthread_unix.cpp:349
#5  0x00007f8d46f22182 in start_thread (arg=0x7f8d37810700) at pthread_create.c:312
#6  0x00007f8d478c547d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f8d38011700 (LWP 2674)):
#0  __pthread_mutex_unlock_usercnt (decr=1, mutex=0x7f8d30005240) at pthread_mutex_unlock.c:63
#1  __GI___pthread_mutex_unlock (mutex=0x7f8d30005240) at pthread_mutex_unlock.c:310
#2  0x00007f8d4687f9b1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8d4683e0f6 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8d4b5567be in QEventDispatcherGlib::processEvents (this=0x7f8d30004db0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007f8d4b5280af in QEventLoop::processEvents (this=this@entry=0x7f8d38010e20, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f8d4b5283a5 in QEventLoop::exec (this=this@entry=0x7f8d38010e20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f8d4b424c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#8  0x00007f8d4b42732f in QThreadPrivate::start (arg=0x247e720) at thread/qthread_unix.cpp:349
#9  0x00007f8d46f22182 in start_thread (arg=0x7f8d38011700) at pthread_create.c:312
#10 0x00007f8d478c547d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f8d4bf257c0 (LWP 2442)):
[KCrash Handler]
#5  0x0000000000000d31 in ?? ()
#6  0x00007f8d4b53c999 in QObject::disconnect (sender=0x249f920, signal=0x23e3c09 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x47b588 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0x2460450, method=0x242aef9 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x47b540 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2883
#7  0x000000000044fbb5 in SessionPool::killSession (this=this@entry=0x2460450, session=0x249f920, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:182
#8  0x000000000044ff55 in SessionPool::disconnect (this=0x2460450, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:115
#9  0x00000000004285fb in ImapResourceBase::startConnect (this=0x241f020) at ../../../resources/imap/imapresourcebase.cpp:246
#10 0x0000000000464511 in ImapResourceBase::qt_static_metacall (_o=0x249f920, _o@entry=0x241f020, _c=685514976, _c@entry=QMetaObject::InvokeMetaMethod, _id=1, _id@entry=14, _a=0x0, _a@entry=0x7ffe28dc23d0) at moc_imapresourcebase.cpp:122
#11 0x00007f8d4b531908 in QMetaMethod::invoke (this=this@entry=0x7ffe28dc25c0, object=object@entry=0x241f020, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#12 0x00007f8d4b533dc2 in QMetaObject::invokeMethod (obj=0x241f020, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#13 0x00007f8d4ba1ad7f in ?? () from /usr/lib/libakonadi-kde.so.4
#14 0x00007f8d4ba1b90d in ?? () from /usr/lib/libakonadi-kde.so.4
#15 0x00007f8d4b541c1e in QObject::event (this=0x2461d50, e=<optimized out>) at kernel/qobject.cpp:1194
#16 0x00007f8d4a8c2e2c in QApplicationPrivate::notify_helper (this=this@entry=0x22a4040, receiver=receiver@entry=0x2461d50, e=e@entry=0x2343800) at kernel/qapplication.cpp:4567
#17 0x00007f8d4a8c94a0 in QApplication::notify (this=0x7ffe28dc3170, receiver=0x2461d50, e=0x2343800) at kernel/qapplication.cpp:4353
#18 0x00007f8d48a07cca in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#19 0x00007f8d4b5294dd in QCoreApplication::notifyInternal (this=0x7ffe28dc3170, receiver=receiver@entry=0x2461d50, event=event@entry=0x2343800) at kernel/qcoreapplication.cpp:953
#20 0x00007f8d4b52cb3d in sendEvent (event=0x2343800, receiver=0x2461d50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x2272220) at kernel/qcoreapplication.cpp:1577
#22 0x00007f8d4b52cfe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#23 0x00007f8d4b556f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=0x22a3310) at kernel/qeventdispatcher_glib.cpp:287
#25 0x00007f8d4683de04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f8d4683e048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f8d4683e0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f8d4b5567a1 in QEventDispatcherGlib::processEvents (this=0x2273700, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#29 0x00007f8d4a964be6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007f8d4b5280af in QEventLoop::processEvents (this=this@entry=0x7ffe28dc30e0, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f8d4b5283a5 in QEventLoop::exec (this=this@entry=0x7ffe28dc30e0, flags=...) at kernel/qeventloop.cpp:204
#32 0x00007f8d4b52db79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#33 0x00007f8d4ba0a783 in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libakonadi-kde.so.4
#34 0x0000000000418993 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:193
#35 0x00007f8d477ecec5 in __libc_start_main (main=0x4182e0 <main(int, char**)>, argc=3, argv=0x7ffe28dc3288, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe28dc3278) at libc-start.c:287
#36 0x0000000000418854 in _start ()

Possible duplicates by query: bug 350559, bug 345833.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2017-01-07 12:49:36 UTC

*** This bug has been marked as a duplicate of bug 319776 ***