Bug 350559 - IMAP resource crash after wake-from-sleep
Summary: IMAP resource crash after wake-from-sleep
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.13
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-07-23 17:08 UTC by RJVB
Modified: 2017-01-07 12:50 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RJVB 2015-07-23 17:08:41 UTC
Application: akonadi_imap_resource (4.13)
KDE Platform Version: 4.14.7 (Compiled from sources)
Qt Version: 4.8.7
Operating System: Linux 3.14.46-ck1-mainline-amdf10-rjvb x86_64
Distribution: Ubuntu 14.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I woke the computer from sleep, unlocked the KDE wallet when requested, and then connected to the preferred WiFi hotspot (for some reason, the system connects to the weaker of my 2 WiFi networks first, half the time).

-- Backtrace:
Application: RJVB@mw of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4e41f087c0 (LWP 4502))]

Thread 4 (Thread 0x7f4e2d051700 (LWP 4595)):
#0  0x00007f4e3bf4561a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f4e3bf45979 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4e3bf03699 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4e3bf03f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4e3bf040ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4e412a128e in QEventDispatcherGlib::processEvents (this=0x7f4e280008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f4e4126c66f in QEventLoop::processEvents (this=this@entry=0x7f4e2d050e20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4e4126c9b5 in QEventLoop::exec (this=this@entry=0x7f4e2d050e20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4e41150a8d in QThread::exec (this=<optimized out>) at thread/qthread.cpp:538
#9  0x00007f4e41153803 in QThreadPrivate::start (arg=0x2407330) at thread/qthread_unix.cpp:352
#10 0x00007f4e3c82d182 in start_thread (arg=0x7f4e2d051700) at pthread_create.c:312
#11 0x00007f4e3d40847d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f4e25e00700 (LWP 7703)):
#0  0x00007f4e3c8307ee in __pthread_mutex_unlock_usercnt (decr=1, mutex=0x7f4e14005320) at pthread_mutex_unlock.c:57
#1  __GI___pthread_mutex_unlock (mutex=0x7f4e14005320) at pthread_mutex_unlock.c:310
#2  0x00007f4e3bf459b1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4e3bf03a59 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4e3bf03f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4e3bf040ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f4e412a128e in QEventDispatcherGlib::processEvents (this=0x7f4e140053e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#7  0x00007f4e4126c66f in QEventLoop::processEvents (this=this@entry=0x7f4e25dffe20, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f4e4126c9b5 in QEventLoop::exec (this=this@entry=0x7f4e25dffe20, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f4e41150a8d in QThread::exec (this=<optimized out>) at thread/qthread.cpp:538
#10 0x00007f4e41153803 in QThreadPrivate::start (arg=0x2398350) at thread/qthread_unix.cpp:352
#11 0x00007f4e3c82d182 in start_thread (arg=0x7f4e25e00700) at pthread_create.c:312
#12 0x00007f4e3d40847d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f4e24dfe700 (LWP 25026)):
#0  0x00007f4e3bf4561d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f4e3bf45979 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4e3bf03557 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4e3bf03f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4e3bf040ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f4e412a128e in QEventDispatcherGlib::processEvents (this=0x7f4e0c011d60, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f4e4126c66f in QEventLoop::processEvents (this=this@entry=0x7f4e24dfde20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4e4126c9b5 in QEventLoop::exec (this=this@entry=0x7f4e24dfde20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4e41150a8d in QThread::exec (this=<optimized out>) at thread/qthread.cpp:538
#9  0x00007f4e41153803 in QThreadPrivate::start (arg=0x2418f50) at thread/qthread_unix.cpp:352
#10 0x00007f4e3c82d182 in start_thread (arg=0x7f4e24dfe700) at pthread_create.c:312
#11 0x00007f4e3d40847d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f4e41f087c0 (LWP 4502)):
[KCrash Handler]
#6  indexOfMethodRelative<4> (normalizeStringData=<optimized out>, method=<optimized out>, baseObject=0x7ffeb48688b0) at kernel/qmetaobject.cpp:524
#7  QMetaObjectPrivate::indexOfSignalRelative (baseObject=baseObject@entry=0x7ffeb48688b0, signal=signal@entry=0x240ada9 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", normalizeStringData=normalizeStringData@entry=false) at kernel/qmetaobject.cpp:628
#8  0x00007f4e41283a84 in QObject::disconnect (sender=0x25477c0, signal=0x240ada9 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=0x23ee460, method=0x2362d59 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2986
#9  0x000000000046c01c in SessionPool::killSession (this=0x23ee460, session=0x25477c0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:181
#10 0x000000000046ba04 in SessionPool::disconnect (this=0x23ee460, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:115
#11 0x000000000041b827 in ImapResource::startConnect (this=0x2549460) at ../../../resources/imap/imapresource.cpp:302
#12 0x0000000000443188 in ImapResource::qt_static_metacall (_o=_o@entry=0x2549460, _c=<optimized out>, _id=<optimized out>, _a=_a@entry=0x7ffeb4868b60) at ./moc_imapresource.cpp:117
#13 0x00007f4e41276ca4 in QMetaMethod::invoke (this=this@entry=0x7ffeb4868cc0, object=object@entry=0x2549460, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#14 0x00007f4e412791c8 in QMetaObject::invokeMethod (obj=0x2549460, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#15 0x00007f4e419d9539 in invokeMethod (obj=<optimized out>, member=<optimized out>, aData=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=..., obj=<optimized out>, member=<optimized out>, val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at /usr/include/qt4/QtCore/qobjectdefs.h:433
#16 Akonadi::ResourceScheduler::executeNext (this=0x23e48d0) at ../../akonadi/resourcescheduler.cpp:348
#17 0x00007f4e419db951 in Akonadi::ResourceScheduler::qt_static_metacall (_o=0x23e48d0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./moc_resourcescheduler_p.cpp:101
#18 0x00007f4e41289e79 in QObject::event (this=0x23e48d0, e=<optimized out>) at kernel/qobject.cpp:1222
#19 0x00007f4e4064240c in QApplicationPrivate::notify_helper (this=0x219adc0, receiver=0x23e48d0, e=0x23e7990) at kernel/qapplication.cpp:4570
#20 0x00007f4e406488fb in QApplication::notify (this=0x7ffeb48698c0, receiver=0x240ada9, e=0x23e7990) at kernel/qapplication.cpp:4356
#21 0x00007f4e3e4a3307 in KApplication::notify (this=0x7ffeb48698c0, receiver=0x23e48d0, event=0x23e7990) at ../../kdeui/kernel/kapplication.cpp:321
#22 0x00007f4e4126dc4c in QCoreApplication::notifyInternal (this=0x7ffeb48698c0, receiver=receiver@entry=0x23e48d0, event=event@entry=0x23e7990) at kernel/qcoreapplication.cpp:955
#23 0x00007f4e41271ab7 in sendEvent (event=0x23e7990, receiver=0x23e48d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, receiver@entry=0x7f4e412a10e0 <postEventSourceDispatch(GSource*, GSourceFunc, gpointer)>, event_type=event_type@entry=0, data=0x2150e30) at kernel/qcoreapplication.cpp:1579
#25 0x00007f4e41271e67 in QCoreApplication::sendPostedEvents (receiver=0x7f4e412a10e0 <postEventSourceDispatch(GSource*, GSourceFunc, gpointer)>, receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1472
#26 0x00007f4e412a10f3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#27 postEventSourceDispatch (s=0x21824d0) at kernel/qeventdispatcher_glib.cpp:287
#28 0x00007f4e3bf03e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f4e3bf04048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f4e3bf040ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f4e412a126f in QEventDispatcherGlib::processEvents (this=0x2152310, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#32 0x00007f4e406e4da6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f4e4126c66f in QEventLoop::processEvents (this=this@entry=0x7ffeb4869850, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f4e4126c9b5 in QEventLoop::exec (this=this@entry=0x7ffeb4869850, flags=...) at kernel/qeventloop.cpp:204
#35 0x00007f4e41272b29 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1227
#36 0x00007f4e419cdac3 in Akonadi::ResourceBase::init (r=0x2549460) at ../../akonadi/resourcebase.cpp:556
#37 0x0000000000421077 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:192
#38 0x00007f4e3d32fec5 in __libc_start_main (main=0x420540 <main(int, char**)>, argc=3, argv=0x7ffeb48699d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffeb48699c8) at libc-start.c:287
#39 0x0000000000417c9c in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 316105.

Possible duplicates by query: bug 316105, bug 308602, bug 307658.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2017-01-07 12:50:30 UTC

*** This bug has been marked as a duplicate of bug 319776 ***