Bug 35795 - Menu bars give bad appearance to all KDE applications
Summary: Menu bars give bad appearance to all KDE applications
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: unspecified
Platform: RedHat Enterprise Linux Linux
: NOR normal with 223 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 125394 238624 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-12-05 11:48 UTC by maarizwan
Modified: 2012-09-08 21:32 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maarizwan 2001-12-05 11:42:26 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kdelibs
Version:           unknown (using KDE 2.2.2 -1)
Severity:          wishlist
Installed from:    Red Hat Linux 7.2
Compiler:          gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)
OS:                Linux (i686) release 2.4.3-12
OS/Compiler notes: 

not just appearance but also usability trouble.

1. Open any app say konqueror
2. you can see the 2 toolbars 'location' and 'standard toolbar'
3. you can also see the menubar
4. the toolbars look nice but the menubar doesn't look consistent with toolbars.
5. especially the 'slider' is missing for menubar which would ease all application developers to write an individual hide-menubar function
6. now if you horizontall minimize the window by dragging on right or left
7. you can see the toolbar get nicely adjusted 
8. But the menubar looks very ugly since all menu items are displayed.
9. if menubar would behave like the toolbar the window will look much better.

Please make menubar behave like toolbar.

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 Casey Allen Shobe 2003-08-09 00:57:17 UTC
Well, this includes my request.  I have been missing the ability since KDE v1 days.   
I've been praying and hoping somebody would put it back, yet still it's gone.   
Windows (Office and IE, anyways) allows you to move the menubar about  
anywhere you like, the top, the bottom, left, right, and it's great!  KDE v1 lacked the  
left/right ability, but it was still something.  Personally, I only really care about the  
bottom, which is where I prefer to place my menubar.  
  
Plus, in addition to being able to move it, you'd be able to make it occupy the same  
row as a slimmed-down menubar.  You see this configuration in IE/Explorer often,  
and there's a reason!  It's efficient, saves screenspace, and lets you put the  
menubar wherever you like.  And I don't really see how the menubar is that much  
different, from say, the bookmarks toolbar with only text menus shown, except that it  
has hotkeys.  
  
  
And also...in regards to numbers 6-8, this ought also to be a preference.   
Obviously, some like the "more options" button that the toolbars feature.  Personally,  
I prefer the wrapping myself.  There should be one setting, for both.  They're just not  
consistant.  
  
Also, the more options or whatever it's called button is buggy. 
 
1.  It overlaps the frame of the toolbar on the right, but the frames of the menubar or 
other toolbars still show.  This is with the default KDE nonhighcolor style. 
2.  I have it on my bookmarks toolbar right now...when I click the more button, it 
shows the remaining icons, but does not indicate whether the items are menus are 
not, as i.e. IE (no pun intended) would show with little arrow icons to the right. 
3.  When I click on an icon in that menu that I know is a menu, the menu for it 
appears in midair, whilst the original menu disappears.  So I'm left with a floating 
child menu with no parent.  That's odd. 
4.  The button always shows on my location toolbar.  It always has, unless I make 
my window at least 1400 or so pixels wide.  I use the location toolbar because the 
Open Location dialog doesn't share the history...grr, so it would be nice if I didn't 
have that annoying button covering up the down arrow on the dropdown (which I 
workaround by turning on the silly go button that nobody in their right mind uses 
(but I'm glad it's an option), so it covers up that instead).  This has happened on my 
location bar on every machine I've used (all linux, but different distributions, 
compiles, cpu architectures) since somewhere in KDE2.x. 
 
That's all.  I just want the UI that I have to deal with in *every* KDE program to be 
the best part, not a constant annoyance. 
Comment 2 Thomas Schildknecht 2007-03-08 14:23:36 UTC
One of the menu related feature I particulary like in some KDE apps is the ability to hide it. It's particulary useful for some applications who don't have a bunch of options and features (think about Amarok, Konversation, Kopete... once all is set, just a few icons should be sufficient to use the apps). I also like that Amarok create an icon with a popup menu containing the menubar items when the menubar is hidden.

(note that some applications like Akregator, Kaffeine or KMail could have a "hide menu" feature too)
Comment 3 Andrea Bravetti 2007-03-08 14:45:56 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Stefan Monov 2007-03-08 14:47:00 UTC
*** Bug 125394 has been marked as a duplicate of this bug. ***
Comment 5 Shinobu Maehara 2008-01-20 07:48:11 UTC
I also prefer wrapping, perhaps even for toolbars. As for the menubars in IE and Office, these aren't really menubars at all - they're toolbars without icons. Standard Windows menubars suffer from the same problem as KDE's, so Windows is not as far ahead as was suggested.
Comment 6 Christoph Feck 2010-05-24 07:57:33 UTC
*** Bug 238624 has been marked as a duplicate of this bug. ***
Comment 7 Jakob Lehmann 2010-05-24 21:30:11 UTC
(In reply to comment #6)
> *** Bug 238624 has been marked as a duplicate of this bug. ***

Well my report was a bit different, but I accept it as a duplicate, this is my original post:

The KDE Human Interface Guideline (HIG) declare, that a menubar is mandatory
for every single application, quotes:

"Provide a menubar in every application main window"
"Don't make the menubar 'hideable', users may not easily be able to make the
menubar viewable again"

This has grown to be a problem, since application developers tend to get away
from menubars and as such - violate the KDE HIG.
Applications that in their current state violate this part of the HIG are for
example rekonq, konsole, kget, the systemsettings and palapeli to name a few.

There are valid reasons to replace the menubar how it looks today with
something more useable, more visually appealing and less space wasting.

But first of all let us see, what is good about the menubar:

- provides an easy way to access every functionality of a program
- accessibility features (press alt+*key*)
- menubars are also present in Microsoft Windows, Mac OS X, GNOME etc.

So what is bad about the menubar?

- wastes vertical space, which is a problem on smaller screens and annoying on
bigger screens
- menubars are flat, thus they are not usable on touchscreen devices
- doesnt look appealing
- uses deprecated labels like "file" (quassel has a "file" entry with the
entries "networks -> join network" and "quit", where is there a file involved?)
- text only which makes it hard to use for people who have trouble reading (for
example disabled people), also this makes it harder to find what you are
looking for since you dont have self explanatory icons

What could be done to improve/replace the menubar?

The menubar should be merged with the right side of the toolbar, entries should
be reordered and renamed, in general there should be less entries (for example
there could be an entry "actions" with basic actions such as "save" "open"
"print" and "find", "help" doesnt need to be an own entry). Menubar entries
should have icons. It should be configurable in system settings whether icons,
text or both should be shown, this should also apply to the toolbar.

Problems with that:

- some applications do not have toolbars (I just know one: Konsole)
- needs work, a template needs to be written and applications need to be
changed
- KDE would be the first one to fully replace the menubar, breaking same look
and feel as other desktop enviroments

Why this would still be better:

- saves space for applications
- makes it work on touchscreen devices
- would look better
- increased accessibility
- less confusing to find the right function
- more modern look and feel
- would stop violation of the HIG

I hope you see the opportunities that are open for KDE, to be a pioneer in this
issue.
Please note that this should be considered a draft, it needs further discussion
and tweaks, maybe a completely different solution will be found in the end.

I will attach a poorly done mockup of this concept.
Thanks for reading :-)
Comment 8 Martin Koller 2012-09-08 21:32:00 UTC
In KDE4 (tested in 4.9.1) the menubar and toolbars behave in the same way: when no more space is available, they add a small arrow and hide what does not fit.
So the original bugreport is solved.