Bug 238624 - menubar section of KDE's HIG needs rethinking
Summary: menubar section of KDE's HIG needs rethinking
Status: RESOLVED DUPLICATE of bug 35795
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources All
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-23 23:52 UTC by Jakob Lehmann
Modified: 2010-05-24 07:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
digikam how it looks today (550.04 KB, image/png)
2010-05-23 23:53 UTC, Jakob Lehmann
Details
digikam how it could look after the redesign (poorly done mockup) (539.55 KB, image/png)
2010-05-23 23:54 UTC, Jakob Lehmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jakob Lehmann 2010-05-23 23:52:48 UTC
Version:           unspecified (using Devel) 
OS:                All

The KDE Human Interface Guideline (HIG) declare, that a menubar is mandatory for every single application, quotes:

"Provide a menubar in every application main window"
"Don't make the menubar 'hideable', users may not easily be able to make the menubar viewable again"

This has grown to be a problem, since application developers tend to get away from menubars and as such - violate the KDE HIG.
Applications that in their current state violate this part of the HIG are for example rekonq, konsole, kget, the systemsettings and palapeli to name a few.

There are valid reasons to replace the menubar how it looks today with something more useable, more visually appealing and less space wasting.

But first of all let us see, what is good about the menubar:

- provides an easy way to access every functionality of a program
- accessibility features (press alt+*key*)
- menubars are also present in Microsoft Windows, Mac OS X, GNOME etc.

So what is bad about the menubar?

- wastes vertical space, which is a problem on smaller screens and annoying on bigger screens
- menubars are flat, thus they are not usable on touchscreen devices
- doesnt look appealing
- uses deprecated labels like "file" (quassel has a "file" entry with the entries "networks -> join network" and "quit", where is there a file involved?)
- text only which makes it hard to use for people who have trouble reading (for example disabled people), also this makes it harder to find what you are looking for since you dont have self explanatory icons

What could be done to improve/replace the menubar?

The menubar should be merged with the right side of the toolbar, entries should be reordered and renamed, in general there should be less entries (for example there could be an entry "actions" with basic actions such as "save" "open" "print" and "find", "help" doesnt need to be an own entry). Menubar entries should have icons. It should be configurable in system settings whether icons, text or both should be shown, this should also apply to the toolbar.

Problems with that:

- some applications do not have toolbars (I just know one: Konsole)
- needs work, a template needs to be written and applications need to be changed
- KDE would be the first one to fully replace the menubar, breaking same look and feel as other desktop enviroments

Why this would still be better:

- saves space for applications
- makes it work on touchscreen devices
- would look better
- increased accessibility
- less confusing to find the right function
- more modern look and feel
- would stop violation of the HIG

I hope you see the opportunities that are open for KDE, to be a pioneer in this issue.
Please note that this should be considered a draft, it needs further discussion and tweaks, maybe a completely different solution will be found in the end.

I will attach a poorly done mockup of this concept.
Thanks for reading :-)

Reproducible: Always
Comment 1 Jakob Lehmann 2010-05-23 23:53:59 UTC
Created attachment 43828 [details]
digikam how it looks today
Comment 2 Jakob Lehmann 2010-05-23 23:54:46 UTC
Created attachment 43829 [details]
digikam how it could look after the redesign (poorly done mockup)
Comment 3 Jakob Lehmann 2010-05-23 23:56:27 UTC
(In reply to comment #2)
> Created an attachment (id=43829) [details]
> digikam how it could look after the redesign (poorly done mockup)

Note that the yellow rectangles in the upper right corner are supposed to be menubuttons.
Comment 4 Christoph Feck 2010-05-24 07:57:33 UTC
This looks like a duplicate of bug 35795 or bug 84800.

If anything is missing there, please add to the respective bug number.

*** This bug has been marked as a duplicate of bug 35795 ***